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Smart Development Environment 4.0 User's Guide 

The software and documentation are furnished under the Smart Development Environment license agreement and may be used 
only in accordance with the terms of the agreement. 

Copyright Information  
Copyright © 1999-2007 by Visual Paradigm. All rights reserved. 

The material made available by Visual Paradigm in this document is protected under the laws and various international laws 
and treaties. No portion of this document or the material contained on it may be reproduced in any form or by any means 
without prior written permission from Visual Paradigm. 

Every effort has been made to ensure the accuracy of this document. However, Visual Paradigm makes no warranties with 
respect to this documentation and disclaims any implied warranties of merchantability and fitness for a particular purpose. The 
information in this document is subject to change without notice. 

All examples with names, company names, or companies that appear in this document are imaginary and do not refer to, or 
portray, in name or substance, any actual names, companies, entities, or institutions. Any resemblance to any real person, 
company, entity, or institution is purely coincidental. 

Trademark Information  

Smart Development Environment is registered trademark of Visual Paradigm. 
Sun, Sun ONE, Java, Java2, J2EE and EJB, NetBeans are all registered trademarks of Sun Microsystems, Inc. 
Eclipse is registered trademark of Eclipse. 
JBuilder is registered trademark of Borland Corporation. 
IntelliJ and IntelliJ IDEA are registered trademarks of JetBrains. 
Microsoft, Windows, Windows NT, Visio, and the Windows logo are trademarks or registered trademarks of Microsoft 
Corporation.  
Oracle is a registered trademark, and JDeveloper is a trademark or registered trademark of Oracle Corporation. 
BEA is registered trademarks of BEA Systems, Inc.  
BEA WebLogic Workshop is trademark of BEA Systems, Inc. 
Rational Rose is registered trademark of International Business Machines Corporation. 
WinZip is a registered trademark of WinZip Computing, Inc. 
Other trademarks or service marks referenced herein are property of their respective owners. 

Smart Development Environment License Agreement 

THE USE OF THE SOFTWARE LICENSED TO YOU IS SUBJECT TO THE TERMS AND CONDITIONS OF THIS 
SOFTWARE LICENSE AGREEMENT. BY INSTALLING, COPYING, OR OTHERWISE USING THE SOFTWARE, YOU 
ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTAND IT, AND AGREE TO BE BOUNDED 
BY ALL OF THE TERMS AND CONDITIONS OF THIS SOFTWARE LICENSE AGREEMENT. 

1. Limited License Grant. Visual Paradigm grants to you ("the Licensee") a personal, non-exclusive, non-transferable, 
limited, perpetual, revocable license to install and use Visual Paradigm Products ("the Software" or "the Product"). 
The Licensee must not re-distribute the Software in whole or in part, either separately or included with a product.  

2. Restrictions. The Software is confidential copyrighted information of Visual Paradigm, and Visual Paradigm and/or 
its licensors retain title to all copies. The Licensee shall not modify, adapt, decompile, disassemble, decrypt, extract, 
or otherwise reverse engineer the Software. Software may not be leased, rented, transferred, distributed, assigned, or 
sublicensed, in whole or in part. The Software contains valuable trade secrets. The Licensee promises not to extract 
any information or concepts from it as part of an effort to compete with the licensor, nor to assist anyone else in such 
an effort. The Licensee agrees not to remove, modify, delete or destroy any proprietary right notices of Visual 
Paradigm and its licensors, including copyright notices, in the Software.  

3. Disclaimer of Warranty. The software and documentation are provided "AS IS," WITH NO WARRANTIES 
WHATSOEVER. ALL EXPRESS OR IMPLIED REPRESENTATIONS AND WARRANTIES, INCLUDING ANY 
IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE OR 
NON-INFRINGEMENT, ARE HEREBY EXCLUDED. THE ENTIRE RISK AS TO SATISFACTORY QUALITY, 
PERFORMANCE, ACCURACY AND EFFORT IS WITH THE LICENSEE. THERE IS NO WARRANTY THE 
DOCUMENTATION, Visual Paradigms EFFORTS OR THE LICENSED SOFTWARE WILL FULFILL ANY OF 
LICENSEES PARTICULAR PURPOSES OR NEEDS. IF THESE WARRANTIES ARE UNENFORCEABLE 
UNDER APPLICABLE LAW, THEN Visual Paradigm DISCLAIMS SUCH WARRANTIES TO THE MAXIMUM 
EXTENT PERMITTED BY SUCH APPLICABLE LAW.  

4. Limitation of Liability.  Visual Paradigm AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY 
DAMAGES SUFFERED BY THE LICENSEE OR ANY THIRD PARTY AS A RESULT OF USING OR 
DISTRIBUTING SOFTWARE. IN NO EVENT WILL Visual Paradigm OR ITS LICENSORS BE LIABLE FOR 
ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, EXEMPLARY, SPECIAL, 
CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF 
THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, 
EVEN IF Visual Paradigm HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  
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5. Termination.  The Licensee may terminate this License at any time by destroying all copies of Software. Visual 
Paradigm will not be obligated to refund any License Fees, if any, paid by the Licensee for such termination. This 
License will terminate immediately without notice from Visual Paradigm if the Licensee fails to comply with any 
provision of this License. Upon such termination, the Licensee must destroy all copies of the Software. Visual 
Paradigm reserves all rights to terminate this License.  

SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES.  The SOFTWARE is not designed or intended for use in high-
risk activities including, without restricting the generality of the foregoing, on-line control of aircraft, air traffic, aircraft 
navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Visual 
Paradigm disclaims any express or implied warranty of fitness for such purposes or any other purposes. 

NOTICE.  The Product is not intended for personal, family or household use; rather, it is intended exclusively for professional 
use. Its utilization requires skills that differ from those needed to use consumer software products such as word processing or 
spreadsheet software. 

GOVERNMENT RIGHTS.  If the Software is licensed by or on behalf of a unit or agency of any government, the Licensee 
agrees that the Software is "commercial computer software", "commercial computer software documentation" or similar terms 
and that, in the absence of a written agreement to the contrary, the Licensees rights with respect to the Software are limited by 
the terms of this Agreement. 

Acknowledgements 
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Part 1 - Working with Smart Development 
Environment 

Welcome to Smart Development Environment, a powerful visual UML plug-in for your IDE. SDE, short for Smart 
Development Environment, is an award winning UML modeling plugin seamlessly integrated with most of the leading IDEs in 
the market such as Microsoft Visual Studio .NET, Eclipse, Borland JBuilder, NetBeans/Sun ONE, IntelliJ IDEA, Oracle 
JDeveloper, and BEA WebLogic Workshop. 

This part explains in detail how to use SDE to perform UML modeling and code-model round-trip engineering with your IDE, 
such that you can develop your application in a faster better and cheaper way. 

In this part: 

• Getting Started with SDE fo Java 
• Working with Diagrams 
• Style and Formatting 
• Visual Modeling 
• Automatic Diagrams Layout 
• Generating Documentation 
• Export and Import 
• User Interface Designer 
• Instant Reverse 
• Instant Generator 
• Java Round Trip Engineering 
• State Machine Diagram Code Generation 
• Team Collaboration with VPTS 
• Team Collaboration with CVS 
• Team Collaboration with Subversion 
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Chapter 1 - Getting Started with SDE for Eclipse 

Aside from a collection of menus, tool-bars and windows that make up the development workspace, one special feature is our 
Resource-centric interface, which lets the user access modeling tools easily without referring back and forth from the 
workspace to various toolbars. Incorporating shortcuts such as mouse gestures into our modeling tools allow our users to draw 
as with a pen and paper, executing complicated modifications with just a click and drag, creating a completely visual 
environment. 

 

This chapter will describe how to get started with Smart Development Environment for Eclipse. You will learn following 
techniques in this chapter: 

• How to Launch Smart Development Environment for Eclipse? 
• What is Workspace? 
• Importing License Key 
• Working with Floating License Server 
• Basic Environment 
• Dockable User Interface 
• Browse your work by trees and tables 
• Basic diagram editing functionalities 

Launching SDE for Eclipse 

SDE for Eclipse can run in different operating systems. 

Windows 

To launch SDE for Eclipse in Windows: 
Select start > All Programs > Visual Paradigm > SDE for Eclipse. 

 
Figure 1.1 - Launch SDE for Eclipse in Windows 
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Linux 

To launch SDE for Eclipse in Linux: 
Select SDE_for_Eclipse icon on the desktop. 

 
Figure 1.3 - Launch SDE for Eclipse in Linux 
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Managing License Key and Edition 

All VP products need a license key to activate. A License key of a higher edition can be used on a lower edition. For example, 
you can run Standard Edition of SDE for Eclipse with Professional Edition of SDE for Eclipse key. 
SDE for Eclipse also provides a 30-days evaluation key for trial. After the evaluation key expires, you can choose to purchase 
the full license from our website or resellers, or un-install the program. 

The license key for Community Edition will not expire. However, Community Edition cannot be used for commercial purposes. 

Importing a Single Seat License Key 

A Visual Paradigm's Single Seat (developer based) license allows a licensee to install the software on more than one machine, 
such as desktop and notebook, which belong to the licensee only. As the license is developer based, the software must be used 
by the licensee only, without running more for than one instance concurrently. 

To import a single seat License Key: 
1. You should first open the License Key Manager. There are two ways of opening License Key Manager:  

•  If there are no valid license keys imported, the License Key Manager will show up for importing license key. 

•  Select from the main menu Modeling > Key Manager... 

 
 Figure 1.7 - Select Key Manager 
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Figure 1.8 - License Key Manager 

 

 Name  Function  

 

Import license 
key  

To import a license key. 

 

Delete the 
license key 

To delete the license key imported. 

 
Request Key 

To request a 30 days evaluation key if you are not using the Community Edition. If you are using the 
Community Edition, it will request an activation key. Both keys will be sent to you by email. 

 
Help  

To show the Help. If no Help has been installed before, the Download Help dialog box will appear to 
enable downloading and installation of Help.  

Table 1.1  

 

2. Then, you can either select License Keys > Import... or press on the Import License Key button on the toolbar. This 
displays the Import License Key dialog box.  
From the File field, enter the file path of license key. You can enter the path in the text field directly, or you can click on the ... 
button to browse for license key file. Click OK . 

 
Figure 1.9 - Import License Key dialog 
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3. The imported key is then displayed in the Key Manager. 

Figure 1.10 - The imported key displayed in Key Manager 

Then, click Close from the License Key Manager to start using SDE for Eclipse. 

Switching from Evaluation Key to Permanent Key 

You can try SDE for Eclipse by using an evaluation key for 30 days. Then, you will need to buy a permanent key if you want 
to continue to use it. After purchasing, you should follow the steps below to switch your evaluation key to a permanent one. 
To switch from evaluation key to permanent key: 
1. Open the License Key Manager from the main menu Modeling > Key Manager....  

 
Figure 1.11 - License Key Manager with evaluation key with expiry date 

 
2.  Remove the evaluation key by clicking the Delete the license key button in License Key Manager dialog. You can also 
remove the key by clicking License Keys > Remove. If your key has expired, you have to check the Expired Keys to show 
your expired evaluation key in order to delete.  

 
Figure 1.12 - Delete by clicking Delete the license key button 

 
If your key has not expired, Delete License Key dialog will appear and ask if you really want to remove the key. Click Yes to 
confirm. 

 
Figure 1.13 - Confirm deleting license key 
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3. Click Import license Key to import the permanent key. You can also select License Keys > Import...  to import the key. 

 
Figure 1.14 - Import by clicking Import license key button 

 
4.Select or type a path for the permanent key in Import License Key dialog. Click OK  to confirm. 

 
Figure 1.15 - Select or type a path for permanent key 

 
5. Permanent key imported. Unlike an evaluation key, the permanent key does not have expiry date. 

 
Figure 1.16 - Permanent Key with no expiry date 

Importing Upgrade Keys 

 
From time to time, VP releases new versions. If your license keys are covered by the maintenance period, the latest version will 
be available to you without any payment. You can login to the Customer Service Center (https://cs.visual-paradigm.com) to 
download the latest version and get an upgrade key. The upgrade key should be used with the original license key, i.e. the 
original key should neither have been delete or expired. 
After you have installed the latest version and downloaded the upgrade key, follow the steps below to import upgrade keys to 
use that version. Here, a license key of version 4.0 is used as an example to replace the key of version 3.1. 
 
To import upgrade keys: 
1. Open the License Key Manager from the main menu Modeling > Key Manager... 

 
Figure 1.17 - License Key Manager with license key of version 3.1 
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2. Click Import license Key to import the upgrade key. You can also select License Keys > Import...  to import the key. 
Remember the old key must still exist before you import the upgrade key. 

 
Figure 1.18 - Import by clicking Import license key button 
 
3. Select or type a path for the upgrade key in Import License Key dialog. Click OK  to confirm. 

 
Figure 1.19 - Select or type a path for upgrade key 

 
4. The upgrade key has replaced your old one. 

 
Figure 1.20 - License Key Manager with license key of version 4.0 
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Floating License Key 

VP Floating License allows you to deliver development software to every user in your organization without paying for unique 
licenses for every developer.When you use a floating license, the entire organization can access to SDE for Eclipse but the 
number of people that use VP at the same time is limited to the number of license keys you buy.  

By using a floating license, you can reduce the cost of buying licenses, as you just need to purchase enough number of licenses 
that will run VP at the same time, instead of buying licenses for all developers in your organization. 

The installation of floating license server and the configuration of client pointing to the server is a simple process. Our license 
server can be run on multiple platforms and can be installed in less than 10 minutes. 

The license sharing process is automatic, which is convenient to use. VP Floating License automatically manages and shares 
the licenses through the network. When the client connects to the license server, the server will assign him a license until the 
license limit has been reached. Once it disconnects from the server, the license will be released automatically and the other user 
can start using VP with that license. 

This kind of key is particularly useful for organizations which have limited access to VP at a certain time each time, e.g. a 
company has ten staff but only two staff will use SDE for Eclipse at the same time. The the company can then purchase just 
two floating license keys but the whole company will be able to use SDE for Eclipse at different times. 

Before you use SDE for Eclipse with a floating license key, your machine need to access to the license server via LAN to 
acquire a license key first. For more details, you can refer to the Floating License Server Installation Guide about floating 
license server installation for more details. 

Configuring Floating License Server 
To configure floating license server: 
1. Open the License Key Manager. 
2. Select License Keys > Floating License > Configure... . 

 
Figure 1.21 - Select configuration of floating license 

 

3. Input the host and port. You can refer to Floating License Server User's Guide for more details. 

 
Figure 1.22 - Configuration dialog box 
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Exporting Floating License Key 
To use a Floating License key, you need to have Local Area Network (LAN) access to the *Floating License Server*. You may 
choose to export one of the floating license keys to your laptop if you need to use it out of the office (e.g. a meeting with a 
client). If you export a floating license key the number of floating licenses in the server will decrease. This will be reverted 
when you import the licence key back to the server from your laptop. 
 
To export floating license key: 
1. Select License Keys > Floating License > Export Floating License... . 

 
 Figure 1.23 - Export the Floating License 

 
2. Floating license key is exported from server. 

 
Figure 1.24 - Floating license exported 

 

Importing Floating License Key 
When you finish using the exported license key, you can import the key back to the server. 
 
To import floating license key: 
1. Select License Keys > Floating License > Import Floating License... . The Import Floating License Key dialog is 
displayed. 

 
Figure 1.25 - Import Floating License 

 
 



SDE User’s Guide (Part 1)  Chapter 1 – Getting Started with SDE fo Java 

 

1-11 

2. Select the key you want to import and click OK  to confirm. 

 
Figure 1.26 - Select license key to import 

 
3.The key is imported successfully. 

 
Figure 1.27 - License key imported successfully 

 
 
If you did not import the exported key to the server when you switch off SDE for Eclipse, the next time you switch on SDE for 
Eclipse, it will ask if you want to import it to the server. 

 
Figure 1.28 - Asking whether to import the license key 
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Switching Edition 

There is a single installer for all editions. You can install any edition with the same installer. If you want to change your 
installed edition, you can either re-install the software or use the VP Suite Product Edition Manager as long as you have a valid 
key for that edition to run.  

When evaluating SDE for Eclipse, you can ensure the features you want and are most likely to use are available in different 
editions. 

 
1. Select start > All Programs > Visual Paradigm > VP Suite Product Edition Manager  . 

Figure 1.29- Select Product Edition Manager 
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2. Select the desired edition in the edition manager. 

 
Figure 1.30 - Select desired edition 

Auto Switch Edition 

When you start SDE for Eclipse of an edition other than the edition you have a license key for, the Switch Edition dialog will 
appear and ask whether you want to switch to the other edition. 

For example, if you have imported a Standard Edition license key, when you run the Enterprise Edition, SDE for Eclipse will 
ask you if you want to switch to Standard Edition. 

 

 
Figure 1.31 - Switch Edition dialog  

 

You may click Yes to switch to a lower edition, or No to display the License Key Manager dialog to import another key. 
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VP Suite Product Selector 

Product selector is for a flexible license scheme, and is only for users using a floating license key.  
The selector is flexible so that you can view the license keys available in the floating license server and start a product with the 
selected key. 

To start the Product Selector: 

Select Product Selector from 'bin' folder in the directory where VP Suite is installed. 

 
Figure 1.32 - Bin folder 
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Figure 1.33 - Product Selector 

 

  Name Function  

 
Product Name of products available. 

 
Start To start the selected product. 

 
Available/Total 

The number of products in the server available. This is a fraction that the number of product available 
over the total product purchase. 

 
Select Server  To select floating license server(s). 

 
Refresh Server  To refresh a floating license server(s). 

Table 1.2  
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Basic Environment 

In this section, you will learn the basic environment of the SDE for Eclipse user interface, and get to know how to use it to 
perform modeling more efficiently. 
After you have imported the license key, you will see the SDE for Eclipse main screen. 

 
Figure 1.34 - Basic environment 

 Name Description  

 
Menu  All the commands for execution. 

 
Toolbar  Frequently used commands. 

 
Diagram pane Area where you create your diagram. 

 
Message pane Display messages that are generated by performed operations. 

Table 1.3  
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Panes 

SDE for Eclipse provides various panes for performing different tasks and for displaying the modeling project in different 
views. 

Modeling Perspective 

SDE for Eclipse provides different views, however, not all the views will be shown on the Eclipse's "Java" or "Resources" 
perspective automatically. Therefore, SDE for Eclipse provides Modeling Perspective to show all the views. 
To switch to Modeling Perspective. Select Windows > Open Perspective > Modeling. Modeling may not shown on the menu, 
then you may need to select Other... and select Modeling on the dialog. 

 
  
 
If you want to show SDE for Eclipse's view on other perspective. Select Windows > Show View > Other.... Then select SDE 
for Eclipse. You can select the view you wanna to be shown. 
 
Note that if SDE for Eclipse is starting and current perspective is not Modeling Perspective. SDE for Eclipse will ask you 
switch to Modeling Perspective. 
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Diagram Navigator Pane 

The Diagram Navigator Pane displays diagrams and their diagram elements in the project, which are categorized by diagram 
type.  
To open this pane: 

• Select Windows > Show View > Diagram Navigator 

 

Figure 1.41 - Diagram Navigator Pane 
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Model Pane 

The Model Pane displays models in the project. 
To open this pane: 

• Select Windows > Show View > Model 

 

Figure 1.42 - Model Pane 
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Class Repository Pane 

The Class Repository Pane displays packages and class models in the project. 
To open this pane: 

• Select Windows > Show View > Class Repository  

 

Figure 1.43 - Class Repository Pane 
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Logical View Pane 

Logical View Pane displays logical view of the project that can be customized to the desired structure. 
To open this pane: 

• Select Windows > Show View > Logical View 

 

Figure 1.44 - Logical View Pane 
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ORM Pane 

ORM Pane displays ORM-related views including classes and database configurations. 
To open this pane: 

• Select Windows > Show View > ORM  

 

Figure 1.45 - ORM Pane 

Stencil Pane 

Stencil Pane displays stencils that can be used to create custom shapes. You can also organize and select stencils here. 
To open this pane: 

• Select Windows > Show View > Stencil 

 

 

Figure 1.46 - Stencil Pane 
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Property Pane 

Property Pane displays the properties of the selected element(s). You can also edit the properties here. 
To open this pane: 

• Select Windows > Show View > Property 

 

Figure 1.47 - Property Pane 

Diagram Overview Pane 

This pane displays the overview of the active diagram which is scaled to fit the display area. The rectangle represents the 
visible area of diagram. You can navigate to different parts of the diagram by dragging the display area. 
To open this pane: 

• Select Windows > Show View > Diagram Overview 

 

 

Figure 1.48 - Diagram Overview Pane 
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Documentation Pane 

Documentation Pane can display documentation of the selected element. SDE for Eclipse also provides rich text documentation. 
You can edit your documentation directly here. 
To open this pane: 

• Select Windows > Show View > Documentation 

 

Figure 1.49 - Documentation Pane 

Message Pane 

Message Pane displays information, warning and error messages shown by SDE for Eclipse. 
To open this pane: 

• Select Windows > Show View > Message 

 

Figure 1.50 - Message Pane showing XMI Results 
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Open Specification Dialog Box  

The open specification dialog box is a top-level window which enables you to browse for and edit the detail of model elements 
or diagrams. It can be invoked by right-clicking on either a model or a diagram and selecting Open Specification... from the 
popup menu. 

  

Figure 1.56 - Open Actor Specification Figure 1.57 - Open Diagram Specification 
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Figure 1.58 - Actor Specification 

The open specification dialog box contains several pages which show different aspects of the selected item. General 
information such as name, stereotype, documentation, files are included in most of the model elements. For some of the model 
elements, relationship between other model elements (children, relations) and information that is specific to the model elements. 
(attributes/operations in Class, sub-diagrams of Package) will be displayed as well. 
There are five buttons at the bottom of the dialog box: Reset, OK , Cancel, Apply  and Help. 

Button Description  

Reset  Reset the changes made in the dialog box. 

OK  Accept the changes and close the dialog box. 

Cancel  Cancel and close the dialog box. 

Apply  Apply the changes immediately without closing the dialog box. 

Help  Display the help information of the Open Specification dialog box. 

Table 1.4  
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Navigating between Model Elements  

You can navigate to other model elements via the open specification dialog box. This can be done in two ways. For model 
elements with a one-to-many relationship such as relations, children, you can invoke the open specification dialog box of a 
selected model elements by clicking on the Open Specification... button. 

 

Figure 1.59 - Open Association Specification 
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Some of the properties of the model element are references to another model element (or a reference to itself) such as 
Supplier/Client of a Dependency, or Role A/Role B of an Association. In this case you can click on the ... button besides this 
property to navigate to that model element. 

 

Figure 1.60 - Association Specification 

Note that if the open specification dialog box of the referenced model element is already opened, this button will be disabled. 



 

Working with Diagrams 2 
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Chapter 2 - Working with Diagrams 

SDE for Eclipse is a visual modeling tool that provides all well-known modeling toolsets to cover all aspects of modeling and 
documentation, from business process modeling to detailed system specification. SDE for Eclipse supports more than 20 
diagram types including all diagram types in UML, BPMN, SysML, ERD, DFD and more. Visual Paradigm strives to 
continuously enhance the diagramming environment to increase effectiveness and efficiency of modeling, as when using SDE 
for Eclipse, most of your working time is with diagrams. 

 

  In this chapter you will learn: 

• Creating Diagram 
• Creating Diagram Elements and connecting them 
• Basic Diagram editing 
• Different Copy and Paste strategies 
• Grouping Diagram Elements for easier management 
• Some diagramming techniques 

 
Figure 2.1 - Diagram pane 
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Creating Diagram 

You can create diagrams in different ways: 

• Using toolbar 
• Using popup menu of Diagram Navigator 

To use toolbar to create: 
Click on the icon on the toolbar and select the diagram you want to create from the dialog box. 

 
Figure 2.2 - New Class Diagram icon on the toolbar 
 

 
Figure 2.3 - Select New SDE EE-EC Diagram 
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To use the popup menu of Diagram Navigator to create: 
Right click on the diagram type node in Diagram Navigator and select New Class Diagram in popup menu. 

 
Figure 2.4 - Select New Class Diagram from popup menu of Diagram Navigator 

Creating Diagram Elements 

After creating a new diagram, you can create diagram elements using the diagram toolbar. In this section, we will introduce the 
techniques of how to create diagram elements and connectors: 

• Creating Shapes  
• Creating Connectors  
• Creating Self-Connection 

Creating Shapes 

To create a shape, click on a diagram element button from the diagram toolbar and click on the diagram pane to create it. The 
element generated will have a default size. 

 

Figure 2.5 - Click to Create Shapes 
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You can also drag a specific boundary before releasing the mouse to define a shape's initial size. 

 
Figure 2.6 - Create Shapes with specific size 

 

Alternatively, you can also create a diagram element by dragging a diagram element button then dropping it on the diagram 
pane. 

 
Figure 2.7 - Drag and drop to Create Shapes 

 

Apart from that, you can use the diagram popup menu to add a shape. 

 
Figure 2.8 - Create Shapes using diagram popup menu 



SDE User’s Guide (Part 1)  Chapter 2 – Working with Diagrams 

 

2-6 

Creating Connectors 

To create a connector, select the desired connector from the diagram toolbar and click on the source shape. Drag the connector 
to the destination shape. 

SDE for Eclipse provides continuous UML syntax checking. You will see a stop sign when you try to create an invalid 
connection, e.g. you cannot create a generalization relationship between an actor and a use case. 

 

Figure 2.9 - Try to create an invalid connection 

If the connection is valid you will see a blue rounded rectangle surrounding the destination shape. 

 

Figure 2.10 - Try to create a valid connection 

 

You may also use resource to create connectors. 
Click on the Association resource of a shape and drag over the shape you want to connect to. If you release the mouse on an 
empty space, a shape will be created with the connector. 

 
 

Figure 2.11 - Click on resource Figure 2.12 - Drag over the shape 

Creating Self-Connection 

Some of the shapes can have a connection to itself, for example Self-Association of a Class or Self-Link of an Object in a 
Communication Diagram. To create a self-connection, click on the connector button on the diagram toolbar and click once on 
the target object. 

Alternatively, you can click on the Self Association resource. 

  

Figure 2.13 - Create Self-Connection Figure 2.14 - Self-Connection 
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Resource-Centric Interface 

Visual Paradigm is the first vendor to introduce the resource centric diagramming interface. The resource centric interface 
greatly improves the efficiency of modeling. You no longer needs to go back and forth between the toolbar and the diagram to 
create diagram elements, make connections and modify the diagrams. The resource centric interface can make sure the modeler 
is able to create a diagram with correct syntax more quickly. 
There are three types of resource: 

• Connection Resource 
• Manipulation Resource 
• Branching Resource 

Connection Resource 

It is designed for creating elements and making connections. Here, the connection between an actor and a use case is used as an 
example. 
To use Connection Resource: 
1. Move mouse over Association - > Use Case resource. 

 
Figure 2.15 - Association - > Use Case resource 
 

2. Drag resource to empty space on diagram pane. 

 
Figure 2.16 - Drag resource 

 

3. Release the mouse, new connector and shape are created. 

 
Figure 2.17 - Connector and shape created 
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Manipulation Resource 

You can use Manipulation Resource to modify properties or appearance of elements. For example, you can show or hide 
compartments, add references, add sub-diagram and fit size. 
To use Manipulation Resource, simply click once on it. 

 
Figure 2.18 - Reference of Manipulation Resource 

Branching Resource 

Branching Resource helps you to create decision structure in diagram. 
To use branching resource: 
1. Move mouse over a Branching Resource. 

 
Figure 2.19 - Branching Resource 
 

2. Drag resource to empty space on diagram. 

 
Figure 2.20 - Drag resource 
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3. Release mouse, a branch is created. 

 
Figure 2.21 - Create branch 

 

Alternatively, if a shape in the branch already exists, you can drag the resource over it. 

 
Figure 2.22 - Drag resource over existed shape 
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When mouse is released, a branch is created involving the target shape. 

 
Figure 2.23 - Create branch 

 

 

Enabling/Disabling the Resource-Centric Interface 

To enable/disable the resource centric interface feature, select/deselect menu Format > Resource Centric. This option will be 
applied to all diagrams. 

 
Figure 2.24 - Enable/Disable Resource Centric 

Interface 
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Enabling/Disabling Group Resource-Centric Interface 

Group resources appear when two or more shapes are selected. They are used to perform actions on the selected shapes, e.g. 
alignment and distribute shapes. 
To enable/disable, select/deselect Modeling > Application Options... to open the Options dialog box, select Diagramming > 
Resource Centric tab. This option will be applied to all diagrams. 

 
Figure 2.25 - Group Resources Centric Interface for use case 
 

Show Extra Resources 

By default the resource centric interface displays the most commonly used resources of a diagram element. You can choose to 
view less common resourcesby clicking on the Format > Show Extra Resources in the main menu. The figures below show 
the view of a Action element with "Show Extra Resources" turned off and on. 

 
 

Figure 2.26 - Resource-Centric of Action Figure 2.27 - Action with an Extra Resource-Centric 

 

Show Generic Resource-Only 

Generic Resource is a special kind of resource in the Resource-Centric Interface. Unlike other resources, the type of the 
connector and/or shape type that will be created is undetermined, you will be asked for the desired connector/shape type when 
the creation is confirmed. 
To show/not to show Generic Resource Only, select Modeling > Application Options... to open the Options dialog box, select 
Diagramming > Resource Centric tab. 

 

 
Figure 2.28- Show Generic Resources-Only 
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Basic Editing 

Multiple Selection 

Multiple selection can be made with mouse alone or with keyboard and mouse. 
With mouse alone: 
Click on an empty space of the diagram and drag to include desired shapes in the dashed-line rectangle. 

 
Figure 2.29 - Multiple selection using mouse 

 

With keyboard and mouse: 
With the Shift or Ctrl  key held down, click on the shapes to select them. After selecting a shape, you may click it again to 
deselect it. 

 
Figure 2.30 - Multiple selection using mouse and keyboard 
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Moving Shape 

SDE for Eclipse diagram editor supports true WYSIWYG diagram editing. You can move shapes with the mouse or keyboard. 
 
With mouse: 
Click on a shape to drag it to the desired direction to move it. 

  

Figure 2.31 - Shape before moving to the right Figure 2.32 - Shape after moving to the right 
 

With keyboard: 
1. Select shape(s) which you want to move. 
2. Press the up/down/left/right  arrow key to move the shape(s). 

Moving Shape in One Direction 

Instead of moving shapes in any direction, you may restrict the shapes to move in one direction only for easier alignment, i.e. 
you may move the shapes vertically or horizontally, but not diagonally. 
This can be done by pressing Shift key while dragging the shapes.  

 
Figure 2.33 - Restrict moving direction 

 

Delete 

The main difference between CASE Tool and drawing tools is that CASE Tool has a Model and View concept. The model is 
where information is stored, while the view is a presentation of the model. A model can have multiple views, for example, you 
can show the same class in different class diagrams. Upon pressing 'delete', SDE for Eclipse will assume you are deleting the 
view of the model, but will prompt you to delete the model if all views of a specific model are deleted. This section will show 
you how to delete models and views. 
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Delete 

To delete view together with model: 
1. perform one of the following action: 

• Select Delete > Delete in the popup menu of that element. 
• Press the Delete button on the keyboard. 

 
Figure 2.34 - Select Delete 

 
2. A Delete dialog box will display and ask you if you want to delete. Click Yes to confirm. If you want to set this option as 
default, check Use this option as default and don't ask again. 

 
Figure 2.35 - Delete dialog box for confirming deleting 
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3. If there is no referenced view other than deleted view, the Delete dialog will ask you if you want to delete the model from 
the repository. Click Yes to confirm. If you delete more than one diagram element at one time, you may click Yes to all to 
confirm. 

 
Figure 2.36 - Confirm deleting from the repository 

 

Delete View Only 

To delete view(diagram element of model) only: 
1. Select Delete > Delete View Only in the popup menu of that element. 

 
Figure 2.37 - Select Delete View Only 
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2. A Delete dialog box will display and ask you if you want to delete. Click Yes to confirm. If you want to set this option as 
default, check Use this option as default and don't ask again. 

 
Figure 2.38 - Delete dialog box to confirm deleting 

 

Copy and Paste 

Copy 

SDE for Eclipse support various copy and paste options. By default your copy will only within SDE for Eclipse and will not 
affect the content in your system clipboard. If you want to copy the content to other application, you can copy to clipboard as 
image then you can paste your design to other application. This section, we will show you different copy and pasts options 
SDE for Eclipse provides. 

Copy within SDE-EC 
Copying diagram elements within SDE-EC allows you to copy selected diagram elements to the application clipboard. You can 
paste the diagram elements to other SDE-EC diagrams from the current project or across another project.  

 
You cannot paste the selected content to other applications. 

To copy selected diagram elements within SDE-EC, perform one of the following actions: 

• Select Edit > Copy from main menu.  
• Right-click on the selected diagram elements and choose Copy > Copy within SDE EE-EC from popup menu.  
• Press Ctrl-C. 

Copy within SDE-EC is the default copy action. For more details about the default copy action, please reference to the section 
"Setting Default Copy Action" below. 

Copying to the Clipboard as Image (JPG) 

 
Copying diagram elements as JPG image will copy the selected diagram element as a JPG image to the system clipboard, 
which you can copy to other applications.  

To copy selected diagram elements to the system clipboard as JPG image, perform one of the following actions: 

• Select Edit > Copy to Clipboard as Image (JPG) from main menu.  

• Click on the Copy drop down button on the toolbar and select Copy to Clipboard as Image (JPG) from the drop 
down menu. 

• Right-click on the selection and choose Copy > Copy to Clipboard as Image (JPG) from popup menu.  
• Press Ctrl-Alt-C.  
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Copying to the Clipboard as Image (EMF) 

 
Copying diagram elements as EMF (Enhanced Metafile) image will copy the selected diagram element as an EMF image to the 
system clipboard, which you can copy to other applications. Unlike copy as JPG image, the copied content is in EMF format, 
which is a more scalable format where image quality can be retained even after being resized/zoomed. 

 
The copy to system clipboard as EMF image feature is available on Windows platforms only. 

To copy selected diagram elements to the system clipboard as EMF image, perform one of the following actions: 

• Select Edit > Copy to Clipboard as Image (EMF) from main menu.  

• Click on the Copy drop down button on the toolbar and select Copy to Clipboard as Image (EMF) from the drop 
down menu. 

• Right-click on the selection and choose Copy > Copy to Clipboard as Image (EMF) from popup menu.  
• Press Ctrl-Alt-Shift-C. 

Setting Default Copy Action 
The default copy is triggered when the hotkey Ctrl + C is pressed. The actual action performed by default copy follows the 
SDE for Eclipse application option (as configured in the Options dialog box -> Diagramming category -> Environment page). 
The default copy action can be set to one of the following: 

• Copying within SDE-EC  
• Copying to Clipboard as OLE 
• Copying to Clipboard as Image (JPG)  
• Copying to Clipboard as Image (EMF) 

Paste 

You can select different paste methods according to what you have copied. 

Pasting View 
The pasted diagram elements share the same content of the copied diagram elements. Any changes made on the pasted 
elements will result in the same changes appearing on the elements copied, as the model elements are shared on the diagram 
elements. 

To paste diagram element with model sharing, perform one of the following actions: 

• Select Edit > Paste from main menu.  

• Right-click on the target diagram and choose Paste View from popup menu. 
• Press Ctrl-V  

Pasting Model 
It clones a copy of the copied diagram elements and the model element, then pastes them to the diagram. It is enabled to copy 
within SDE-EC. 

To paste diagram element without model sharing, perform one of the following actions: 

• Right-click on the target diagram and choose Paste Model from popup menu. 
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Pasting as Image Shape 
With image shape, you can easily annotate and document your diagrams with related images. Instead of creating an image 
shape manually, you can copy an image from any application to the clipboard and then paste it to the diagram as a new shape. 

 

Figure 2.39 - Paste as Image Shape 

To paste an image shape, perform one of the following actions: 

• Select Edit > Paste from main menu.  

• Right-click on the target diagram and choose Paste View from popup menu. 
• Press Ctrl-V 

Undo/Redo 

When you create and edit a diagram, you may make mistakes like accidentally deleting a diagram element. You can use the 
Undo function to cancel the previous action. On the other hand, you may re-perform the action using the Redo action. The 
undo/redo feature in SDE for Eclipse is diagram based. 

Undo 

You can roll back undesirable changes by performing Undo. To undo an action, perform one of the following actions: 

• Select Edit > Undo from main menu.  
• Press Ctrl-Z.  

Redo 

This feature is to re-perform actions that were just undone. To redo an action, perform one of the following actions: 

• Select Edit > Redo from main menu.  
• Press Ctrl-Y.  
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Grouping 

After you have applied alignment to a group of shapes, you may want to keep its configuration and not want them to get 
messed up. Grouping feature is designed for this usage. After shapes are grouped, you can treat the grouped shapes as a single 
shape. 
In SDE for Eclipse, you can perform multiple level grouping - that is, group a shape with other shapes, and even with other 
groups. 

Grouping Shapes 

To group shapes, select shapes in the diagram and perform one of the following actions: 

• Select menu Edit > Group . 
• Right-click on the selection and select Grouping > Group from the popup menu.  

Ungrouping Shapes 

To ungroup shapes, select the grouped shapes in the diagram and perform one of the following actions: 

• Select menu Edit > Ungroup. 
• Right-click on the selection and select Grouping > Ungroup from the popup menu. 
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Resizing Shapes in Group 

In some cases, you may want to resize multiple shapes on the diagram, SDE for Eclipse allows you to resize the shapes in a 
group, which in turn reduces the handling time for resizing the shapes individually. When you resize one shape of the selected 
shapes, all the selected shapes will resize by the same amount, regardless of their original sizes. 
To resize the shapes in a group: 

1. Select multiple desired shapes on the diagram. 

 

 

Figure 2.40 - Multiple desired shapes on diagram 
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2. Resize one of the selected shapes. All selected shapes will resize proportionally. 

 

Figure 2.41 - Resize one of the selected shapes. All selected shapes will resize proportionally 

 
If the size of the resizing shape returns to its original shapes before resizing, all selected shapes will not 
resize accordingly 
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Reversing Connector Direction 

Reverse Connector can be used to reverse the direction of connector. 

Here, the direction of connector between Shipper and FAS Online System is inverted. 

 
Figure 2.42 - Before reversing Connector Direction 

 

To reverse the connector, right-click on the connector and select Reverse Connector from the popup menu. 

 
Figure 2.43 - Select Reverse Connector 

  

The direction of connector is now inverted.  

 
Figure 2.44 - After reversing Connector Direction 
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Grid 

Showing/Hiding Grids 

To toggle the visibility of grid lines, perform one of the following actions: 

• Check/Uncheck Format > Show Grid from main menu to show/hide grid lines. 

 
Figure 2.45 - Select Grid 
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• Right-click on the target diagram, check/uncheck Grid > Grid Visible  from popup menu to show/hide grid lines. 

 
Figure 2.46 - Select Grid Visible 

• From the property table, check/uncheck Visible under Grid  heading to show/hide grid lines. 

 
Figure 2.47 - Check Visible 
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• Right-click on the target diagram and choose Open Specification from popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab and check/uncheck Grid Visible  to 
show/hide grid lines. 

 
Figure 2.48 - Check Grid visible 
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Snap to Grid 

This feature is used to set whether diagram elements should stick to grid lines when moving in the diagram. To turn the option 
on/off, perform one of the following actions: 

• Check/Uncheck Format > Snap to Grid from main menu to turn on/off the snap to grid option. 

 
Figure 2.49 - Select Snap to Grid 
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• Right-click on the target diagram, check/uncheck Grid > Snap to Grid from popup menu to turn on/off the snap to 
grid option. 

 
Figure 2.50 - Select Snap to Grid using popup menu 

• From the property table, check/uncheck Snap to Grid under Grid  heading to turn on/off the snap to grid option. 

 
Figure 2.51 - Select Snap to grid 
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• Right-click on the target diagram and choose Open Specification from popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab and check/uncheck Snap to Grid to turn 
on/off the snap to grid option. 

 
Figure 2.52 - Check Snap to grid in Specification 

Grid Size 

To adjust the grid size, perform one of the following actions: 

• From the property table, enter the value for Width and Height property under Grid  heading. 

 
Figure 2.53 - Adjust grid size in property table 



SDE User’s Guide (Part 1)  Chapter 2 – Working with Diagrams 

 

2-29 

• Right-click on the target diagram and choose Open Specification from popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab and enter the value for Width and Height. 

 
Figure 2.54- Adjust grid size in specification 
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Grid Color 

To adjust the grid color, perform one of the following actions: 

• Right-click on the target diagram and select Grid > Grid Color... from the popup menu. This displays the Select Grid 
Color dialog box for setting the grid color. 

 
Figure 2.55 - Select Grid Color 

• From the property table, click the ... button in the Value column of Color property under Grid  heading. This displays 
a color chooser for selecting a grid color 

 
Figure 2.56- Select Color 
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• Right-click on the target diagram and choose Open Specification from the popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab, click on the button ...from the Grid Color 
field and select the grid color from the drop-down color chooser. 

 
Figure 2.57- Select Grid Color 

 
The grids must be visible before setting the grid color. 

Zooming 

Zooming In 

The zoom in feature allows you to get a close-up view of the diagram. To perform zoom in, perform one of the following 
actions: 

• Select Format > Zoom > Zoom in from main menu.  

• Click on the Zoom In button on the toolbar.  
• Right-click on the target diagram and choose Zoom > Zoom In from the popup menu. 
• Press Ctrl-= (Ctrl-Equals). 
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Zooming Out 

The zoom out feature allows you to see more of the diagram at a reduced size. To perform zoom out, perform one of the 
following actions: 

• Select Format > Zoom > Zoom Out from main menu.  

• Click on the Zoom Out button on toolbar.  
• Right-click on the target diagram and choose Zoom > Zoom Out from popup menu. 
• Press Ctrl-- (Ctrl-Minus). 

Zooming to 100% 

The zoom to 100% feature allows you to view the diagram in its actual size (100%). To restore the zoom ratio to 100%, 
perform one of the following actions: 

• Select Format > Zoom > Zoom 100% from main menu.  

• Click on the Zoom 100% button on toolbar.  
• Right-click on the target diagram and choose Zoom > Zoom 100% from popup menu.  
• Press Ctrl-0. 

Zooming to a Specific Ratio 

The zoom to a specific ratio feature allows you to choose the zooming ratio from the main menu. To perform zoom to a 
specific ratio, perform one of the following actions: 

• Select Format > Zoom > Zoom Selection on the main menu, select a zoom ratio from the menu. 

 

Figure 2.58 - Select zoom ratio 

• Right-click on the target diagram and choose Open Specification from the popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, select a zoom ratio from the Zoom ratio drop down menu, or enter the 
specific zoom ratio to the field. 

• From the property table, select a zoom ratio from the drop down menu on the row Zoom ratio, or enter the specific 
zoom ratio to the field. 
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Zooming to Fit Diagram to Window 

Beside standard zoom in/out and zoom to ratio, there are dynamic zoom options that allow you to zoom the diagram to fit its 
content to the window. 
Select Format > Zoom > Zoom Selection on the main menu (or click on the Zoom ratio combo box in the Property pane 
when a diagram is active), you will see the Page, Width  and Height zoom items. 

• Page - Zoom the whole diagram to fit to window 
• Width  - Zoom the width of the diagram to fit to window 
• Height - Zoom the height of the diagram to fit to window 

 

Figure 2.59 - Select zoom ratio to fit with page 

Just select the zoom item to apply the corresponding zoom option. 
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Figure 2.60 - Zoom to show all the Page 

Zooming to Region 

The zoom to region feature allows you to zoom the diagram to any selected region. 

1. To zoom a diagram to region, click on the Zoom to Region button on the toolbar. 

 

Figure 2.61 - Zoom to region 
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2. Press the mouse on the diagram, hold and drag the desired zoom region (just like multi-select shapes). The region is 
indicated by the dotted-line rectangle. 

 

Figure 2.62 - Select the zoom region in the diagram 

3. Release the mouse button and you will see the diagram is zoomed to the desired region.  

 

Figure 2.63 - Zoom to the Region 
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Quick Previewer 

SDE for Eclipse provides a quick previewer in Diagram Navigator tree. You can preview the diagram before open the diagram. 

 

Figure 2.64 - Quick Previewer 

To preview a diagram, move the mouse cursor over a Diagram node on Diagram Navigator. This displays the Quick Previewer. 
To open the diagram, click the button on the toolbar. 
To resize the Quick Previewer window: 

1. Move the cursor to the bottom right-hand corner of the Quick Previewer window. The cursor changes to "" , 
indicating that you can resize the window. 

2. Press on it.  
3. Drag to resize the window.  
4. Releases the mouse press until you are satisfied with the size of Quick Previewer.  

Apart from preview image, Quick Previewer also shows the documentation of diagrams. To display the documentation of a 
diagram, Click the button on the toolbar of the previewer and choose Documentation. 

 

Figure 2.65 - Preview documentation 

SDE for Eclipse records the size and position of the previewer and restores this when displaying again. To reset this record, 
double-click the toolbar of the previewer window. 
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Generic Connector  

A generic connector allows you to connect any shapes, so it can represent the idea beyond the standard UML notation.You can 
edit the connector using resource. 

To edit an arrow head of a connector using Format Arrow Head  resource: 

1. Click on the Format Arrow Head  resource. The Format Arrow Head resource which is nearer to one end of line controls 
the arrow head at that end. 

 
Figure 2.66 - Resources for Format Arrow Head 

 

2. Select a format of arrow head in the popup menu. 

 
Figure 2.67 - Edit arrow head of generic connector 
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To edit the line style of a connector using the Format Line resource: 

1. Click on the Format Line resource (located in the middle of the connector). 

 
Figure 2.68 - Resources for Format Arrow Head 

 

2. Select a style of line using the Style combo box in the Format Line dialog box. 

 
Figure 2.69 - Select format of generic connector 
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You can also apply your favorite connectors. There are two methods: 

You can right click on the connector and select Format from popup menu and select Favorite Connectors > Apply Favorite 
Connectors.... 

 

 
Figure 2.70 - Select Apply Favorite Connectors 

Alternatively, you can click on the Format Line resource and select Apply Favorite Connector.... 

 
Figure 2.71 - Select Apply Favorite Connectors 
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Then, select your favorite connector to apply it. 

 
Figure 2.72 - Save your favorite connectors 

 

Apart from apply, you can organize your favorite connectors: 

1. Right click on the connector and select Format from the popup menu. 

2. Select Favorite Connectors > Organize Favorite Connectors. 

 
Figure 2.73 - Select Organize Favorite Connectors 
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3. You can choose to Create..., Duplicate..., Edit... or Remove any connectors. 

 
Figure 2.74 - Organize Favorite Connectors 

 

Text Box 

A Text Box allows you to add free text to a diagram. 

To add text using Text Box: 

1. Click on the Text Box in the toolbar. 

2. Click on the diagram pane where you want to add text. 

3. Add text in the box provided. 

 

 
Figure 2.75 - Add a free text 
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Diagram Info Shape 

Diagram Info Shape allows you to add useful information to a diagram. 
To use Diagram Info Shape: 
1. Right-click on the blank area of the diagram and select Add Shape > Diagram Info Shape from the popup menu. 

 
Figure 2.76 - Select Diagram Info Shape from popup menu 

 
2. The diagram info shape will be added to the diagram. 

 
Figure 2.77 - Diagram info shape is added 

By default, there are 2 items provided in the diagram info shape table:  
The Name cell follows the diagram name.  
The Documentation cell follows the diagram documentation. 
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To add a new item: 
1. Right-click on the diagram info shape, select Add Item from the pop-up menu. A new row will be created. 

 
Figure 2.78 - Select Add Item 

 
2. Type in the newly added item and the information in the new row. You can add as many new items as needed. 

 
Figure 2.79 - New item added 
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The diagram info shape is added. 

 
Figure 2.80 - Diagram info shape added 

 

Rich Text Documentation 

In SDE for Eclipse, you can add rich text documentation on different models and diagrams. The styles and formats of the 
documentation can be included when you generate a document. 

Rich text documentation can also be used in: 

• Notes 

 
Figure 2.81 - Note with rich text documentation 
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• Textboxes 

 
Figure 2.82 - Text box with rich text documentation 

 

To add rich text documentation: 
1. Right click the diagram element and select Open Specification from popup menu. 

 
Figure 2.83 - Select Open Specification 

 

2. Specify the documentation. 

 
Figure 2.84 - Specify the documentation 
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You can then switch to the Documentation pane to preview. 

 
Figure 2.85 - Documentation pane 

 

You can also see the result in the report generated. 

 
Figure 2.86 - Documentation generated 

Inserting Image to Documentation 

You can further visualize your concept by incorporating images into documentation. 
1. Select an element in the diagram. 

 
Figure 2.87 - Select a diagram element 
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2. Place the text cursor in the Documentation pane to locate where you want to insert the image, and then click the Insert 
image... button on the documentation toolbar (if this button is hidden, click the double-arrow button to expand the toolbar).  

 
Figure 2.88 - Select Insert Image... 

 

3. Select one or more images to insert. 

 
Figure 2.89 - Choose one or more images 
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4. The image(s) will be inserted to the documentation.  

 
Figure 2.90 - Image added 

 

Using Template 

By using template, you can reuse pre-defined documentation structures to save time and effort. 

To save documentation as template: 

 1. Open the specification dialog box of a model.  

 
Figure 2.91 - Select Open Specification 

 

2. After editing the documentation, click the Save as template... button on the documentation toolbar.  

  
 Figure 2.92 - Save the template 
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3. Specify the template name and click OK  to save the template. 

 
Figure 2.93 - Specify the template name 
  

To load documentation from a template: 
1. Open the specification dialog box of a model. Click the template drop-down button on the documentation toolbar to select a 
saved template.  

 
Figure 2.94 - Select a saved template 

 

2. The template content is loaded. Even if you edit the documentation of the model, the template will still remain the same. 

 
Figure 2.95 - A template is loaded 
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Compartment Visibility Control 

SDE for Eclipse provides a visibility control in class diagram. It allows you to hide or show the attributes or operation using 
the resource-centric of a class. 
To show the attributes compartment or operations compartment click the " " sign button in resource-centric. To hide the 
attributes or operation click the ""sign button in resource-centric. 
You can also use popup menu to change visibility. 

 

 

Figure 2.96 - Compartment Visibility Control 

 

When you reverse the code into class diagram(s) the attributes and operations are visible by default. The 
compartment visibility control is useful when you want to hide the attributes or operations in one click 
(saves time from choosing the presentation option in the popup menu).  
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Printing Diagrams 

 

Print Preview 

The Print Preview dialog box allows you to preview the printout and provides a set of options for changing the printout style. 
To display the dialog box, perform one of the following actions: 

• Select File > Print SDE-EC Diagrams... from main menu  

• Click on the Print  button on the toolbar  

 

Figure 2.97 - Print preview dialog 

The toolbar of the print preview pane allows you to configure the print settings. The buttons and their descriptions are shown in 
the table below: 

Icon  Button  Function  

 Print  Print the diagram(s). The Print dialog box will be opened. 

 Quick Print  
Print diagrams without previewing them. The Quick Print dialog will be 
opened. 

 Page Setup  Set up the page properties such as paper size and orientation. 

 Adjust Margins  Adjust the margins of the pages. 

 Use Gradient Color  
Select to use gradient color in printout. Since printing gradient color will 
use up lots of memory, it is recommended to turn this option off for better 
performance. 

 
Zoom  Select the percentage to reduce/enlarge the print preview of diagrams. 

/  
Paper Base 
Layout/Diagram 
Base Layout 

If the Fit to Pages option is selected, and there are multiple pages in the 
printout, selecting Paper Base Layout will cause the distribution of pages 
to be paper-oriented (the diagram size is ignored in arranging the preview); 
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while selecting Diagram Base Layout will cause the distribution of pages 
to be diagram-oriented. Note that this option affects the preview only; the 
order of the printout remains unchanged. 

/  Paper Place Style  

To change the order of the printout. A large diagram is divided into many 
pages, selecting From left to right  will arrange the printout order from the 
pages on the left to the pages on the right, while selecting From top to 
bottom will arrange the print order from the pages on the top to the pages 
on the bottom.  

 
Fit to Ratio  Set the diagram size to fit to the specified ratio. 

 
Fit to Pages  Set the diagram to be printed on the number of pages specified. 

 
Overlapping  Set the percentage of the margins to overlap among adjacent pages. 

 
Show/Hide Clip 
Marks on Page  

Select/deselect to show/hide the clip marks on the printout. 

 Edit Header/Footer  Edit the header and the footer of the printout. 

 Multiple Page Mode Switch to the Multiple Page Mode to set the multiple page options. 

 Help  Calling the SDE-EC help file  

 Close Print Preview  Close the print preview pane and return to the design area. 

Table 2.1 
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Printing a Diagram with Preview 

You can use the Print command to select the printer. Set the range of pages and number of copies to be printed. 

1. Select the desired diagrams for printing. The selected diagrams will be shown at the preview area.  

 

Figure 2.98 - Diagram Preview 
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2. Click on the Print  button  on the Print Preview Toolbar. The Print  dialog box appears.  

 

Figure 2.99 - Print the Diagram 

3. Select the printer to use, the page range and the number of copies to be printed. You may click on the 
Properties...button to configure the printer-specific properties as well.  

4. Click OK  to start printing.  
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Page Setup 
Page Setup allows the user to specify the page size, orientation as well as the margins of the pages. 

 

Figure 2.100 - Page setup 

1. Click on the Page Setup button  on the toolbar. The Page Setup dialog box appears.  
2. You can click on the Size drop-down menu to select the paper size to use.  
3. You can select the orientation for the page(s) to be printed (either Portrait  or Landscape) in the Orientation  field.  
4. You can enter the value into the Left , Right, Top and Bottom text fields to adjust the size of the corresponding 

margin.  
5. Click OK  to confirm the settings.  
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Adjusting Margins 
The Margins pane allows user to specify the margins of the pages, header and footer. 

 

Figure 2.101 - Adjusting Margins 

1. Click on the Adjust Margins  button  on the Toolbar. The preview area shows the margin setting page.  
2. You can edit the margins sizes by entering the sizes into the text fields. Alternatively, click on the spinner buttons to 

increase/decrease the margin sizes.  

3. Click the Finish Adjust Margin  button  when you have finished configuring the margin settings. The margin sizes 
will then be updated.  
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Zooming Pages 
Diagrams can be zoomed in or zoomed out according to user preference. 
Click on the Zoom drop-down menu to select the desired zoom ratio. 

 

Figure 2.102- Set the Zoom ratio 

The preview area will show the diagrams in the zoom ratio that you have selected. 

 

Figure 2.103 - Preview in the preview dialog 
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Selecting the Preview Layout 
There are two layouts that you can select for the print preview, the Paper Base Layout and the Diagram Base Layout. 
If the Fit to Pages option is selected and there are multiple pages in the printout, selecting Paper Base Layout will cause the 
distribution of pages to be paper-oriented (the diagram size is ignored in arranging the preview); while selecting Diagram Base 
Layout will cause the distribution of pages to be diagram-oriented. 
Note that this option affects the preview only; the order of the printout remains unchanged 

To select a layout of the preview, click on the Paper Base Layout button  or Diagram Base Layout button  on the 
toolbar.  A popup menu will appear where you can select the layout to use. 
The preview after applying the Paper Base Layout: 

 

Figure 2.104 - Preview in paper Base Layout 
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The preview after applying the Diagram Base Layout: 

 

Figure 2.105 - Preview in Diagram Base Layout 
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Setting Paper Place Style 
You can select the paper place style to change the order of the printout. To select the paper place style, click on the Paper 
Place Style button on the toolbar. A popup menu appears where you can select a paper place style. 
Consider a large diagram is divided into many pages, selecting 'From left to right ' will arrange the printout order from the 
pages on the left to the pages on the right, while selecting 'From top to bottom' will arrange the print order from the pages on 
the top to the pages on the bottom 
The order of the printout after selecting From left to right . 

 

Figure 2.106 - Printout order is left to right 
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Fit to Ratio  
Fit to Ratio is used to resize the diagrams in the printout to a specific ratio. 
Click on the Fit to  drop-down menu and select Ratio. 
You can enter the ratio into the textbox, e.g. enter 150 to set the ratio to 150%. After you have edited the ratio, the diagrams in 
the printout will be resized to the new ratio. 

 

Figure 2.107 - Fit to ratio 

Fit to Pages 
Fit to Pages is used to split the diagram to a desired number of pages when printing. 

1. Click on the Fit  to drop-down menu and select Pages.  

2. Click on the Multiple Pages button  on the toolbar. The page selector appears.  

 

Figure 2.108 - Select multiple pages Page 

3.  
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4. Click on the row-column combination to select it (note that you can click and drag on the page selector to extend the 
selection). The diagram will be split into multiple pages by the rows and columns that you have selected.  

Figure 2.109 - Fit to page 

Setting the Diagram Overlap Percentage 
Overlapping is used when users want the diagrams to have overlapping at the boundaries between pages. This is particularly 
useful when you have a large diagram that span multiple pages and you want to stick the pages of the printout together; the 
overlapping area can then be used as a hint when sticking the pages. 

 

Figure 2.110- Multiple page without overlap 

1. Click on the Overlapping textbox to input the overlapping percentage and press the Enter key.  
2. The printing area near the boundaries of the pages will be duplicated by the overlapping percentage inputted.  
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Figure 2.111 - Multiple page with overlap 

 

Printing with Frame/Border Option 
You can print your diagram with a frame or border. There are three options: 

• With frame 
• With border 
• No border 

Select With frame/ With border/No border option from the drop-down menu. 

 
Figure 2.112 - Select option from drop-down menu 
 
Output of printing with frame 

 
Figure 2.113 - Printing with frame 
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Output of printing with border 

 
Figure 2.114 - Printing with border 

 
Output of printing with no border 

 
Figure 2.115 - Printing with no border 
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Showing/Hiding Clip Marks on Page 
Clip marks act as an indication of the boundary of a page. 

 

Figure 2.116 - Clip marks 

To show clip marks on the printout click on the Show Clip Marks on Page button . You will see the boundaries of the 

pages are surrounded by clip marks. To hide the clip marks click on the Hide Clip Marks on Page button  again. 

Editing Header/Footer of the Pages 

To edit the header/footer of the printout click on the Edit Header/Footer button  on the toolbar. You will then switch to the 
edit header/footer pane. 

 

Figure 2.117 - Editing Header/Footer of the Pages 

You can edit the header and the footer in the Header panel and the Footer panel respectively. Each of the panel consists of the 
Left Section, Center Section and the Right Section, which represents the position that the content will be located in the 
header/footer. 
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There is a toolbar between the Header panel and the Footer panel, which facilitates the editing of header/footer. The 
description of the buttons in the toolbar can be found in the following table: 

Icon Name  Description  

 Select Font  
Select the font to use for the selected section. Note that you must click on the section once in order 
to select it  

 Insert Page Number  Insert the page number 

 
Insert Number of 
Page  

Insert the total number of pages  

 Insert Date  Insert the date that the printing starts  

 Insert Time  Insert the time that the printing starts  

 Insert File Name  Insert the file name of the SDE-EC project  

 Insert Project Name  Insert the name of the SDE-EC project  

 Insert Diagram Name Insert the diagram name  

Table 2.2 

After you have finished editing the header/footer, click on the Close Edit Header/Footer button  to switch to the print 
preview mode. A sample page that has the header and footer formatted is shown in the picture below: 

 

Figure 2.118 - Page with header and footer 
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The Multiple Page Mode 
The Multiple Page Mode allows users to configure how the diagrams should be distributed in multiple pages. To switch to the 

Multiple Page Mode click on the Multiple Page Mode button  on the toolbar. 
Clicking on the button beside the Multiple Pages field will invoke the page selector, where you can select the row-column 
combination for the printout. Alternatively, you can type in the Row and Column text field directly. 

 

Figure 2.119 - Select multiple page 
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Click on the button beside the Page Style field to change the printout order. Consider a large diagram is divided into many 
pages, selecting 'From left to right'  will arrange the printout order from the pages on the left to the pages on the right, while 
selecting 'From top to bottom'  will arrange the print order from the pages on the top to the pages on the bottom. 

 

Figure 2.120 - Distributes diagram in multiple page 

After you have finished configuring the multiple page settings click on the Close Multiple Page Mode button to close the 
Multiple Page Mode. 
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Printing a Diagram with Quick Print  

The Quick Print feature allows you to print diagrams without previewing them, hence speeding up the print job. To quick print, 
perform one of the following actions: 

• Select File > Print SDE-EC Diagrams... from main menu. This displays the Print Preview dialog box. Click  on 
the toolbar of the Print Preview dialog box.  

In both cases, the Quick Print  dialog box will show.  

 

Figure 2.121- Quick Print dialog 

Field  Description  

Print Range  

Click on either of the below options to specify the print range. 
All - Print all the diagrams within the current project 
Active - Print only the active diagram 
Diagrams - Check from the diagram tree to select the diagram(s) for printing 

Scaling  
Select No scaling to print with diagrams' original size. Numbers of pages used for each diagram are subject to the 
scale of diagrams. Select Fit to pages to print with specified number of pages per diagram with respect to the 
specified number of rows and columns. 

Border 
option 

Select border option of printout. 

Page 
Setup...  

Page Setup allows you to specify the page size, the orientation as well as the margins of the pages.  

Page 
numbers  

Select to print diagrams with page number on it. 

Use 
gradient 
color 

Select to use gradient color in printout.  

Table 2.3 
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Shape Alignment 

Aligning Shapes 

This feature provides a facility to align selected diagram elements. You can align using toolbar, popup menu or group resource.  
All alignment methods calculate the resulting shape boundaries on a referenced shape. You can refer to the section 'Referenced 
Shape for Alignment' for details. 
Before you use any one of  the methods to align, you should first select more than one shape.  

 

 
Figure 2.122 - Three use cases selected 

Here, three use cases aligning towards the top is used as an example. 
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To align using toolbar, you can select Format > Alignment > Top from the main menu. 

 
Figure 2.123 - Select Top from main menu 
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To align using popup menu, you can select Alignment > Top in the popup menu. 

 
Figure 2.124 - Select Top from popup menu 

 

To align using group resource, you can select the Alignment resource > Align Top which appears when two or more shapes 
are selected. 
You can select the way of aligning from the drop-down menu. 

  

 
Figure 2.125 - Select Align Top from Alignment resource 

 

By using any of the above methods, the shapes are aligned. 

 
Figure 2.126 - Shape aligned 
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Distributing Shapes 

This feature provides a facility to distribute selected diagram elements with uniform space. You can use resource, toolbar and 
menu to distribute shapes. 
Before you use any one of the methods to distribute shapes, you should first select more than two shapes.  

 
 Figure 2.127 - Three use cases selected 

 Here, three use cases distributing horizontally is used as an example. 
 
Use resource to distribute shapes: 
To align using group resource, you can select the Distribute  resource > Distribute Horizontally  which appear when more 
than two shapes are selected. 

 
 Figure 2.128 - Select Distribute Horizontally 

 

The use cases after Distribute Horizontally . 

 
 Figure 2.129 - Three use cases distribute horizontally 
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Making Shapes Same Width and Height 

This feature provides a facility to set selected diagram elements to the same width, same height, or both. You can use resource, 
toolbar and menu to make the shapes being the same width/height. 
The methods calculate the resulting shape boundaries based on a referenced shape. You may refer to the section 'Referenced 
Shape for Alignment section' below for details. 

  

You need to select two or more shapes in order to apply this feature. Here, making three use cases the same width is used as an 
example. 

 
 Figure 2.130 - Three use cases selected 

 
To make shapes same width, you can select Make Same Width resource > Same Width. 

 
 Figure 2.131 - Select Same Width 

 
The resultant use cases now have the same width. 

 
Figure 2.132 - Resultant use cases 
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Referenced Shape for Alignment 

When there are multiple shapes selected, the last selected shape will be used as the referenced shape for alignment. That is, the 
alignment method will be performed based on the position/size of the referenced shape. The referenced shape will be rendered 
with its resize handles surrounded by white rectangles. 

 

Figure 2.133- before and after Alignment left 

You can set a shape as the referenced shape for alignment (if it is currently not) by shift-clicking on the shape for two times 
(the first time to deselect the shape, and the second time to reselect it). 
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Using the Align Shapes Dialog Box 

You can invoke the Align Shapes Dialog either Format > Alignment > Align shapes... in the menu bar or the toolbar, or 
using the hot key F12. The Align Shapes dialog box allows you to configure the top/bottom, left/right alignments and same 
width/same height options all at a time. Select the desired options and click OK  to apply the settings. 

 

Figure 2.134 - Align Shapes Dialog 

Visual Alignment Guide 

When you move a shape, visual alignment guide helps you to align with the closest shape. The guide lines show the vertical 
edge of the closest shape if you move a shape horizontally. Similarly, the guide lines show the horizontal edge if you move a 
shape vertically. 
Here, a use case moving horizontally to align with other use cases is used as an example. 
 
To align with other shapes: 
1. Move the use case which you want to align with others. You can see the Visual Alignment Guide line. 

  

 
Figure 2.135 - Use case with guide lines before alignment  
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2. Move until the use case align with the others. 

 
Figure 2.136 - Move the use case 

 
3. Release the mouse and you will see the aligned use case. 

 
Figure 2.137 - Use case aligned 
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You may also change the alignment guide style, or enable/disable it. 
1. To perform these task, select Modeling > Application Options... to open the Options dialog box.  

Figure 2.138- Options dialog box 

 
2. Select Diagramming > Environment tag. 

 
Figure 2.139 - Select Environment tag 
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To enable/disable the guide lines, check/uncheck the option Show diagram alignment guide. 

 
Figure 2.140 - Enable/disable the guide lines 

 
You can also change the guide line style by choosing Show edges or Show center. 
   

 
Figure 2.141- Change the style of guide lines 

 
If you choose Show center, the guide line shows the center of the closest shape. 

 
Figure 2.142 - Show center of the closest shape 

 
If you choose Show edges, the guide lines show the edge of the closest shape. 

 
Figure 2.143 - Show edges of the closest shape 
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Selectable 

The option allows you to make certain diagram elements read-only so that you can focus on editing other elements.  All 
diagram elements are selectable by default. 

To make one or more diagram elements non-selectable: 

1. Right-click on the elements and deselect from the popup menu to make the selected element non-selectable. 

 
Figure 2.144 - Deselect the selectable option 
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2. When a diagram element is non-selectable, it can not be detected by mouse or key actions.  This means that if you click or 
drag on it, it will be the same as clicking or dragging on the white space of the diagram and nothing with happen 

 

 
Figure 2.145 - Diagram element after deselection 
. 

3. To make a non-selectable diagram element selectable again, right-click on it and select Selectable from the popup menu. 

 
Figure 2.146 - Diagram element can be selected again 
 

4. You may also right-click on the diagram and select Make All Non-Selectable/Make All Selectable from the popup menu to 
make all elements non-selectable/selectable. 

 
Figure 2.147 - Make all diagram elements Selectable or Non-selectable 
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Locking a Diagram 

If a diagram is locked, you can only view but not change the elements on the diagram. 
A diagram is locked by right-clicking the diagram and then selecting Lock Diagram from the popup menu. 

 
Figure 2.148- Locking a diagram 
 



 

Style and Formatting 3 
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Chapter 3 - Style and Formatting 

This chapter will show you how to change the style and format of diagram elements. 

One of the goals of modeling is help the modeler and readers to understand the subject being modeled. As a result, applying 
consistent style and formatting can greatly improve the efficiency of modeling. In SDE for Eclipse, it supports a rich array of 
tools in a set to help the modeler to perform modeling. 

In this chapter: 

• Changing connector styles 
• Setting and pinning connection end points 
• Filling color 
• Formatting lines 

 

Connector Styles 

Connectors are the lines that connect two shapes. When more shapes are created and more connectors appear, you may find 
that it is difficult to handle the straight spaghetti-like connectors. To overcome this problem, SDE for Eclipse provides five 
connector styles to help you handle the connectors, namely Rectilinear, Oblique, Curve, Round Oblique and Round Rectilinear. 

 
Figure 3.1 - Different types of connectors 
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Setting Connector Style 

When a new connector is created, it follows the default connector style defined in the Options of the application. It is possible 
to change the connector style individually. There are two ways to change the connector style. The first one is via a popup menu 
and the other is via the Property table. 
To change the connector style via popup menu: 

1. Right click the connector that you want to change the style of. 
2. Select the Connector Style menu and then the connector style sub-menu will appear. 
3. Select either Rectilinear, Oblique, Curve, Round Oblique or Round Rectilinear. 

 

Figure 3.2 - Change connector style on popup menu 
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To change the connector style via Property table:  

1. Select the connector whose style you want to change. 
2. Find the Connector style row in the Property table.  
3. Click the Value column of Connector style row.  
4. Select either Rectilinear, Oblique, Curve, Round Oblique or Round Rectilinear. 

 

Figure 3.3 - Change connector style on properties table 

Rectilinear Connector Style 

Once the connector is set to Rectilinear, the connector always remains either horizontal or vertical. You cannot create a 
breakpoint on the connector by yourself. The breakpoints are generated on the connector automatically after you reshape the 
line. 

In the following figure, there is a pin icon at each end of the connector. Pinning a connection end point allows the pinned end 
point of a connector to be fixed, no matter how the connecting shapes are moved. For further details, please refer to 
Connection Point Style> Pinning the Connection End Point in this chapter. 

 

Figure 3.4 - Rectilinear Connector Style 

To reshape the connector, you can drag the lines or the break points at the connector.  
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Dragging on Lines 
There is a horizontal line and vertical line along the connector. If you are dragging on the horizontal lines, the lines can only 
move up or down. In the following figures, the line we want to move is in blue. As you can see, the right end point of the blue 
line is touching Class2. After moving the red line upwards, the right end point of the blue line does not touch Class2. To rectify 
this, a vertical line is automatically created to continue the connection between Class and Class2. 

  

Figure 3.5 - Drag on the line 

The result of dragging the vertical line is similar to dragging the horizontal line. The difference is that the line is restricted to 
vertical movement (either from left to right or from right to left). When two shapes are disconnected, a horizontal line will be 
created at the end of point to continue the connection between shapes. 

Dragging on Break Points 
Dragging on break points provides two dimensional movements to the point, modifying the connectors. The point being moved 
may affect all lines of the connector that depends on the numbers of line in the connector. The following figures demonstrate 
the result of dragging the orange point along the red arrow. 

  

Figure 3.6 - Drag on break point 

Oblique Connector Style 

There is no boundary for the modification of the connectors. You can create break points anywhere you like on the connector, 
and the lines in the connector will not be aligned with the horizontal or vertical axis. If you drag a line, a new breakpoint will 
be created at the drag point and two lines will be created. If you wish to modify a line to be horizontal or vertical, you may do 
this by hand. 

The following figures demonstrate modifications to the connector. The new breakpoint is created when you drag the connector 
away from its starting point. When you release the mouse click the breakpoint will be finalized. 

 

Figure 3.7 - Oblique Connector Style 
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The figure below shows the modification to the connector with the oblique connector style. The connector is divided into two 
lines and a new break point is created on the connector. 

 

Figure 3.8 - Create a break point by drag on the line 

 
You can use the Point Eraser  in the Diagram Toolbar or double click on the connector point to erase 
that points. 

Curve Connector Style 

By applying the Curve connector style, the connector will be arranged as a smooth curve line. To change the curve shape, 
simply add/move/remove point(s) on the connector and the curve will be automatically re-calculated according to the points. 
The Curve connector style makes the connectors much easier to route in complex diagrams to avoid crossing connectors. 

The following figures demonstrate the modifications to the connector. The new breakpoint is created when you drag the 
connector away from its starting point. When you release the mouse click the breakpoint will be finalized. Another breakpoint 
is created in the middle of the connector to make a curvature. 

 

Figure 3.9 - Curve Connector Style 

 
The figure below shows the modification to the connector with the curve connector style. The connector has one more 
curvature and a new break point is created on the connector. 

 
Figure 3.10 - Create a break point by drag on the line 
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Round Oblique Connector Style 

The behavior of the Round Oblique connector is the same as that of the Oblique connector style. The only difference is the 
corners of the connector using Round Oblique style will appear rounded. 

 

Figure 3.11 - Round Oblique Connector Style 

Round Rectilinear Connector Style 

The behavior of Round Rectilinear connector style is the same as that of Rectilinear connector style. The only difference is the 
corners of the connector using Round Rectilinear style will appear rounded. 

 

Figure 3.12 - Round Rectilinear Connector Style 

 

Setting a Default Connector Style 

Default connector style can be set from the Options. To set default connector style: 

1. Select Modeling > Application Options...from main menu. This displays the Options dialog box.  
2. Open the Diagramming category. 
3. Select the Environment page.  
4. From the row Connector Style, select either Rectilinear, Round Rectilinear, Oblique, Round Oblique or Curve. 
5. Press OK  button to confirm changes. 
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Follow Diagram Connector Style 

In SDE for Eckuose, with the Follow Diagram feature, you do not need to set connector style one by one if you want to change 
all connectors in the diagram. When you right-click on a diagram you can set its default connector style from its popup menu, 
so that once the diagram connector style is changed, all connectors whose connector style is set to 'Follow Diagram' will be 
updated to the new style. 

Connection Point Style 

Each shape has a property called Connection Point that specifies how the connection points of the connectors should move if 
the shape is being moved. Unlike the connector style that is connector oriented, the connection point style is shape oriented. 

Setting Connection Point Style 

To set the connection point style: 
Using popup menu:  

1. Select one or more shapes and right-click on the selection. 
2. Select the Format > Connection Point...from popup menu. This displays the Select Connection Point Style dialog 

box. 

 

Figure 3.13 - Select Connection Point Style Dialog 

3. Select either 'Round the shape' or 'Follow center' for the connection point style. Upon selecting a style an animation 
will appear to emulate the effect of the selected connection point style. 

4. Click OK  to confirm the change. 
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Using the property table 

1. Select a shape.  
2. Select either 'Round the shape' or 'Follow center' from the Value field of the Connection point property. 

 

Figure 3.14 - Properties Table 

Round the Shape 
Upon selecting the 'Round the shape' connection point style, the last connect point of the connector will move along the bounds 
of the shape. 

 

Figure 3.15 - Round the shape 
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Follow Center 
Upon selecting the 'Follow center' connection point style, the last connect point of the connector will be determined by the 
center of the shape. 

 

Figure 3.16 - Follow center 

Pinning the Connection End Point 

Pinning a connection end point allows the pinned end point of a connector to be fixed, no matter how the connecting shapes are 
moved. In figure below, the connection end point linking the class Bank is pinned to the location of the getAccount operation. 

 

Figure 3.17 - Pin a connector point 

In SDE for Eclipse a connecting end point is unpinned by default. If a connecting end point is unpinned, its location will be 
determined by the connection point style of the connecting shape. 

To pin a connection and an end point: 
Using Resource-Centric Interface  

1. Select the connector.  
2. There is a "pin" resource for each connection end point. If the end point is currently pinned an icon will be displayed 

(a pin with shorter needle). If the end point is currently unpinned, an "unpinned" icon will be displayed (a pin with 
longer needle). In the figure below, the end point connecting the class Bank is pinned, while the end point connecting 
the class BankConsortium is unpinned. 

3. Click once on the resource to toggle its pin state. 

 

Figure 3.18 - Toggle the pin state 
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Using the popup menu 

1. Right-click on the connector.  
2. Select the Pin menu from the popup menu, the Pin sub-menu appears.  
3. Select either From Point or To Point to pin/unpin the desired connection end point. 

 

Fill Color 

All of the shapes have a fill color property, which allows you to select a solid fill color or a gradient fill color as well as define 
its transparency. 

To format fill color for shapes, select the desired shapes and perform one of the following actions: 

• Right-click on the selection and choose Format > Fill...from popup menu.  
• From the property table, click on the ...button of the Fill  property to invoke the Format Fill Color  dialog box. 

In both cases, the Format Fill Color  dialog box will be displayed. 

Format Fill Color Dialog Box 

The Format Fill Color  dialog box allows you to select the fill color type (solid or gradient) and you can create your own fill 
color by configuring the transparency, gradient style and colors. 

 

Figure 3.19 - Format Fill Color Dialog 

Field  Description  

Fill Style  Select the fill style of the fill color. It can either be Solid (a single color) or Gradient (a fill color that is mixed 
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by two colors). 

Transparency  

Specify the transparency of the fill color. The greater the value, the more transparent is the shape. 0 (zero) 
transparency makes the fill color completely opaque, while 100 (one hundred) transparency makes the fill color 
completely transparent. 
You can adjust the transparency by dragging the slider, or by typing the value in the text field. 

Alternatively, you can click the Opaque button to set the fill color to opaque, or click the Transparent button 

to set the fill color to transparent.  

Preview  
The Preview pane displays a rectangle that is filled with the editing fill color. The background is checked so 
that you can also preview the transparency of the fill color as well. 

Save as 
Default  

To save the current fill color as the default fill color for new shapes, click the Set as Default button.  

Table 3.1 

Formatting a Solid Fill Color 
Upon selecting Solid from the Fill style field, you will see the detail pane for formatting a solid fill color. 

 

Figure 3.20 - Select Solid Fill Style 

Field  Description  

Color  
This field displays the current selected color. It will display the color name if the selected color is a default color 
(Black, White, Yellow, etc); otherwise the RGB value of the selected color will be displayed. 

Default 
Color List  

The default color list displays a list of pre-defined colors. Each color is displayed with a color preview and a color 
name. You can view the RGB value of a color by moving the mouse pointer over the color. 

Custom 
Color Pane  

The custom color pane displays a wider range of colors that you can choose from, and you may define a new 
custom color by clicking on the Custom...button. The new color will be added to the recent color list (located at 
the bottom two rows of the custom color pane) for later reuse. 

Table 3.2 
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Formatting a Gradient Fill Color 
Upon selecting Gradient from the Fill  style field you will see the detail pane for formatting a gradient fill color. 

 

Figure 3.21 - Select Gradient Fill style 

Field  Description  

Color 1  
You can select the first color of the gradient from the Color 1 field. To select a color click the ... button or 
double-click on the color editor. A color chooser will appear for you to select a color.  

Color 2  
You can select the second color of the gradient from the Color 2 field. To select a color click on the ...button or 
double-click on the color editor. A color chooser will appear for you to select a color.  

Gradient 
Color 
Themes  

The Gradient Color Themes pane displays a list of pre-defined gradient color themes. 
To add a new color theme select Color 1 and Color 2 then click the Add to Themes...button. Please note that 
you must select a combination of colors that does not already exist in the color themes. 
To rename a theme click on the Rename...button or double-click on the desired theme. An input dialog will 
appear for you to enter a new name. 
To remove a theme select the theme and click on the Remove button, or use the Delete key instead. 

Gradient 
Style  

The Gradient Style pane allows you to select the gradient style of the gradient fill color (the angle of how the 
gradient color is drawn). There are sixteen pre-defined gradient styles, which are shown as toggle buttons in the 
Gradient Style pane. To select a gradient style to use click on one of the styles. 

Table 3.3 

Line Format 

You can format the line of a shape so that you can adjust its stroke style, weight (thickness), color and transparency. 
To format the line of a shape, select the desired shape and perform one of the following actions: 

• Right-click on the selection and choose Format > Line...from popup menu. 
• From the property table, click on the ... button of the Line property to invoke the Format Line dialog box.  
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In both cases, the Format Line dialog box will be displayed.  

Format Line Dialog Box 

The Format Line dialog box allows you to format the line of a shape. 

 

Figure 3.22 - Format Line Dialog 

Field  Description  

Style  
Select the style (stroke) of the line. You can select one of the 23 styles (including "None" , which 
means no line) to apply in the combo box.  A preview will be shown for each of the style items. 

Weight  

Adjust the weight (thickness) of a line. The greater the value, the thicker the line. You can use the 
up/down button to increase/decrease the line weight, or you can type directly into the text field. The 
line weight ranges from 1 to 20. 

 
Only integer values can be used for line weight. If you type 2.8 in the text field, 2 
will be applied instead. 

 

Color  
Specify the line color. Click on the ... button beside the Color field to select a color, either 
from the Default page (which shows predefined colors) or from the Custom page (which 
shows a larger variety of colors, and allows you to define any custom colors).  

Transparency 

Specify the transparency of the line. The greater the value, the more transparent the line. 0 
(zero) transparency makes the line completely opaque, while 100 transparency makes the line 
completely transparent. 
You can adjust the transparency either by dragging the slider, or by typing the value in the text 

field. Alternatively you can click on the Opaque button to set the fill color to opaque, or 

click on the Transparent button to set the fill color to transparent. 

Preview  
The Preview pane displays a rectangle surrounded by the line with the selected line format 
applied.  

Save as Default 
Line Format  

To save the current line format as the default line format for new shapes click the Set as 
Default button. 

Table 3.4 

 

Font 

You can change the font format such as color and size. 
To format the font, select the desired shapes or text boxes and perform one of the following actions: 
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• Right-click on the selection and choose Format > Font... from the popup menu. 
• From the property table, click on the ... button of the Font property to invoke the Select Font dialog box.  

In both cases, the Select Font dialog box will be displayed.  
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Select Font Dialog Box 

The Select Font dialog box allows you to format the font of a shape or a textbox. 

 

Figure 3.23 - Select Font dialog box 

Field  Description  

Font 
Name  

Select different types of font. The number of fonts depends on the fonts available in your computer.  

Font 
Style  

Select the style of font. You can select one of the 4 styles, a preview will be shown for each of the style items. 

Font 
Color  

Specify the font color. Just click on the ... button beside the Color field to select a color either from the Default page 
(which shows predefined colors) or from the Custom page (which shows a larger variety of colors, and allows you 
to define any custom colors).  

Font 
Size 

Select the size of font. You may either click on the default sizes or enter the font size in the text field. 

Preview  The Preview pane displays the selected font format.  

Table 3.5 
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Format Copier 

Format copier enables you to copy the fill, line and font settings of one shape to another. 

To copy format of a shape to another: 

1. Select the source shape. 

 
Figure 3.24 - Select the source shape 

 

2. Click Format Copier on the toolbar. 

 
Figure 3.25 - Click Format Copier 
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3. Click on the targeted shape to apply the formatting. 

 
 Figure 3.26 - Apply formatting 

 

Stereotyped Element Appearance 

With the configurable stereotype appearance including fill, line and font, stereotyped elements can be easily distinguished and 
emphasized in the diagram.  

Here, a stereotype of class is used as an example. 

Configuring Stereotype Appearance 

1.Select main menu Modeling > Edit Stereotypes.... to open Configure Stereotypes dialog box. 

 
Figure 3.27 - Select Edit Stereotypes... 
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2. In the Configure Stereotypes dialog box, select a model type in Model elements and the target stereotype in Stereotypes 
(in this example we selected “Entity Bean” - a pre-defined stereotype of Class). Click the Edit... button.  

 
Figure 3.28 - Configure Stereotypes dialog box 
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3. The Stereotype Specification is shown.  

 
Figure 3.29 - Stereotype Specification 

 
To apply fill color to stereotype: 
1. select the Use checkbox and click the ... button of the Fill  property.  

 
Figure 3.30 - Check Use and edit Fill property 
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2. Select a fill color in the Format Fill  dialog box and click OK .  

 
Figure 3.31 - Format Fill dialog box 

 
To apply line style to stereotype: 
1. Select the Use checkbox and click the ... button of the Line property.  

 
 Figure 3.32 - Check Use and edit Line property 

 
2. Configure the line style in the Format Line dialog box and click OK .  

 
Figure 3.33 - Format Line dialog box 
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To apply font to stereotype: 
1. Select the Use checkbox and click the ... button of the Font property. 

 
 Figure 3.34 - Check Use and edit Font property 

 
2. Select a font in the Select Font dialog box and click OK . 

 
Figure 3.35 - Select Font dialog box 
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After configuring stereotype appearance, click OK  in the Stereotype Specification. Then, Click OK  when returned to the 
Configure Stereotypes dialog box. 

 
Figure 3.36 - Stereotype appearance configured 

 

Applying Stereotypes to Shape 

1. Right-click on a shape and select Stereotypes > Stereotypes... from the popup menu to open the Class Specification Dialog.  

 
Figure 3.37 - Select Stereotypes... 
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2. Select a stereotype in the All  list, click Add Selected to add it to the Selected list.  

 
Figure 3.38 - Add a stereotype to Selected list 

 
3. Click OK  in the specification dialog box. The stereotype is applied to the model, and the stereotype’s appearance is applied 
to the shape.  

 
Figure 3.39 - Stereotype applied 
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Changing Stereotype Appearance 

1. Select main menu Modeling > Edit Stereotypes... to open the Configure Stereotype dialog box. Select a model type in 
Model elements and the target stereotype in Stereotypes. Click the Edit... button. 

 
Figure 3.40 - Select a model type and the target stereotype  

 
2. We will modify the stereotype fill color in this example. Click the ... button of the Fill  property.  

 
Figure 3.41 - Modify the stereotype fill color 
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3. Select orange as fill color, click OK .  

 
Figure 3.42 - Select a fill color 
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4. When returned to the Stereotype Specification dialog box, ensure the Apply changes to stereotypes in current project 
option is selected, otherwise stereotypes already used in the current project will not be updated. After that, click OK  to close 
the dialog box.  

 
Figure 3.43 - Return to Configure Stereotypes 

 
5. The appearances of shape that assigned the changed stereotype are updated. 

 
Figure 3.44 - Appearances of shape updated 
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Visual Modeling 4 
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Chapter 4 - Visual Modeling 

This chapter will show you the features of performing UML modeling. 

In this chapter: 

• Creating multiple views for model 
• Finding and jumping in diagrams and projects 
• Forming diagrams from models 
• Controlling the visibility of compartment 
• Creating and editing sub-diagrams, references and logical views. 
• Customizing data types 
• Using mouse gesture 

Showing Model in Different Diagram 

A model is a specific collection of interconnected objects and their properties. A diagram element is the view associated with 
the model. In SDE for Eclipse, one model can have multiple views. Also, SDE for Eclipse supports sharing models to show the 
same model in different diagrams. This can help to avoid putting everything in a single giant diagram, leading to difficulties in 
modeling and understanding.  

Here, a class model is used as an example. 

To show the model in a different diagram: 

1. Select a class model in the Model pane. 

 
Figure 4.1 - Select a class model 
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2. Create a new class diagram, drag the model from model tree. 

 
Figure 4.2 - Drag the model 

 

3. A new view of the model is created. 

 
Figure 4.3 - View created 
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Form Diagram from Model 

This feature can help you visualize a set of model and transfer it to a diagram with a few clicks. There are different options to 
form diagrams to fit different needs. 
You can form a diagram with the selected models (classes/packages) in the Model pane and Class Repository pane. 

1. Open/Activate the Model pane or Class Repository pane.  
2. Select the classes and packages you would like to appear in the new Class Diagram.  
3. Right-click on the selection and select Form Diagram from the popup menu. 
4. Choose from one of the Form Diagram types (Customize..., Hierarchical , or Navigation) in the cascading menu. 

 

Figure 4.4 - Form diagram from model 

 
Currently SDE for Eclipse allows you to form diagrams with only packages and classes. 
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Customize Form Diagram Properties 

You can use the Form Diagram dialog box to customize form diagram properties. 
To open the Form Diagram dialog box: 
1. Select more than one classes or packages in Model pane or Class Repository.  

 
Figure 4.5 - Select models 

 
2. Right click on them and select Customize... from the popup menu, the Form Diagram dialog box appears. 

 
Figure 4.6 - Open Form Diagram dialog box 
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Select the relationships you want to show in the new diagram in the Form Diagram tab. The relationships can be between the 
diagram elements of the selected models and their related diagram elements. 

 

Figure 4.7 - Form Diagram Dialog 
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A new diagram is created with the diagram elements of the selected models, the related diagram elements and the relationships 
between the diagram elements. 

Figure 4.8 - The generated Class Diagram 

In this case, the class model called "Invoice" and "InvoiceLineItem" are selected. The new diagram (on the right hand side) 
shows the relationships between the the two models and other models. 

Figure 4.9 - The association of the selected classes are included in the new diagram 
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Presentation Options 
Click the Presentation Options tab on the Form Diagram dialog box to set the presentation options for the classes in the new 
diagram. 

 

Figure 4.10 - The presentation options 
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Hierarchical Diagram 

If you selected Hierarchical in the cascading menu, a new diagram is created with the diagram elements of the selected models, 
the parents and children of the diagram elements and the general relationships between the diagram elements. 

 

Figure 4.11 - Hierarchical Diagram 

In this case, the class model called "Clerk" is selected. The new diagram (on the right hand side) shows the generalization 
relationships between the "Clerk" model and other related models. 

 

Figure 4.12 - Show the inheritance hierarchical in the new diagram 
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Navigation Diagram 

If you selected Navigation in the cascading menu, a new diagram is created with the diagram elements of the selected models, 
the sources (non-navigable diagram elements) and targets (navigable diagram elements) of the diagram elements and the 
association relationships between the diagram elements. 

Figure 4.13 - Navigation Diagram 

In this case, the class model called "Order" is selected. The new diagram (on the right hand side) shows the association 
relationships between the "Order" model and other related models. 

Figure 4.14 - show the navigation association of the selected classes. 
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Sub-Diagrams 

It is a known fact that elaboration is one of the common modeling techniques. 
SDE for Eclipse supports sub-diagrams to facilitate elaboration. For example, we have a Use Case Diagram to elaborate each 
use case by a Sequence Diagram. 
You can create new sub-diagram or associate with existing diagrams as a sub-diagram. 

Creating a Sub-Diagram 

To create a new sub-diagram for a model, perform one of the following actions: 

• Right-click on the diagram element and choose Sub Diagrams from the popup menu to expand it. A list of 
recommended sub-diagram types (according to the nature of the model) is shown. If the type of diagram you want to 
add is not one of the recommended types, select Other Diagrams to expand it. From the Sub Diagrams or Other 
Diagrams menu, select %SUB_DIAGRAM_TYPE% > Create %SUB_DIAGRAM_TYPE%  (e.g. Sub Diagrams 
> Use Case Diagram > Create Use Case Diagram).  

• Right-click on the diagram element and choose Open Specification from the popup menu. This displays the Open 
Specification dialog box. From the dialog box, switch to the Diagrams tab and click Add. A list of recommended 
sub-diagram types (according to the nature of the model) is shown. If the type of diagram you want to add is not one 
of the recommended types, select Other Diagrams to expand it. From the root menu or Other Diagrams menu, 
select the desired type of sub-diagram to create it. 

For example, here is a Use Case creating sequence diagram. 

 
Figure 4.15 - Create Sequence Diagram 
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Selecting Existing Diagrams as Sub-Diagrams 

To select existing diagrams as sub-diagrams: 

• Right-click on the diagram element for adding sub-diagrams and choose Sub Diagrams > Add Existing Diagram... 
from the popup menu. 

• Right-click on the diagram element for adding sub-diagrams and choose Open Specification... from the popup menu. 
This displays the Open Specification dialog box for that model element. Switch to the Diagrams tab, press Add and 
select Existing Diagrams...from the popup menu. 

 

Figure 4.16 - Add existing diagram to Sub-Diagram 
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In both cases, the Add Sub Diagrams Dialog will be displayed. 

 

Figure 4.17 - Select the existing diagram 

The Add Sub Diagrams dialog shows all the selectable diagrams. Selectable diagrams are all the diagrams in the project 
excluding the following: 

• The parent diagram of the selected diagram element 
• All diagrams which are sub-diagrams of any model 

Select the diagrams to add as sub-diagrams, and then click OK  to confirm.  

Viewing the List of Sub-Diagrams 

To view sub-diagram from its parent model element: 

• Right-click on the diagram element and choose Open Specification... from the popup menu. This displays the Open 
Specification dialog box. From the dialog box, switch to Diagrams tab. Sub-diagrams of that diagram element are 
shown in the table. 
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Opening Sub-Diagrams 

To open a sub-diagram from a parent diagram element, perform one of the following actions: 

• Right-click on the diagram element and choose Sub Diagrams > %SUB_DIAGRAM_TYPE% > 
%SUB_DIAGRAM_NAME%  from the popup menu. 

• Select the sub-diagram from resource icon of that diagram element: 

 

Figure 4.18 - Open Sub-diagram 

Removing Sub-Diagrams 

To remove a sub-diagram from its parent diagram element, perform one of the following actions: 

• Right-click on the diagram element and choose Open Specification... from the popup menu. This displays the Open 
Specification dialog box. From the dialog box, switch to the Diagrams tab. Sub-diagrams of that diagram element 
are shown in the table. Select the sub-diagram that you want to remove and click Remove to remove it. 

• Activate the Diagram Navigator/Model pane, expand the tree node of that diagram element, select the sub-diagrams 
that you want to remove and then right-click on them and select Detach from Parent from the popup menu. 

 

Figure 4.19 - Remove Sub-Diagram 
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References 

References can be added to a model to associate any kind of artifacts, including files, folders, URLs and diagrams with the 
model. After you have added the references, you can open them in the tool with the default application/web browser whenever 
you need them. 
There are four kinds of reference you can add: 

• File: Normal files like word documents 
• Folder: Folders in the file system 
• URL: Link of website 
• Diagram: Diagrams in the current project 

Adding Referenced File 

To add a referenced file using the open specification dialog box: 

1. Open the specification dialog box of the model, select the References tab.  
2. Click the Add File... button, or right-click on the table and select Add File... from the popup menu. 

 

Figure 4.20 - Add Reference Files 

To add a referenced file using the References resource: 

1. Click on the References resource (located at the lower left corner of the shape, with a shortcut arrow icon).  

 

Figure 4.21 - Edit reference resource-centric 
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2. Select Add File... in the popup menu.  

 

Figure 4.22 - Select Add File in the popup menu 

Using either method, the reference details pane will be shown. Specify the file path in Path or browse by clicking the ... button. 
You may also optionally provide a description for the reference in Description. 

 

Figure 4.23 - Edit Reference 

 

Adding folders, URLs and diagrams can be done by using a similar approach. 

Editing References 

To edit references:  

Open the open specification dialog box of the model, select the References page. Alternatively click on the References 
resource of a shape and select Edit References from the popup menu. 

 

Figure 4.24 - Open edit reference dialog 
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Right-click on a reference and select Edit  from the popup menu. 

 

Figure 4.25 - Edit reference by clicking on popup menu 

 
Alternatively, click the Details button to show the details pane if it is not already showing.  

 

 

Figure 4.26 - Show reference details 

 
Using either method, the reference details pane will be shown. You can then edit the path and description of the selected 
reference.  

 

 

Figure 4.27 - The reference details 
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Reordering References 

To reorder references: 

1. Open the specification dialog box of the model, select the References page.  
2. Select one or more references in the table. 
3. Click on the Move up/Move down button to move the selection upwards/downwards. Alternatively right-click on the 

selection and select Move Up/Move Down from the popup menu. 

 

Figure 4.28 - Re-ordering reference 

Opening References 

To open references: 

1. Open the specification dialog box of the model, select the References page.  
2. Select one or more references in the table. 
3. Click on the Open... button, or press the Enter key, or right-click on the selection and select Open... from the popup 

menu.  

 

Figure 4.29 - Press Open button to open the selected references. 
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4. Alternatively, click on the References resource of a shape and select a reference from the popup menu. 

 

Figure 4.30 - Open reference by clicking on popup menu 

5. The selected references will be opened by the default applications or web browser. 

Removing References 

To remove references: 

1. Open the specification dialog box of the model, select the References page.  
2. Select the unwanted references in the table. Click the Remove button, or press the Delete key, or right-click on the 

selection and select Remove from the popup menu. 

 

Figure 4.31 - Remove reference 

User Path 

A user path is a variable that refers to a base path in a user's computer. You can add a reference to local file using a user path, 
so that the reference refers to a file relative to a user path, instead of an absolute path. This means you can move references 
files to a different location, or even to a different computer, and can still open them as long as the user path value is up-to-date. 
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Configuring User Paths 
To configure user paths, select menu Modeling > Application Options.... Select the User Path category in the Options dialog 
box. 

Figure 4.32 - Configure User Paths 

• To add a user path, click Add..., and then enter the name and path in the Add User Path dialog box. 

 

Figure 4.33 - Add User Path 

 

• To edit a user path, select it in the table and click Edit..., and then edit the name and path in the Edit User Path dialog 
box. 

• To remove user paths, select unwanted user paths in the table and click Remove. 
• Show user path - Select to show user paths in references, instead of displaying resolved absolute paths. A user path is 

displayed with its name enclosed by ${ }. 

 

Figure 4.34 - Using User Path in the references 
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• Prompt to specify user path - Select to enable prompt for user path after adding a reference to file whose base path is 
not defined as a user path. 

 

 

 

Figure 4.35 - Specify user path  

Logical View 

The Logical View refers to a user's view of the way project is organized. It provides another view of creating, structuring and 
sharing the UML diagrams and models apart from the traditional Diagram Navigator, Model Tree View and Class Repository. 

 

Figure 4.36 - Logical View Pane 

Creating a Logical View 

To create a view: 

1. Right-click on the project node (top-most node of the Logical View pane) and choose Add View from the popup 
menu. This creates a new View under the project node. 

2. Right-click on the new view and choose Rename...from the popup menu to provide a name for the view. 
3. Enter the name in the displayed input box and click OK  to confirm the changes. 

Creating Diagram(s) under View 

To create a diagram under a view, right-click on the view that holds the new diagram and choose Create Diagram > Create 
%DIAGRAM_TYPE%  from the popup menu. This creates a blank diagram of the selected type under the chosen view. 

Moving Diagram(s) between Views 

To move the diagram from one view to another, simply drag and drop it to the target view. The diagram will therefore transfer 
from original view to target view. 
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Exporting and Importing View 

You can export the current Logical View structure as an XML file and apply it over and again on other projects. There are two 
options for importing a Logical View structure. 

Append to existing structure 
The imported structure will append to the current structure, no modification will be made on the existing one. 

  

Replace existing structure 
The imported structure will replace the current structure, predefined structure will be removed. 

For any diagram in the current project that has the same name as any of the diagrams in the XML file, the diagram name will 
be displayed in the Logical View of the current project. Otherwise the name will not be shown in the imported structure. 

 

Finding a Model Element 

Model elements can be searched in the project. To find a model element, you should first display the Find dialog box. To 
display the Find dialog box, select Edit > Find  from main menu. 

 

 

Figure 4.37 - Find Model Element Dialog 
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Field Description  

Text  
Enter the text for which you want to search. The text may be the name of the model element or part 
of the model documentation. 

Scope  

Find in diagram 

Select from drop-down menu any of the options to narrow the search in different ways: 
Find in All Diagrams - To search for views in all diagrams within the project. 
Find in Opened Diagrams - To search for views in all opened diagrams within the project. 
Find in active diagram only - To search for views in the active diagram. 
Do not find in diagrams - Not to search for views in any of the diagrams. 

Find in model  
Check/Uncheck to enable/disable searching for model elements from existing models within the 
project.  

Include documentation 
of elements 

Check/Uncheck to enable/disable searching not only for the name of the model, but also the 
documentation of the model. 

Include tagged values 

Select from the drop-down menu any of the options to include tagged values: 
No - Do not include tagged value during searching 
Name - Include Name of tagged value only during searching 
Value - Include Value of tagged value only during searching 
Name and Value - Include both Name and Value during searching 

Model Types  

All model types 
This option is available only when Find in model is checked. This enables to search model elements 
with all types.  

Specified model types  
This option is available only when Find in model is checked. This enables you to search model 
elements with the same model type as the one specified from the list beneath it.  

Option  

Case Sensitive Check/Uncheck to determine whether or not a case sensitive or insensitive search is to be performed. 

Match whole words only  
Accept models only if their name and/or documentation match exactly the word specified in Text 
field.  

General commands 

Reset  Reset the changes made in the dialog box. 

Find  Find model elements according to the scope specified from the Find dialog box. 

Close  Close the Find dialog box without performing search. 

Help  Display the Help content of Find dialog box. 

Table 4.1 
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Search result will be displayed in the Find Results page of the Message pane. 

 

Figure 4.38 - Find result 

There are two types of results found. One is for displaying the model found and the other one is for displaying view found. 

 
Figure 4.39 - Types of result found 

 
You can copy, remove or clear result(s) by right-clicking on the result(s) and selecting the corresponding commands from the 
popup menu. 
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Jumping to Shape/Model 

In order to let you locate the desired shape/model easier and faster, the jump to shape/model facility is introduced. You can 
select either jump to a shape in the active diagram, or jump to any shape/model in the current project. 

Jumping to Shape in Active Diagram 

1. With a diagram active, select menu Edit > Jump to Element in Active Diagram..., or press the hotkey Ctrl + J. 

 

Figure 4.40 - Select Jump to shape in active diagram 

2. The jump to shape pane is shown. If you are uncertain about the name of the shape to jump to, press the Up/Down 
arrow key to popup the shape list and browse for it there. 

 

Figure 4.41 - Shape in the active diagram is shown 
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3. Upon the selection of an item in the list, extra information like the parent of the selected element is shown. If you keep 
selecting an item for one second, the corresponding element will be "spotlighted" in the diagram. 

 

Figure 4.42 - Spotlight on the diagram when select the shape 

4. When the spotlighting is in action, the jump to shape pane will reposition itself to avoid overlapping with the target 
shape if the Auto position option is selected. 

 

Figure 4.43 - Auto position 

5. If you know the name of the shape to find, you can type all or part of its name to filter the items in the list to locate the 
shape faster. Wildcard characters * (all combination of characters) and ? (any one character) can also be used. 

 

Figure 4.44 - Filter the shapes 
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6. With the desired item in the list selected, press the Enter Key. The corresponding element will be selected and 
centered in the diagram. 

 

Figure 4.45 - Auto select the shape and centered in diagram 

Jumping to Element in Project 

1. Select menu Edit > Jump to Element..., or press the hotkey Ctrl + Shift + J. 

 

Figure 4.46 - Select Jump to element 
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2. The 'jump to element' pane is shown. Similar to 'jump to shape' in the active diagram, you can press the Up/Down 
arrow key to popup the list of elements, and type text to filter the list. But this time the list is filled with all shapes and 
models in the project, regardless of the diagram they reside in. To let you identify which diagram a selected element 
comes from, its diagram name is also displayed. 

 

Figure 4.47 - Select the Element 

3. If the selected item refers to an element in the active diagram, this element will be spotlighted in the diagram. 

 

Figure 4.48 - Spotlight in the diagram 
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4. With the desired element in the list selected, press the Enter Key. If the selected element belongs to a diagram, this 
diagram will be opened, and the element will be selected and centered in the diagram. If the selected element is a 
model that does not have a view, it will be selected in the Model pane. 

 

Figure 4.49 - Select in Model pane 

Mouse Gesture 

Mouse gestures allow you to execute common commands and create UML models within the diagrams. 

Using Mouse Gesture in Windows 

To use mouse gestures in Windows, simply hold down the right mouse button and move the mouse to form the gesture (a blue 
path will be shown indicating your gesture). When you release the button, the gesture command will be executed. 

 
Figure 4.50 - Using mouse gesture in Windows 
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Using Mouse Gesture in Linux 

  

If you want to use mouse gestures in Linux, you can press the left mouse button on the diagram and drag the desired gesture 
while holding the Ctrl key, release the mouse button and key when done. 

 
Figure 4.51 - Using mouse gesture in Linux 

General Features 

  

The following is the 11 basic gestures supported by SDE for Eclipse: 

Gestures  Description  Gestures Descriptions 

 

Down V Right   

 

Down V Left  

 

Clockwise Rectangle*   

 

Counter Clockwise Rectangle*  

 

Folder Shape*   

 

Right V Left#  

 

Down V Up#   

 

Right V Left V Right V Down V Left V Up*#  

 

Left V Down V Right V Down V Left (squarish S)    

 

Right V Down V Left V Up - Right  
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Left V Down V Right V Up - Left       

Table 4.2 

The node is the start point of each gesture 
* Start at any point 
# Bi-directional 

A full list of gesture commands can be found in the Appendix C. 

 

 

 

Figure 4.52 - Mouse Gesture Example 

You can also draw with a Gesture Pen in the toolbar. 

 
Figure 4.53 - Draw with gesture pen 
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Gesture Start Point and Direction 

For the gestures marked as "Start at Any Point" like the Clock-wise Rectangle, start from any corner will give you the same 
result. And for the gestures marked as "Bi-directional" like "Right-Left" , start from right or left will also give you the same 
results. 

 

= 

 

= 

 

= 

 
              

 

= 

 

       

Figure 4.54 - Gesture Start Point and Direction 

Initial State and Final State 

The initial state and final state use the same gestures. The gesture will create an initial state if an initial state is not exist in the 
diagram, and a final state will be created if there is an initial state but no final state. If the diagram has both initial state and 
final state, the gesture will do nothing. 

Connecting Shapes using Mouse Gesture 

Right-click on a shape and then drag over another shape, release the mouse until you see the blue gesture path drawn between 
them. A connector will be created between the shapes, whose turning points are determined by the gesture path you dragged. 

 

Figure 4.55 - Create association 

If you drag the mouse gesture from a shape but release it over empty space of the diagram, a popup menu will appear for you to 
select a connector-shape pair. After selected a pair, a new shape together with a new connector of the selected types are created. 

Figure 4.56 - Create Use Case with Association 
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Creating Class Members using Mouse Gesture 

Creating Attribute 
Right-click on a class, drag to the left and release the mouse until you see the blue gesture line, an attribute will be created. 

 

Figure 4.57 - Create attribute 

Note that if you release the mouse OUTSIDE the class, the created attribute will be stereotyped as Property, and with its Setter 
and Getter properties automatically set to true. 

 

Figure 4.58 - Attribute created with getter and setter 

Creating Operation 
Right-click on a class, drag to the right and release the mouse until you see the blue gesture line, an operation will be created. 

 

Figure 4.59 - Create operation 

Note that if you release the mouse INSIDE the class, the created operation will have its visibility set to protected instead of 
public. 
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Sweeper 

A sweeper allows you to create space for placing shapes. 
To use sweeper: 
1. Click on the icon on the diagram toolbar. 

  

 
Figure 4.60 - Select Sweeper icon 

 

2. Click anywhere on the diagram while holding your left click, a plus sign will appear in the diagram.  

 
Figure 4.61 - Sweeper appears as Plus sign 
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3. You can then move the mouse left and right to create some horizontal spaces between shapes. 

 
Figure 4.62 - Use Sweeper to create horizontal Space 

 
4. Horizontal space created. 

 
Figure 4.63 - Horizontal space created 

 

Similarly, you can move the mouse up and down to create some vertical spaces between shapes. 

 
Figure 4.64 - Use Sweeper to create vertical space 
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Vertical space is created. 

 
Figure 4.65 - Vertical space is created. 

 

Customizing Data Types 

You can choose a programming language that your UML project is based on. By default, there are six types of languages. They 
are: 

•  Java 
•  XML Schema 
•  C++ 
•  Visual Basic 
•  C# 
•  UML 

Also, you can assign data type to attributes, operations (as return type) and parameters. Furthermore, new languages and data 
types can be added. 



SDE User’s Guide (Part 1)  Chapter 4 – Visual Modeling 

 

4-37 

Configuring Project Programming Language 

1. Right-click on the project root node under Diagram Navigator / Model pane / Class Repository  and then select Configure 
Programming Language... from the popup menu. 

 
Figure 4.66 - Select Configure Programming Language button 

2. Select the language to switch to. 

 
Figure 4.67 - Select language to switch to 
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3. The language is changed. The data type will be changed to match the language. 

 
Figure 4.68 - Language changed 
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Adding Languages and Data Types 

1. Select Modeling > Application Options... from the main menu. 

 
Figure 4.69 - Select Option button from main menu 
 

2. Open the Data Type page.  

 
Figure 4.70 - Open the Data Type page 
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3. Press on the plus sign and enter its name to add a language. 

 
Figure 4.71 - Add a language 

 

4. Press Add... and enter its name to add a data-type to the chosen language. 

 
Figure 4.72 - Add a data type 

 

5. A new language with data-type is added. 

 

  

 
Figure 4.73 - A new language with data-type is added 
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Chapter 5 - Automatic Diagrams Layout 

SDE for Eclipse provides a layout facility for arranging diagram elements in diagrams. It re-layouts the diagram elements so 
that they do not overlap, and the relationship links are arranged so that they will not cross over one another. Different layout 
styles and configurable options are provided, which allows for very flexible and sophisticated layouts to be adopted for 
diagrams. 

In this chapter: 

• Using diagram layout facility 
• Setting the diagram layout options 

Auto Layout 

Auto Layout can arrange the shapes by selecting the most suitable layout automatically. It is best for arranging the shapes when 
user has no special preference in choosing a specific layout. 

To apply Auto Layout  to the diagram, right-click on the diagram and select Layout > Auto Layout from the popup menu. 

 

Figure 5.1 - Select Auto Layout 

Class Diagram 

Hierarchy base (Factory class diagram) 
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Figure 5.2 - Hierarchy base (Factory class diagram) 

Navigation base (Mediator class diagram) 

 

Figure 5.3 - Navigation base (Mediator class diagram) 

Activity Diagram 

 

Figure 5.4 - Auto layout of activity diagram 
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State Machine Diagram 

 

Figure 5.5 - Auto layout of state machine diagram 

Communication Diagram 

 

Figure 5.6 - Auto layout of communication diagram 

Other Diagrams 

 

Figure 5.7 - Auto layout of other diagrams 
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Performing Layout 

• To layout all the diagram elements in the diagram, right-click on the diagram and select Layout from the popup menu.  
• To layout the selected diagram elements, right-click on the selection and select Layout from the popup menu (make 

sure there are more than one diagram elements selected). 

 

Figure 5.8 - Performing layout 

Orthogonal Layout 

Orthogonal Layout arranges shapes based on the topology-shape-metrics approach. It is best for arranging shapes and 
connectors in Class Diagrams. It is the default layout in SDE for Eclipse. Every time you drag the models from the Model 
Tree to a diagram, the orthogonal layout will be applied to arrange the newly created shapes in the Class Diagram. 

 

Figure 5.9 - Orthogonal Layout 
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Layout Grid Size: the virtual grid size for layout. Each shape will be placed in a way so that its center point lays on a virtual 
grid point. 

 

Figure 5.10 - Orthogonal Layout setting 

Hierarchic Layout 

Hierarchic Layout arranges shapes in a flow. It is best for arranging shapes that have hierarchical relationships such as 
generalization relationships and realization relationships.  

 

Figure 5.11 - Hierarchic Layout 
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Min. Layer Distance: the minimal horizontal distance between the shapes 
Min. Shape Distance: the minimal vertical distance between the shapes 
Min. Connector Distance: the minimal vertical distance of the connector segments 
Orientation : the layout direction for arranging nodes and connectors -top to bottom, left to right, bottom to top, and right to 
left 
Shape Placement: affects the horizontal spacing between shapes, and the number of bends of the connectors -pendulum, linear 
segments, polyline, tree, simplex 
Connector Style: the style of the connectors -polyline style or orthogonal style 

 

Figure 5.12 - Hierarchic Layout setting 

Directed Tree Layout 

Directed Tree Layout is one of the tree layouts in SDE for Eclipse. It can arrange shapes in a tree structure. It is best for 
arranging shapes except those which have hierarchical relationships such as generalization relationships and realization 
relationships. 

 

Figure 5.13 - Directed Tree Layout 
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Min. Layer Distance: the minimal horizontal distance between the shapes 
Min. Shape Distance: the minimal vertical distance between the shapes 
Orientation : the layout direction for arranging nodes and connectors - top to bottom, left to right, bottom to top, and right to 
left 
Connector End Point Style: how the connector end points will be placed - shape centered, border centered, border distributed 
Orthogonal Connector: whether the connectors will be arranged in orthogonal style 

 

Figure 5.14 - Directed Tree Layout Setting 

Balloon Tree Layout 

Balloon Tree Layout is one of the tree layouts in SDE for Eclipse. It can arrange shapes in a tree structure in a radial fashion. It 
is best for arranging large trees. 

 

Figure 5.15 - Balloon Tree Layout 
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Min. Connector Length: the minimal distance between the connectors and shapes 
Preferred Child Wedge: the angle at which the child node will be placed around its parent node 
Preferred Root Wedge: the angle at which a node will be placed around the root node 
Root Node Policy: determines which node is chosen as the tree root node for layout - directed root, center root, and weighted 
center root 

 

Figure 5.16 - Balloon Tree Layout Setting 
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Compact Tree Layout 

Compact Tree Layout is one of the tree layouts in SDE for Eclipse. It can arrange shapes in a tree structure. You can set the 
aspect ratio (relation of tree width to tree height) of the resultant tree. 

 

Figure 5.17 - Compact Tree Layout 
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Horizontal Spacing: the horizontal spacing between the shapes 
Vertical Spacing: the vertical spacing between the shapes 
Min. Connector Length: the vertical distance of the connector segments 
Aspect Ratio: the relation of the tree width to the tree height 

 

Figure 5.18 - Compact Tree Layout Setting 

Horizontal-Vertical Tree Layout 

Horizontal-Vertical Tree Layout is one of the tree layouts in SDE for Eclipse. It can arrange shapes in a tree structure 
horizontally and vertically. 

 

Figure 5.19 - Horizontal-Vertical Tree Layout 
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Horizontal Spacing: the horizontal spacing between the shapes 
Vertical Spacing: the vertical spacing between the shapes 

 

Figure 5.20 - Horizontal-Vertical Tree Layout Setting 

BBC Compact Circular Layout 

BBC Compact Circular Layout is one of the circular layouts in SDE for Eclipse. It can arrange shapes in a radial tree structure. 
The detected group is laid out on the separate circles. It is best for arranging shapes that belongs to more than one group with a 
ring structure. 

 

Figure 5.21 - BBC Compact Circular Layout 
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Maximal Deviation Angle: the maximal angle of deviation 
Preferred Child Wedge: the angle at which the child node will be placed around its parent node 
Minimal Edge Length: the minimal distance between the shapes 
Compactness Factor: the parameter that affects the length of connector. The smaller the compactness factor, the length of 
connectors will be shorter and the layout will be more compact. 
Allow Overlaps: whether the shape can be overlapped 

 

Figure 5.22 - BBC Compact Circular Layout Setting 
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BBC Isolated Circular Layout 

BBC Isolated Circular Layout is one of the circular layouts in SDE for Eclipse. It can arrange shapes into many isolated ring 
structures. It is best for arranging shapes that belong to one group with ring structure. 

 

Figure 5.23 - BBC Isolated Circular Layout 

The attributes of this layout is the same as BBC Compact Circular Layout. 

Single Cycle Circular Layout 

Single Cycle Layout is one of the circular layouts in SDE for Eclipse. It can arrange shapes in circular structure in single circle. 

 

Figure 5.24 - Single Cycle Circular Layout 
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Choose radius automatically: determine the radius of circular structure automatically or manually 
Minimal Node Distance: the minimal distance between the nodes 
Fixed radius: the radius of circular structure 

 

Figure 5.25 - Single Cycle Circular Layout Setting 

Organic Layout 

Organic Layout is one of the organic layouts in SDE for Eclipse. It can arrange shapes in a star or ring structure. It is best for 
arranging the shapes that have highly connectivity relationship. 

 

Figure 5.26 - Organic Layout 
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Activate Deterministic Mode: whether the layouter is in deterministic mode 
Activate Tree Beautifier: whether or not to activate the subtree beautifier 
Attraction:  the degree of the attraction between shapes 
Final Temperature: the factor that affects the distance between shapes 
Gravity Factor:  the factor that affects the distance between shapes and the center 
Initial Placement: the initial value of placement 
Initial Temperature:  the initial value of temperature 
Iteration Factor:  the degree of iteration 
Maximum Duration:  the maximum degree of duration 
Obey Node Size: the size of obey shapes 
Preferred Edge Length: the preferred length between the nodes 
Repulsion: the factor that affects the distance between shapes which belong to the same ring or star structure 

 

Figure 5.27 - Organic Layout Setting 
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Smart Organic Layout 

Smart Organic Layout is one of the organic layouts in SDE for Eclipse. It is a variant of the Organic Layout. It can set the ratio 
of the quality : producing time of layout and controls the compactness of layout. 

 

Figure 5.28 - Smart Organic Layout 

Compactness: the factor that sets less/more compact layout.  
Deterministic: whether the layouter is in deterministic mode 
Minimal Node Distance: the minimal distance between nodes 
Node Overlaps Allowed: whether the node can be overlapped 
Node Size Aware: whether the node size can be aware 
Preferred Minimal Node Distance: the preferred minimal distance between the nodes 
Quality Time Ratio:  the ratio of the quality of layout to the producing time of layout 

 

Figure 5.29 - Smart Organic Layout Setting 
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Organic Edge Route Layout 

Organic Edge Route Layout is one of the edge route layouts in SDE for Eclipse. It can arrange the connectors without affecting 
the location of shapes. It can ensure that the shapes will not overlap and keep a specific minimal distance. 

 

Figure 5.30 - Organic Edge Route Layout 

Minimal Distance: the minimal distance of the connectors 
Route All:  whether all the connectors will be routed 
Use Existing Bends: whether using existing bends 

 

Figure 5.31 - Organic Edge Route Layout setting 
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Orthogonal Edge Route Layout 

Route Connectors can arrange the connectors using vertical and horizontal line segments only. It is best for arranging the 
connectors that have complicated route. 

 

Figure 5.32 - Orthogonal Edge Route Layout 

Center to space ratio: the ratio of center to the distance between center and nodes 
Coupled distances: the distance between coupled nodes 
Crossing cost: the cost of crossing connector 
Custom border capacity: the capacity of the border 
Local crossing minimization: whether the local crossing of connectors will be minimized 
Minimum distance: the minimum distance of connectors 
Minimum distance to node: the minimum distance between the shapes 
Rerouting: whether the connector that has many crossings will be rerouted 
Routing style: the style of routing 

 

Figure 5.33 - Orthogonal Edge Route Layout setting 
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Chapter 6 - Generating Documentation 

SDE for Eclipse provides several report generation facilities for documenting your the project. Report Writer streamlines your 
work by keeping the project and document in sync. HTML/PDF report generation facility outputs your project as web pages 
and PDF documents, portable to different platforms and environments. Word report generation outputs reports in MS Word 
format. Project Publisher exports the project into interactive web pages that can be read in any web browsers with no additional 
plug-in required. Report Writer can extract data from models. Features of sorting elements allow you to prepare a systematic 
report. 

 

In this chapter: 

• PDF Report Generation 
• Word Report Generation 
• HTML Report Generation  
• Project Publisher 
• Report Writer 
• Sorting Element in Report 

A report is generated by converting project or diagrams in SDE for Eclipse to other types of document, such as HTML and 
PDF.  
With report, users without SDE for Eclipse can still read the project and diagrams. For example, if the user has installed a 
browser, he can read the SDE for Eclipse project if the project is converted to HTML report. 

Although both HTML report generation and Project Publisher can generate web pages, they are different. For HTML report, it 
is a document-like presentation. All the content is shown in one page. On the other hand, for project publisher, it acts like a 
viewer, allowing reader to browse the project content. There are 3 views - Diagram, Model, Class. Each one is a perspective of 
the project.  
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PDF Report Generation 

 

The Generate PDF Dialog Box 

The Generate PDF dialog box provides a set of options for changing the report style. To display the dialog box, perform one 
of the following actions: 

• Select Modeling > Report > PDF... from main menu. 

 

Figure 6.1 - Generate PDF Dialog 

Field  Description  

Output path 
To select the destination file for the generated report. You can type the path in the text field or you 
can browse the location by clicking on the ...button. 

Launch viewer  
If this option is selected, the default browser of the system will be opened automatically to show 
the generated document.  

Generate table of contents If this option is selected, table of content for this document will be generated to the report 

Generate table of figures If this option is selected, table of figures for this document will be generated to the report 

Generate diagrams If this option is selected, the image of the selected diagrams will be generated to the report. 

Generate diagram 
properties 

If this option is selected, the properties of the selected diagrams will be generated to the report. 

Generate diagram 
summary 

If the option is selected, the summary of the selected diagrams will be generated to the report. 

Generate reference 
(file/URL) link 

Select to generate links for referenced files/URLs defined in models. 
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Generate models/diagrams 
link  

Select to generate links for navigating to related models and diagrams. 

Shape type style 
Icon - using Icon to represent the type of shape and diagram elements 
Text - using text to represent the type of shape and diagram elements 

Sort element by 

Automatic - sorting elements by listing them in the most logical order, which is to follow most 
users’ understanding of that kind of diagram 
Follow tree - sorting elements by following the sort order of the diagram tree in the tool 
id or name - sorting elements by their ID or names 
You can refer to the section 'Sorting Elements in Report'. 

Details 

Children Select to generate children of model 

Members Select to generate members of model 

Properties Select to generate properties of model  

Relationships Select to generate relationships of model  

References Select to generate references of model  

Sub-diagrams Select to generate sub-diagrams of model  

Tagged values Select to generate tagged values of model  

Comments Select to generate comments of model  

Anti-aliasing 

Graphics  To enable/disable the graphic anti-aliasing of the diagram images. 

Text  To enable/disable the text anti-aliasing of the diagram images. 

Table 6.1 
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Generating a PDF Report 

To generate a PDF Report: 

1. Open the Generate PDF dialog box.  
2. Enter the destination location of the generated document in the Output path field.  
3. Select the report options, such as Generate diagrams, Generate reference (file/URL) link, etc...if necessary.  
4. Select the details field such as Children, Members. 
5. Define the page settings for the report.  
6. Define advanced report information such as Header/Footer and Document Info if necessary.  
7. Select the diagrams to generate in the report.  
8. Click Generate to start generating the report.  

 

Figure 6.2 - PDF Report 
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Figure 6.3 - The Generated PDF Report 

Configuring Image Quality 

There are two image quality options for the PDF Report: Anti-aliasing for Graphic and Text. 

As the dimension of the paper limits the size of the image in the PDF report, SDE for Eclipse provides an extra image quality 
option in the PDF report to control how the output image will be displayed in the report. 

To change the diagram quality option, select the Anti-aliasing option. 

 

Figure 6.4 - Define image quality 
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Configuring the page information 

This option allows the user to define the page settings, such as the paper size and orientation of the report. To configure the 
page settings: 

1. Open the Generate PDF Report dialog box.  
2. Select the Page tab.  

 

Figure 6.5 - Page setup 

Field Description  

Page size  To select the paper size of the generated report. 

Page Orientation  This option is used to select the orientation of the report (portrait/landscape). 

Page Margin  To specify the page margins of the report. 

Table 6.2 

Selecting the Page size  

SDE for Eclipse supports a wide range of page sizes for PDF report generation. Different paper sizes can be selected in the 
Page size drop-down menu. 

 

Figure 6.6 - Select the Page Size 
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Selecting the Page Orientation 

To select the page orientation for the output report, select the desired orientation option in the Page Orientation section. 

 

Figure 6.7 - Select the Page Orientation 

Adjusting the Page Margins 

To adjust the page margins enter the value in the text box at the margin side you want to adjust, or drag the margin in the 
preview page. 

 

Figure 6.8 - Adjust the page margin 
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Defining a Header/Footer 
To define the Header/Footer of the document: 

1. Open the Generate PDF Report dialog box.  
2. Select the Header/Footer tab.  
3. Insert text or picture in header or footer section to include header/footer in the report.  

 

Figure 6.9 - Define a Header/Footer 

Three sections, Left Section, Center Section and Right Section, are predefined  for users to insert text, or even pictures, page 
numbers, time, etc to the report Header and Footer. A separator can be added to the report in order to separate the region 
between Header, Content and Footer. 

Defining the Header/Footer Style 

SDE for Eclipse supports several types of header/footer style for the PDF report. They are described in the table below: 

Header/Footer Style Description  

 
To format text style, such as font style, size and color. 

 
To insert an image to the header or footer 

 
Insert page number 

 
Insert page count 

 
Insert date 

 
Insert time 

 
Insert project name 

 
Insert report file name 

 
Insert user name 

Table 6.3 
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Defining Document Info 
To define the document info: 

1. Open the Generate PDF dialog box.  
2. Select the Document Info page.  

 

Figure 6.10 - Define Document Info 

Field  Description  

Title  The title of the report. 

Author  The author of the report.  

Subject The subject of the report.  

Keywords The keywords of the report.  

Info header The info header of the report.  

Info header content The info header content of the report.  

Allow modify Select to allow modification on the report.  

Table 6.4 
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Figure 6.11 - The generated PDF Document Info 

Defining a Cover Page 

To define the Cover Page 

1. Open the Generate PDF Report dialog box.  
2. Select the Cover Page tab.  
3. Check the Generate Cover Page checkbox to include Cover Page in the report.  
4. Enter information such as Logo image path for the background, Report Title, Organization name and Author 

Name.  

 

Figure 6.12 - Define the cover page 
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Word Report Generation 

 

The Generate Word Dialog Box 

The Generate Word dialog box provides a set of options for changing the report style. To display the dialog box, perform one 
of the following actions: 

• Select Modeling > Report > Word... from main menu. 

 

Figure 6.13 - Generate Word Dialog 

Field  Description  

Output path  
To select the destination path for the generated report. You can type the path in the text field or 
you can browse the location by clicking on the ...button. 

Launch viewer  
If this option is selected, the default application of the system will be opened automatically to 
show the generated document.  

Generate table of contents If this option is selected, table of content for this document will be generated to the report 

Generate table of figures If this option is selected, table of figures for this document will be generated to the report 

Generate diagrams If this option is selected, the image of the selected diagrams will be generated to the report. 

Generate diagram 
properties 

If this option is selected, the properties of the selected diagrams will be generated to the report. 

Generate diagram 
summary 

If the option is selected, the summary of the selected diagrams will be generated to the report. 

Generate reference 
(file/URL) link 

Select to generate links for referenced files/URLs defined in models. 

Generate models/diagrams 
link  

Select to generate links for navigating to related models and diagrams. 
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Shape type style 
Icon - using Icon to represent the type of shape and diagram elements 
Text - using text to represent the type of shape and diagram elements 

Sort element by 

Automatic - sorting elements by listing them in the most logical order, which is to follow most 
readers’ understanding to that kind of diagram 
Follow tree - sorting elements by following the sort order of the diagram tree in the tool 
id or name - sorting elements by their id or names 
You can refer to the section 'Sorting Elements in Report'. 

Details 

Children Select to generate children of model. 

Members Select to generate members of model. 

Properties Select to generate properties of model.  

Relationships Select to generate relationships of model.  

References Select to generate references of model.  

Sub-diagrams Select to generate sub-diagrams of model.  

Tagged values Select to generate tagged values of model.  

Comments Select to generate comments of model.  

Anti-aliasing 

Graphics  To enable/disable the graphic anti-aliasing of the diagram images. 

Text  To enable/disable the text anti-aliasing of the diagram images. 

Table 6.5 
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Generating a Word Report 

To generate a Word Report: 

1. Open the Generate Word dialog box.  
2. Enter the destination location of the generated document in the Output path field.  
3. Select the report options, such as Generate diagrams, Generate reference (file/URL) link, etc...if necessary.  
4. Select the details field such as Children, Members.  
5. Define the page settings for the report.  
6. Define advanced report information such as Header/Footer and Document Info if necessary.  
7. Select the diagrams to generate in the report.  
8. Click Generate to start generating the report.  

 

 

Figure 6.14 - The Generated Word Report 

Configuring Image Quality 

There are two image quality options for the Word Report: Anti-aliasing for Graphic and Text. 

Since the dimension of the paper limits the size of the image in the Word report, SDE for Eclipse provides an extra image 
quality option in the Word report to control how the output image will be displayed in the report. 

To change the diagram quality option, select the Anti-aliasing option. 

 

Figure 6.15 - Define image quality 
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Configuring the page information 

This option allows the user to define the page settings, such as the paper size and orientation of the report. To configure the 
page settings: 

1. Open the Generate Word Report dialog box.  
2. Select the Page tab.  

 

Figure 6.16 - Page setup 

Field Description  

Page size  To select the paper size of the generated report. 

Page Orientation  This option is used to select the orientation of the report (portrait/landscape). 

Page Margin  To specify the page margins of the report. 

Table 6.6 

Selecting the Page size  

SDE for Eclipse supports a wide range of page sizes for Word report generation. Different paper sizes can be selected in the 
Page size drop-down menu. 

 

Figure 6.17 - Select the Page Size 
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Selecting the Page Orientation 

To select the page orientation for the output report, select the desired orientation option in the Page Orientation section. 

 

Figure 6.18 - Select the Page Orientation 

Adjusting the Page Margins 

To adjust the page margins enter the value in the text box at the margin side you want to adjust, or drag the margin in the 
preview page. 

 

Figure 6.19 - Adjust the page margin 
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Defining a Header/Footer 
To define the Header/Footer of the document: 

1. Open the Generate Word Report dialog box.  
2. Select the Header/Footer tab.  
3. Insert text or picture in header or footer section to include a header/footer in the report.  

 

Figure 6.20 - Define a Header/Footer 

Here, a separator can be added to the report to separate the region between Header, Content and Footer. 

Defining the Header/Footer Style 

SDE for Eclipse supports several types of header/footer style for the Word report. They are described in the table below: 

Header/Footer Style Description  

 
To format text style, such as font style, size and color. 

  
To align content to left. 

 
To align content to center. 

 
To align content to right. 

 
To insert an image to the header or footer 

 
Insert page number 

 
Insert page count 

 
Insert date 

 
Insert time 

 
Insert project name 
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Insert report file name 

 
Insert user name 

Table 6.7 

Defining Document Info 
To define the document info: 

1. Open the Generate Word dialog box.  
2. Select the Document Info page.  

 

Figure 6.21 - Define Document Info 

Field  Description  

Title  The title of the report. 

Author  The author of the report.  

Subject The subject of the report.  

Keywords The keywords of the report.  

Table 6.8 
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Defining a Cover Page 

To define the Cover Page 

1. Open the Generate Word Report dialog box.  
2. Select the Cover Page tab.  
3. Check the Generate Cover Page checkbox to include Cover Page in the report.  
4. Enter information such as Logo image path, Title , Organization name and Author Name.  

 

Figure 6.22 - Define the cover page 
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HTML Report Generation 

 

 

Figure 6.23 - HTML Report 
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The Generate HTML Dialog Box 

The Generate HTML dialog box provides a set of options for changing the report style. To display the dialog box, perform 
one of the following actions: 

• Select Modeling > Report > HTML... from main menu. 

 

Figure 6.24 - Generate HTML dialog 

Field  Description  

Output path 
To select the destination file for the generated report. You can type in the path in the text field or 
you can browse the location by clicking on the ... button. 

Launch viewer  
If this option is selected, the default browser of the system will be open automatically to show the 
generated report.  

Generate table of contents If this option is selected, table of contents for this document will be generated to the report.  

Generate table of figures If this option is selected, table of figures for this document will be generated to the report.  

Generate diagrams If this option is selected, the image of the selected diagrams will be generated to the report. 

Generate diagram 
properties 

If this option is selected, the properties of the selected diagrams will be generated to the report. 

Generate diagram summary If the option is selected, the summary of the selected diagrams will be generated to the report. 

Generate reference 
(file/URL) link  Select to generate links for referenced files/URLs defined in models. 

Generate models/diagrams 
link  Select to generate links for navigating to related models and diagrams. 

Copy reference files Select to copy referenced files defined in models to the report output directory.  

Shape type style Icon - using Icon to represent the type of shape and diagram elements 
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Text - using text to represent the type of shape and diagram elements  

Sort element by 

Automatic - sorting elements by listing them in the most logical order, following most readers’ 
understanding of that kind of diagram 
Follow tree - sorting elements by following the sort order of the diagram tree in the tool 
id or name - sorting elements by their id or names 
You can refer to the section 'Sorting Elements in Report' near the bottom of this chapter. 

Details 

Children Select to generate children of model. 

Members Select to generate members of model. 

Properties Select to generate properties of model. 

Relationships Select to generate relationships of model.  

References Select to generate references of model.  

Sub-diagrams Select to generate sub-diagrams of model.  

Tagged values Select to generate tagged values of model.  

Comments Select to generate comments of model.  

Anti-aliasing  

Graphics To enable/disable the graphic anti-aliasing of the diagram images. 

Text  To enable/disable the text anti-aliasing of the diagram images. 

Print Diagrams  To select which diagram will be generated in the report. 

Table 6.9 
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Generating an HTML Report 

To generate an HTML Report: 

1. Open the Generate HTML dialog box.  
2. Specify the destination location of the report in the Output path field.  
3. Configure the report properties, such as Generate diagrams, Generate reference (file/URL) link, etc...if necessary.  
4. Select the template of the report that will be generated.  
5. Select the diagram's image quality if Generate diagrams is selected.  
6. Define advanced report information such as Front Page and Document Info if necessary.  
7. Select the diagram to generate in the report.  
8. Click Generate to start generating the report.  

 

 

 

Figure 6.25 - Generating HTML report Figure 6.26 - The generated HTML report 

Configuring Image Quality 

There are two image quality options for the HTML Report: graphics and text anti-aliasing. To enable/disable the anti-aliasing 
options, check/uncheck the anti-aliasing options checkbox. The below two images show the difference in graphics with anti-
aliasing enabled (left) and graphics with anti-aliasing disabled (right). 

  

Figure 6.27 - Images with anti-aliasing Figure 6.28 - Images without anti-aliasing 
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Configuring the Document Info 

To define the document info: 

1. Open the Generate HTML dialog.  
2. Select the Document Info tab.  

 

Figure 6.29 - Define the Document Info 

Field  Description  

Title  Specify the title of the HTML report. 

Author  Specify the author of the HTML report. 

Keywords  Specify the keywords meta-tag of the HTML report. 

Table 6.10 
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Defining a Front Page 

To define the Front Page 

1. Open the Generate HTML Report dialog box.  
2. Select the Front Page tab.  
3. Check the Generate front page checkbox to include a Cover Page in the report.  
4. Enter information such as a Logo image path for the background, Title , Organization name, Author Name etc.  

 

Figure 6.30 - Define the front page 

Project Publisher 

 
The Project Publisher is a tool that exports the project, including detailed information in diagrams and models, into interactive 
and well-organized web pages. The generated web pages can be read in any web browser with no additional plug-in required, 
so collaborative partners may see the published product even if they do not have Visual Paradigm products installed. 

Launching Project Publisher 

To launch Project Publisher, perform one of the following actions: 

• Select Modeling > Project Publisher... from main menu. 

The Project Publisher dialog box appears. 
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Using Project Publisher 

To publish the project, you need to enter the Output directory  where the published files will be saved to. You may select the 
Launch viewer option so the default web browser on your computer will open the index page of the published project when 
the process is completed. 

 

Figure 6.31 - Project Publisher 

Click OK  to start publishing. The progress dialog box will appear while generating the content and a 'Project publishing 
complete' message will show once it is done. 
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Using the Published Project 

Go to the output directory of the published project and open the file 'index.html ' with a web browser. The web page is 
organized in frames, namely the Navigator Pane, Menu Pane and Content Pane. 

 

Figure 6.32 - Published project 

Navigator Pane 
It comprises of the Diagram Navigator, Model Navigator and Class Navigator. 

• Diagram Navigator shows the categories of diagrams in the project. You can click on a category to view its diagrams 
in the Menu Pane, or click Show All Diagrams to view all diagrams.  

 

Figure 6.33 - Diagram Navigator 
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• Model Navigator shows the Package models in the project. You can click on a Package to view its child models in 
the Menu Pane, or click Show All Models to view all model elements.  

 

Figure 6.34 - Model Navigator 

• Class Navigator shows the Package models in the project. You can click on a Package to view its child 
packages/classes in the Menu Pane, or click Show All Models to view all packages/classes.  

 

Figure 6.35 - Class Navigator 

Menu Pane 
It shows the sub-menus of the Navigator pane. The contents shown in this pane varies with the link you clicked in the 
Navigator Pane. For more details about the possible contents please refer to the Navigator Pane section. 
To view the details of an item (diagram, model or package/class), click on its link in the Menu Pane and its details will be 
shown in the Content Pane. 

 

Figure 6.36 - Menu Navigator 

Content Pane 
It shows the details of the item (diagram, model or package/class) you clicked in the Menu Pane or Content Pane. 
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Diagram Content 

 

Figure 6.37 - The Diagram Content 

The diagram type, name, description, together with a full size image of the diagram are shown in the Content Pane. The image 
is mapped to different clickable regions for each shape, so you can click on a shape in the image to view its details. 

 

Figure 6.38 - Shape link to the descriptions 
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Using Jump to 
The Jump to combo box in the diagram content page lists all shapes in the diagram, you can select a shape to jump to. The 
content page will scroll to the selected shape and the shape will be highlighted by a red border. 

 

Figure 6.39 - Jump to an element 

Besides, there will be two shortcut buttons above the selected shape. 

• The Back to top button brings you to the top of the page.  

 

Figure 6.40 - Back to top button 

• The Open specification button brings you to the details page of the shape.  

 

Figure 6.41 - Open Specification button 
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Models 
The Models section of the diagram content page shows the name, type and documentation of the models of all shapes in the 
diagram. You can click on the link of a model to view its details. 

 

Figure 6.42 - Model list 

Model Content 

 

Figure 6.43 - The Model Content 

The type, name and general model properties of a model are shown in the content page. 
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Parent Hierarchy 

The parent hierarchy is shown as a list of models on top of the page. You can click on a parent in the hierarchy to view its 
details. 

 

Figure 6.44 - Parent Hierarchy 

Relationships 

The summary of the relationships of the model is shown in the Relationships Summary section. Click on a relationship and it 
will take you to the Relationships Detail section. 

 

Figure 6.45 - Relationship summary 

Other Model Details 

Certain types of model have their own properties, for example, attributes and operations of class, or columns of ERD table. 
They are also included in the content page as custom sections. For instance, the Operations Overview and the Operations 
Detail sections show the overview and details of the operations of a class respectively. 

 

Figure 6.46 - Other Class details 
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Report Writer 

 
The Report Writer is a sophisticated tool for report creation. Users can output the existing project as reports by documenting 
their project within SDE for Eclipse. SDE for Eclipse offers seamless integration of UML modeling tool with word processors 
to provide a unified documenting environment. By dragging the models from SDE for Eclipse to Report Writer, data is 
extracted from models and content is created in Report Writer. 

Retaining the conformance between documentation and design is a tedious task. Report Writer maintains the consistency 
between them. If you create a new model, the content will be appended to the existing one. If you remove a model, the 
generated element will be removed. If you re-edit the models, the content will be refreshed. 

Users can also apply their own style for the generated element, to the Report Writer more flexible. 

Launching Report Writer 

To launch Report Writer, perform one of the following actions: 

• Select Modeling > Report > Writer... from main menu. 

Installing Report Engine 
If it is the first time you have started the Report Writer, the Report Engine Installation dialog box will be displayed asking for 
the installation of Report Engine. 

 

Figure 6.47 - Report Engine Installation Dialog 

To install Report Engine, perform one of the following actions: 

• Choose from the Report Engine Installation dialog box the option Download from Internet and click OK . This 
downloads the Report Engine from the Internet and automatically proceeds with Report Engine installation once the 
download has been completed.  

• Choose from the Report Engine Installation dialog box the option 'Select in local file system', locate the report 
engine and then click OK  to start the Report Engine installation. The Report Engine can be obtained by clicking 
'Download with browser'. You can enter the path directly into the text field or click ... to locate the file from the file 
chooser.  
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Entering Report Information 
Upon launching Report Writer for the first time, the Template dialog box will be displayed and ask for the information of the 
new report. Enter the report information and select a desired report theme for the report, preview of the selected theme is 
shown on the preview pane. Click OK  to start Report Writer when everything is ready. 

 

Figure 6.48 - Templates Dialog 
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Panes 

When Report Writer is launched you are taken to the Report Writer environment where you can create and edit your reports. 
Three distinct panes are presented on the screen: the Project Explorer, Template Pane and the Writer Pane. 

 

Figure 6.49 - Report Writer 
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Diagram Navigator 
The Diagram Navigator displays all diagrams within the project in a form of a project tree and organizes them by their 
diagram type. Through the use of a folding tree structure you can browse the names of these diagrams by either expanding or 
collapsing the folders and perform sorting by diagram type and name. 

 

Figure 6.50 - Diagram Navigator 

Button  Icon  Description  

Collapse  To collapse all the nodes within the project tree.  

Expand  To expand all the nodes within the project tree.  

Show Diagram View  To show only diagrams but not models in the tree.  

Sort by Name  To sort diagrams within the project tree by alphabetical order of their names  

Sort by Type   To sort diagrams within the project tree by their diagram type. 

Move Selected Model Up    To move selected models upwards.   

Move Selected Model Down    To move selected models downwards.   

Refresh   To refresh the project tree within the Diagram Pane. 

Table 6.11 
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Model Tree 
The Model Pane displays models within the project in a form of a project tree. Notice that not all the model elements are 
displayed, and only the elements that are available for generating report content are shown. 

 

Figure 6.51 - Model Tree 

Button Icon Description  

Collapse  To collapse all the nodes within the project tree.  

Expand  To expand all the nodes within the project tree.  

No Sorting  
To display the models within the project without sorting. Ordering of models will be based on 
their order of creation.  

Sort by Name   To sort models within the project tree by alphabetical order of their names  

Sort by Type   To sort models within the project tree by their model type. 

Move Selected Model 
Up   To move the selected models upwards.  

Move Selected Model 
Down  To move the selected models downwards.  

Refresh   To refresh the project tree within the Model Pane. 

Table 6.12 

Template Pane 
The Template Pane displays all the templates available for the model or diagram selected in Property Pane. 

 

Figure 6.52 - Template Pane 



SDE User’s Guide (Part 1)  Chapter 6 –Generating Documentation 

 

6-38 

Each template represents the corresponding report content of a particular model or diagram. By dragging a template into the 
Writer Pane, the report content will be printed on the report. There are three types of template: Text, Image and Table. Each 
of them has its own appearance in the report content. 

Type Icon  Description  

Text  
 

The generated element block is mainly composed of text. It is mainly used in the documentation template of 
elements. 

Image 
 

The generated element block is mainly composed of images. It is used in the diagram template for UML 
Diagrams. 

Table  
 

The generated element block is mainly composed of tables. Most of the content-related templates use this type 
of template.  

Table 6.13 

Writer Pane 
Writer Pane embeds a word processor to provide a report editing environment. 

Figure 6.53 - Writer Pane 
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Toolbar 

Toolbar is the horizontal bars placed below the menu bar. They store all the frequently used commands that appear as a row of 
buttons. 

Icon Button  Function  

 New Report...  To create a new report.  

 Save Report To save modified reports. 

 Import Report...  
To import an external document (either an .sxw or a .doc file) 
as a report. 

 Export Report...  To export the current report as an .sxw or .doc file. 

 Export All Reports...  To export all the reports within the current project. 

 Update from Model  
To update the content within the current report from the SDE 
for Eclipse models. 

 Print Report...  To print the current report by supplying the printer name. 

 Undo To undo the last action you performed.  

 Redo To redo the last action you performed.  

 
Select Report  To select a report from the current project for editing. 

 Remove Report...  To remove the existing report(s). 

 Click to Show Stylist  To display the stylist dialog box for modifying the style. 

 Copy Style to Current Report  To copy the style settings defined in another report. 

 Click to Show Bookmarks  
To display bookmarks that outlines the boundary for each 
generated element. 

 Insert Hyperlink To insert a hyperlink. 

 
Click to Generate Model 
Documentation 

To include documentation of model when generating content.  

 Close Report Dialog  To close Report Writer and go back to SDE for Eclipse. 

Table 6.14 
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Constructing a Report 

Creating a Generated Element 
The term "Generated element" here means a block of report content generated by Report Writer and consists of details of a 
particular diagram or model element. 

To create a generated element block: 

1. Click to select the desired model element from either the Diagram Navigator or Mode Tree for content generation.  
2. The supported templates for the selected model element are shown on the Template Pane. Each template represents a 

way in presenting the selected model element on the report. For example, "Children" template of a System represents 
a list of children placed inside a particular System.  

 

Figure 6.54 - Template Pane 

3. Drag the desired template from the Template Pane and drop it onto the report.  

 

Figure 6.55 - Drag the template from template pane and drop it onto report 

 



SDE User’s Guide (Part 1)  Chapter 6 - Generating Documentation 

 

6-41 

4. When the cursor drags over the Writer Pane, a tiny straight line �will appear in the report indicating the position of 
the expected position of the generated element. Once you've dropped the template onto the report, corresponding 
content will be generated element to the dropped position.  

 

Figure 6.56 - Drag the template to report 

 

The update process will replace ALL the contents within each generated element without notification. 
Therefore please insert the content carefully and ensure that it is not located inside the scope of any 
generated elements.  

 
To create a new report, select from main menu Report > New Report...or click on the New Report...button 
on the toolbar.  

Showing the Bookmarks 
Creating a new generated element within the boundary of an existing one is dangerous because the content may be messed up 
during a report update process. To avoid this, you can display bookmarks to indicate the start and end position of each 
generated element, and to prevent dropping a new one within the scope of the existing generated element. 

 

Figure 6.57 - Showing bookmarks 

To show/hide bookmarks: 

• Check/Uncheck Tool > Show Indicator from main menu to show/hide bookmarks.  
• Select/Deselect Click to Show Bookmarks/Click to Hide Bookmark on the toolbar to show/hide bookmarks.  
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Applying Style to Report 

A style in Report Writer is a collection of formatting attributes that describe the nature of paragraphs. The generated element 
highly adopts the predefined styles in Report Writer therefore users can customize the related styles to bring consistency to the 
whole document. There are two ways for applying style to report. 

Style configuration 
The Stylist dialog box allows you to configure the pre-defined styles. To display the Stylist dialog box: 

• Select Tool > Show Stylist from main menu.  

• Click the Click to Show Stylist button  on the toolbar.  

In both cases, the Stylist dialog box display.  

 

Figure 6.58 - Stylist 
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To edit the style, right-click on the highlighted style and choose Modify... from the popup menu. This displays the dialog box 
for the selected style. You can now adjust it with your own preference. When everything is ready, please click OK  to commit 
the settings and exit the dialog. 

 

Figure 6.59 - Edit Paragraph Style 

The changes will take effect immediately and you will notice the style is applied to those generated elements using the same 
style. 

 

Figure 6.60 - Style Change 
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Loading Style from Other Report 
The Copy Style dialog box allows you to copy the style from existing report. To display the Copy Style dialog box: 

• Select Tool > Copy Style from main menu.  

• Click the Copy Style to Current Report button  on the toolbar.  

In both cases, the Stylist dialog box display. 

 

Figure 6.61 - Copy Style Dialog 

Select a desired report for getting the style configuration and click Copy Style. The style configuration in the current report is 
replaced by the style configuration of the selected report. All the predefined styles will be overwritten. 

Updating Table of Contents 

There is a predefined Table of Contents in each of the report template. Here is the pre-built Table of Contents structure: 

Level  Paragraph Style  

0 Heading 1 (VP)  

1  Heading 2 (VP) 

2  Heading 3 (VP)  

3 - 9 None  

Table 6.15 

To update the Table of Contents, right-click on the caption Table of Contents and select Update Index/Table from popup 
menu. 

Exporting a report 

You can export report as file and edit it outside SDE for Eclipse. Supported format includes Microsoft Word 97/2000/XP 
document (with extension .doc) and OpenOffice.org 1.0 Text Document (with extension .sxw). 
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Exporting current report 

1. Click on the Export Report...button  on the toolbar or select Report > Export Report...from main menu. This 
display the Save dialog box.  

2. In the Save dialog box, enter the file name and select OpenOffice.org 1.0 Text Document (.sxw) format or 
Microsoft Word 97/2000/XP (.doc) format for exporting.  

3. When everything is ready, click Save to export the report.  

Exporting all report(s) 

1. Click the Export All Reports...button on the toolbar or select Report > Export All Reports...from main menu. 
This display the Save dialog box.  

2. In the Save dialog box, enter the directory for storing the reports in the File name field and select either 
OpenOffice.org 1.0 Documents or Microsoft Word Documents for the Document Type.  

3. When everything is ready, click Save to export the report(s).  

Importing a Report 

You can import a document back into Report Writer for data updating. To import a report: 

1. Click the Import Report...button on the toolbar or select Report > Import Report...from main menu. This 
displays the Open dialog box.  

2. In the Open dialog box, select either OpenOffice.org 1.0 Text Document (.sxw) format or Microsoft Word 
97/2000XP (.doc) format for importing. Select a file and click Open to import the selected document into Report 
Writer.  

3. If the document has previously been exported from Report Writer, a dialog will appear and ask for overwriting the 
existing one or not.  

 

Figure 6.62 - Confirm overwrite existing report 

If you click Yes, the existing report will be replaced by the imported one. If you click No, the imported report will be stored 
into Report  

Updating a Report 

In reality, software design keeps evolving from time to time. Originally, users needed to modify the related documents 
manually to ensure that it is fully conformed to the latest design. Report Writer binds closely with the SDE for Eclipse project, 
and hence generated elements can then be updated without affecting the user-defined content. 

To update a report, choose the desired report for updating from the drop-down menu and click the Update from Model 

button  from the toolbar or select Report > Update from Model from main menu. 

Update process will start automatically. Data will be extracted from project and replace with the content within the existing 
generated element. 

 

Please do not click on the Writer Pane while the update process is undergoing, as it may affect the accuracy 
of the content. It can also damage the generated element, so that updating cannot be performed anymore 
unless the damaged block is removed manually.  
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The update process will replace ALL the contents within each generated element without notification. 
Therefore please insert your content wisely and ensure that it is not located inside the scope of any 
generated element. 

Printing a report 

There are two ways for printing the reports. The first one is to print the currently opened report and another one is to print all 
the reports within the project. The following steps demonstrate how you can print reports in Report Writer. 

1. Click the Print Report... button  on the toolbar or select Report > Print Report... from main menu. This displays 
the Print  dialog box asking for the printer name.  

2. Select the printer for printing the document from the drop down menu.  
3. To print the currently opened report, click Print Current...  To print all reports, click Print All...   

 
Do not click on the Writer Pane while the printing process is undergoing, it may affect the print job.  

 

Sorting Elements in Report 

Sorting out the elements in the report helps to prepare a report which is well-organized.   

There are three ways of sorting in a report: 

• Automatic 
• Follow tree 
• Sort by id or name 

We will use a PDF report as an example. 

To set the sorting option: 

1. Select Modeling > Report > PDF... from the main menu.  

 
Figure 6.63 - Select Generate PDF Report... 
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2. This shows the Generate PDF dialog box. 

 
Figure 6.64 - Generate PDF dialog box 

 

3. Select how elements will be sorted from the Sort element by drop-down menu. 

 
Figure 6.65 - Select way of sorting 

 

4. Press the Generate button. 

 



SDE User’s Guide (Part 1)  Chapter 6 –Generating Documentation 

 

6-48 

Different ways of sorting 

• Automatic 

The report generated is sorted by listing elements in the most logical order, following most users’ understanding of that kind of 
diagram.  

 
Figure 6.66 - Sorting by Automatic 

. 
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• Follow tree 

The report generated is sorted by following the sort order of the Diagram Navigator in the tool. 

 
Figure 6.67 - Sort by Follow tree 
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• Sort by id or name 

The report generated is sorted by name or ID of the element. 

Figure 6.68 - Sort by id or name 
 



 

Export and Import 7 
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Chapter 7 - Export and Import 

SDE for Eclipse facilitates excellent interoperability by allowing exchange of  UML diagrams and models via XMI. Apart 
from this, you also can import models created previously from IBM Rational Rose. 

This chapter guides you through the process of importing and exporting a SDE for Eclipse project, an XML file or an XMI file. 
You can also learn how to export a SDE for Eclipse project as an image and how to import a IBM Rational Rose Project. 

In this chapter: 

• Image Exporter 
• SDE for Eclipse Project Importer and Exporter 
• XML Importer and Exporter 
• XMI Importer and Exporter 
• Rose Importer 
• ERwin modeler project file Importer 
• Oracle workflow engine BPEL generator 
• JBoss workflow engine BPEL generator 

Exporting Diagram as Images 

 

 

The images exported can be inserted to external documents for easier distribution. Here are the types of image SDE for Eclipse 
support exporting: 

• JPG 
• PNG with background 
• PNG without background 
• SVG 
• EMF 
• PDF (diagram per page) 
• PDF (diagram per file) 

Exporting the Active Diagram as an Image 

This feature exports the active diagram as an image file. To export the active diagram as an image file, perform one of the 
following actions: 

• Select File > SDE-EC Export > Active Diagram as Image... from main menu. 

File chooser dialog box will appear where you can specify the output of the image file.  
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Exporting Diagrams as Images 

This feature exports one or more diagrams as images. To export the active diagram as image file, perform one of the following 
actions: 

• Select File > SDE-EC Export > Diagrams as Image... from main menu. 

The Diagram Exporter dialog box will be displayed. You can specify which diagrams to export, and preview the exported 
image. After you have configured the export settings click Export  to export the diagrams.  

 

Figure 7.1 - Diagram exporter 

Field Description 

Output 
destination 

The Output destination is the directory where all the exported images are saved to. You can enter the path in 
the text field directly, or you can click on the ... button to browse for the directory. 

Export type 
To select the image format of the exported image click on the pull-down box beside the Export type field and 
select the format you want to use. 

Diagrams 
The Diagrams pane shows the diagrams in the current project. Check the checkbox beside the diagram you 
want to export. The number of selected diagrams is displayed at the bottom of the Diagram pane. The Preview 
pane also allows you to preview the exported image of the selected diagram. 
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Preview 

The Preview pane shows the preview of the exported image of the selected diagram in the Diagrams pane. You 
can check/uncheck the Show preview checkbox to enable/disable the preview. 
You can select the size of the preview image by selecting from the pull-down box beside the Preview mode 
field. Selecting Stretch will show the image in scaled size that fits to the preview area, while selecting Real 
size will show the image in its actual size.  

Anti-aliasing 

Anti-aliasing is a method which handles the staircase pixels of slanted lines and curves to make them look 
smoother. You can apply anti-aliasing to the exported images. To apply anti-aliasing to graphics, check the 
Graphics Anti-aliasing checkbox in the Anti-aliasing pane. Likewise, you can check the Text checkbox in the 
Anti-aliasing pane to apply anti-aliasing to text. 

Auto 
overwrite 
existing files  

You can check the 'Auto overwrite existing files' checkbox to allow overwriting of files in the export process.  

Max. Size Maximum size of exported images. If the diagram size is larger than the max. size, it will be resized. 

Table 7.1 

Slice diagrams 
User can slice a large diagram into pieces(number of files), as well as restrict the size of the exported diagram.  

 

Figure 7.2 - Slice diagrams 

There are three slicing strategies. They are Fixed Slice, Free Slicing and Fixed Ratio.  

Slicing 
strategies 

Description 

 Fixed Slice 
Fixed Slice is a simple strategy which slices exported diagram into pieces of the same size. The user specifies the 
number of columns and rows to slice and then the exported diagram will be sliced into specific pieces. 

 Free 
Slicing 

Users can customize how to slice the exported diagram by specifying the position of vertical slices and horizontal 
slices. It is particularly useful to prevent a shape from being sliced into pieces. 

 Fixed Ratio 

Fixed Ratio gains the benefits of Fixed Slice and Free Slicing. The width and height of pieces are the same but 
for the last row and column. Users can also customize the width and height of sliced pieces. Like Free Slicing, 
Fixed Ratio is size oriented. User modifies the size of pieces and Diagram Slicer calculates the number of row 
and column to slice. 

Table 7.2 



SDE User’s Guide (Part 1)  Chapter 7 – Export and Import 

 

7-5 

Exporting Diagrams to PDF format 

You can export SDE for Eclipse diagram to native PDF format. Since the exported PDF is of a small size, it can save a lot of 
space. Also, because the diagram in PDF is a vector, it is scalable.  
There are two different options when you export: 

• PDF(diagram per page) 

            All the diagrams selected will be exported in the same PDF file. Each diagram will occupy one page.  

• PDF(diagram per file) 

            Each diagram selected will be exported in one new PDF file. 
 
To export diagram to PDF format: 
1. Select File > SDE-EC Export > Diagrams as Image... in the main menu. 

 
 Figure 7.3 - Select Diagrams as Image... 
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2. Diagram Exporter dialog box is displayed. Select the PDF format you want. 

 
 Figure 7.4 - Select PDF format 

 
3. Select ... to select the output destination or type it in the text box. If you select PDF(diagram per page) as the export type, 
you should type in a file name with .pdf as extension.  

 
 Figure 7.5 - Type in Output destination 

 
 



SDE User’s Guide (Part 1)  Chapter 7 – Export and Import 

 

7-7 

4. Select the diagram(s) you want to export and click Export  to generate. 

 
 Figure 7.6 - Select diagrams to export 

 
5. Then, a dialog box is displayed telling you the diagram is exported. You may choose from the options Open File, Open 
Folder, Copy Path or Finish. Choose Open File to see the exported file.  

 
Figure 7.7 - Export finished 
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6.  Only one file is created. In the exported file, you will find all the diagrams you have selected. 

 
Figure 7.8 - Exported file 

 
If you select PDF(diagram per file), you should type in a directory where the files should be saved in. After selecting the 
diagrams to export, click Export . 

 
Figure 7.09 - Type in a directory 
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After exporting, you may select Open Folder to open the directory holding the exported file. 

 
Figure 7.10 - Select Open Folder 

 
The more diagram you selected, the more file you generated.  

 
Figure 7.11 - Exported files in the designated directory 
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Each file exported will only contain one diagram. 

 
Figure 7.12 - Exported file 
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Exporting and Importing SDE for Eclipse Project Fil e 

Exporting SDE for Eclipse Project File 

Many hands make simple work.  Exporting a SDE for Eclipse project file lets you split up a single large project into smaller 
sections, e.g. a few diagrams and focus on modifying and improving one section without affecting other components.  The 
exported files will then be the same as a normal SDE for Eclipse project.  This means different sections can be worked on at 
the same time, and when all the sections are complete Importing the modified files back to the master project will merge the 
changes into the project.   
 
To export SDE for Eclipse Project File: 
1. Select File > SDE-EC Export > UML Model... in main menu. 

 
Figure 7.13 - Export UML model 
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2. Export Project dialog box is displayed. Type in the Output destination. 

 
Figure 7.14 - Export Project dialog box 

 
3. Select the diagram you want to export. 

 
Figure 7.15 - Select diagram to export 
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4. Open the project exported. The project only contains the diagram you selected in the Diagram Navigator. 

 
Figure 7.16 - Diagram Navigator of exported project 
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Importing SDE for Eclipse Project File 

After you have edited the exported file, you can import it back to the master project. The modifications will then be merged to 
the master project. 
1. Open the master project. Select File > SDE-EC Import  > UML Model...  in the main menu. 

 
Figure 7.17 - Import UML Model 
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2. Select the project to be imported. 

 
Figure 7.18 - Select a project to import 

 
Diagram in the master project before import.  

 
Figure 7.19 - Diagram before import 
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Diagram in the master project after import. The color of the use case 'Verify ID' has been changed. 

 
Figure 7.20 - Diagram after import 
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Exporting and Importing XML 

XML is a widely used standard for exchanging data. You can export the whole SDE for Eclipse Project or just part of it to 
XML. After exporting, you can run your own application to read and update it. You can also import the XML file back to SDE 
for Eclipse Project to reflect your changes.  

Exporting XML 

To export a project to XML: 
1.Select File > SDE-EC Export > XML...  in the main menu. 

 
Figure 7.21 - Export XML 
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2. The Export to XML dialog box is displayed. 

 
Figure 7.22 - XML dialog box displayed 

 
3. Type in or select the output destination. The destination should be a directory because not only a XML file will be generated, 
but also some of the project file, such as image, will be generated. 

 
Figure 7.23 - Text box for Output destination 
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4.Select the diagram needed to export and click Export  to generate. If you want to export the whole project, you can check the 
check box Export project . 

 
Figure 7.24 - Select Export  

 
5. The XML file is generated. 

 
Figure 7.25 - XML file is generated 
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Modifying XML 

 
When you modify the XML of a project, the project will change accordingly. You can edit the XML file based on XML 
schema bundled. The XML schema in {installation folder}\bundled\project.xsd. 

 
Figure 7.26 - XML schema 

 
To edit XML: 
1. Open the XML file in an editing program. 

 
Figure 7.27 - Open XML file 
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2. Directly edit the file. 

 
Figure 7.28 - Edit the file 

 

Importing XML 

You can import the modified XML to update your project.  
To import XML: 
1. Select File > SDE-EC Import > XML... from the main menu. 

 
Figure 7.29 - Import XML file 
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2.Specify the import file path by selecting ... or typing the path in the text box. The import path should be path of a file. This is 
because the importer will search for the data.zip automatically. 

 
Figure 7.30 - Specify the file path 

 
3. The import of XML has completed. 

 
Figure 7.31 - Import completed 

 

Exporting and Importing XMI 

XMI (Metadata Interchange) is the standard way for exchanging data between CASE tool. SDE for Eclipse can cover most of 
the XMI versions and standards.  
Here are the versions and standards we support: 
Exporting:  

• XMI 1.0 
• XMI 1.2 
• XMI 2.1 
• XMI 2.1 (for UML2) 

Importing: 

• XMI 1.0 
• XMI 1.2 
• XMI 2.1 
• XMI 2.1 (for UML2) 
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Exporting XMI 

If the SDE for Eclipse project is exported to XMI, users without SDE for Eclipse can use other CASE tools to open the XMI to 
get the content of the project. 
To export XMI: 
1. Select File > SDE-EC Export > XMI...  in main menu. 

 
Figure 7.32 - Export XMI 

 
2. Export XMI  dialog box is displayed. You can choose the XMI Version of the export XMI. 

 
Figure 7.33 - Export XMI dialog box 
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3. Specify the output file path by typing in the text box or select ... .If the file path does not have the extension .xmi, the 
exporter will append the extension to the path. Then, click OK to confirm. 

 
Figure 7.34 - Specify the export file path 

 
4. The XMI is generated. 

 
Figure 7.35 - XMI file created 
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Importing XMI 

You can import the XMI file which is modified by other users or other CASE tools, in order to update your project. 
To import XMI: 
1. Select File > SDE-EC Import > XMI...  in the main menu. 

 
Figure 7.36 - Import XMI 

 
2. Import XMI  dialog box is displayed. Specify the import file's path by typing in the text box or select ... and click OK  to 
confirm. 

 
Figure 7.37 - Specify import file's path 
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Exporting and Importing EMF-based UML2 

Exporting to UML2 

EMF stands for Eclipse Modeling Framework. In SDE for Eclipse, we can support importing and exporting Eclipse XMI 
Standard. You can directly import and export the exported file to Eclipse UML2. 
To export EMF-based UML2: 
1. Select File > SDE-EC Export > XMI... in main menu. Export XMI  dialog box is displayed. 

 
Figure 7.38 - Export EMF-based UML2 

 
2. Check the Export for UML2  check box. You can see the extension of export file path is .xmi.uml .Then specify the file path 
and click OK to confirm. 

 
Figure 7.39 - Check Export for UML2 and specify file path 
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Importing to Eclipse UML2 Model 

You can modify the exported file using Eclipse UML2. 
To import the file: 
1. Copy the exported XMI file to the eclipse project's directory or directly export the file there in the previous steps. 

 
Figure 7.40 - Get the XMI file in project's directory in Eclipse 

 
2. Select File > Refresh in main menu of Eclipse. 

 
Figure 7.41 - Refresh eclipse 
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3. The Package Explorer is refreshed and the XMI file is imported. 

 
Figure 7.42 - XMI file imported 

 

Modifying UML2 XMI 

After exporting, you may edit the XMI file in Eclipse. 
Here, changing the name of a class is used as an example. 
1. Expand the project tree and select the class which you want to change it's name. 

 
Figure 7.43 - Select the class to modify 
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2. Select Show Properties View in the popup menu. 

 
Figure 7.44 - Select Show Properties View 

 
3. Select the property you want to edit. Here, select Name and click on the Value column. 

 
Figure 7.46 - Select the property to edit 

  
4. Change the Name and save the project. 

 
Figure 7.45 - Change the property 
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Importing UML2 XMI 

After modifying in Eclipse UML2, you can import back the file to update your project. The process of importing is the same as 
importing XMI file. 
To import XMI: 
1. Select File > SDE-EC Import > XMI...  in the main menu. 

 
Figure 7.46 - Import XMI 

 
2. Import XMI  dialog box is displayed. Specify the import file's path by typing in the text box or select ... and click OK  to 
confirm. 

 
Figure 7.47 - Specify import file's path 
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3. The project is updated. The diagram before importing. 

 
Figure 7.48 - The diagram before importing 

 
The diagram after importing. The name of class Polygon has been changed into Shape. 

 
Figure 7.49 - The diagram after importing 
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Importing Rational Rose Project File 

 

 
 
Rational Rose® is one of the most widely used UML CASE tool in 90's.  
SDE for Eclipse supports the importing of Rational Rose file. As a result, you can import your Rational Rose project into SDE 
for Eclipse and retain all the information in the project, including color and position. 

Figure 7.50 - Import from Rational Rose®  

 

To import a Rose project into SDE for Eclipse: 
1. Select File > SDE-EC Import > Rose Project... from main menu. This displays the Import Rose Option dialog box. 

 
 Figure 7.51 - Import a Rose Project 
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2.Type in the path of Rational Rose file in the File path. You may also select ... to select the file. 

 
 Figure 7.52 - Specify the file path 

 
3. Select the mode of importing from the drop down menu of Import mode. You can choose to import Model only or both 
Model and diagram. Then, click OK  to start importing the MDL file.  

 
 Figure 7.53 - Select the import mode 

 
4. The progress dialog box appears. You can check the check box Close Dialog when finished progress to close the dialog 

box when finished importing. You can select button to open the message pane. 

 
 Figure 7.54 - Progress dialog box 
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5. The message pane shows the messages to indicate the progress of the importing process. When the process has finished click 
on the Close button in the progress dialog box to close.  

 
 Figure 7.55 - Message pane opened 

 
6. The models/diagrams are imported. Expand the project tree from Diagram Navigator and choose to browse for a diagram. 
You can Double-click on a diagram in the project tree to open the imported diagrams.  

 
 Figure 7.56 - Diagrams imported 
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If you have selected Model only in the Import Mode  in step 3, only models are imported. You can see the imported models in 
the Model pane. 

 
Figure 7.57 - Models Imported 
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ERwin Modeler Project File Importer 

 

Importing an ERwin Data Modeler Project 

To import an ERwin Project into SDE for Eclipse: 
1. Design and save the model in ERwin Data Modeler as a XML file. 

 
Figure 7.58 - Modeling in ERwin 
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2. Launch SDE for Eclipse. Select File > SDE-EC Import > ERwin Project (XML)...  from main menu. This display the 
AllFusion ERwin Data Modeler Project Importer  dialog box. 

 
Figure 7.59 - Menu for Import ERwin Project 

 
3. In the dialog, locate the ERwin Project file and click OK  to start import. You can enter the path directly on the text field or 
click ... to locate the file from file chooser. 

 
Figure 7.60 - Import ERwin Project dialog box 
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4. Then, the Open Imported Entity Relationship Diagram(s) dialog box is displayed if there are any entity relationship 
diagram. You can check the Selected column to select the diagram(s) you want to open. 

 
Figure 7.61 - Open Imported Entity Relationship Diagrams dialog box 

 
5. Diagrams and Models were imported to the current project. 

Figure 7.62 - The imported ERwin project 
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Oracle workflow engine BPEL generator 

 

Generating BPEL for Oracle workflow engine 

To generate BPEL for Oracle workflow engine: 
1. Design a Business Process Diagram in SDE for Eclipse. 

 
Figure 7.63 - Business Process Diagram 

 
2. Right click on diagram. Select Generate > BPEL.... This display the Export BPEL  dialog box. 

 
Figure 7.64 - Menu for generate BPEL 
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3. In the dialog, specify the path of the output BPEL files in Output directory . Select Oracle BPEL Process Manager 
(10.1.2) in Target server. You can Auto overwrite existing files by checking the check box. Click OK  to start export. 

 
Figure 7.65 - Export BPEL Dialog box 

 
4.List of exported files will be shown. 

 
Figure 7.66 - Exported files 
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JBoss Workflow Engine BPEL Generator 

 

Generating BPEL for JBoss workflow engine 

To generate BPEL for JBoss workflow engine: 
1. Design a Business Process Diagram in SDE for Eclipse. 

 
Figure 7.67 - Business Process Diagram 

 
2. Right click on diagram. Select Generate > BPEL.... This displays the Export BPEL  dialog box. 

 
Figure 7.68 - Menu for generate BPEL 
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3. In the dialog, specify the path of the output BPEL files in Output directory . Select JBoss jBPM BPEL (1.1 beta1) in 
Target server. Click OK  to start export. 

 
Figure 7.69 - Export BPEL dialog box 

 
4.List of exported files will be shown. 

 
Figure 7.70 - Exported files 

 



 

User Interface Designer 8 
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Chapter 8 - User Interface Designer 

 
Apart from facilitating visual modeling, SDE for Eclipse also facilitate screen mock up in early requirement capturing stage. 
With SDE for Eclipse cutting edge visual modeling technology, you can save a lot of time from writing tedious code to make a 
user interface for confirming requirements. 
In this chapter, you will learn: 

• Creating User Interface Diagram 
• Change Component Properties 
• Annotating Component 
• Linking Components 
• Switching Orientation by Resource-centric Interface 
• Auto Detect Orientation 

Creating User Interface Diagram 

Similar to other diagrams, user interface diagram can be created using different ways: 

• Using toolbar 
• Using New Diagram dialog box 
• Using popup menu of Diagram Navigator 

Here, creation of it using toolbar is used as an example. 
To create a new user interface diagram, select New SDE-EC Diagram from toolbar. And select User Interface from the dialog 
box 

  
 Figure 8.1 - Select New SDE-EC Diagram 
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Figure 8.2 - Select User Interface 
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The diagram is created. 

 
Figure 8.2 - New User Interface Diagram 
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Creating Component 

You can create component by drag and drop, select and click and with size. 
To create by drag and drop: 
1. Drag the component you want to add from the toolbar. 

 
Figure 8.3 - Drag the component 
 
2. Then drop the component on the diagram pane. 

 
Figure 8.4 - Drop on diagram pane 
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To create by select and click: 
1. Select the component you want to add in the toolbar. 

 
Figure 8.5 - Select component 
 
2. Click on the diagram pane. The component is created. 

 
Figure 8.6 - Component created 
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To create by defining an initial size: 
1. Select the component you want to add in the toolbar. 

 
Figure 8.7 - Select component 
 
2. Drag a specific boundary before releasing the mouse to define the component's initial size. 

 
Figure 8.8 - Define an initial size 
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3. The component with specific size is created. 

 
Figure 8.9 - Component created 

 

Change Component Properties 

You can set the properties of user interface by opening the specification of the component. Then, you can go into the UI tab to 
update all user interface properties. 
Here, the configuration of the user interface properties of list and label are used as examples. 
To set the properties of a label: 
1. Right click on the label and select Open Specification... from the popup menu. 

 
Figure 8.10 - Select Open Specification 
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2. Then, select UI tab.  

 
 Figure 8.11 - Select UI tab 

 
3. User interface properties can be configured. 

 
 Figure 8.12 - UI properties of label 
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4. You can edit the Caption and Mnemonic. 

 
Figure 8.13 - Edit user interface properties 

 
5. The label has been edited. 

 
Figure 8.14 - Label edited 
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To set the user interface of a list: 
1. Right click on a list and select Open Specification... from the popup menu. 

 
Figure 8.15 - Open Specification  

 
2. Select UI  tab. 

 
Figure 8.16 - Select UI tab 
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3. The UI properties you can edit is shown. 

 
Figure 8.17 - UI properties of List 

 
4. You can edit the Values and Selected value of the user interface. You can also decide the properties of Horizontal Scroll 
Bar and Vertical Scroll Bar . 

 
Figure 8.18 - Edit UI properties 
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5. List has been edited. 

 
Figure 8.19 - List edited 

 

Annotating Component 

You may want to add annotation to specific UI Component as instruction. In SDE for Eclipse, you can use the Note resource to 
achieve it. 
Here, adding annotation to a button is used as an example. 
When your mouse moves pass a button, you can see the Note resource.  

 
Figure 8.20 - Note resource 
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Drag the Note resource to a place on diagram pane where you want the note to be created on. 

 
Figure 8.21 - Drag the Note resource 

 
When you release the mouse, you can type in annotation in the note. 

 
Figure 8.22 - Type in annotation 
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Annotation has been added. 

 
Figure 8.23 - Annotation added 

 

Linking Components 

Similar to other diagrams, user interface diagram allows you to create connector to connect two components. This can be 
achieved by using Resource Centric. 
Here, connecting a button and a panel is used as an example. 
1. Mouse over a button, you will see the Centric Resource for Generic Connector. 

 
Figure 8.24 - Select Centric Resource for Generic Connector 

 
2. Drag the resource to the component you want to connect to. 

 
Figure 8.25 - Drag the resource 
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3. Release the mouse and connector is created. You may also edit the name of connector. 

 
Figure 8.26 - Edit the name of connector 

 

Switching Orientation by Resource-centric Interface  

Sometimes, you may want to switch the orientation of certain component. In SDE for Eclipse, you can use the Switch 
Orientation Resource to do so. 
When your mouse move over some components like scollbar, you can see the Switch Orientation Resource. 

 
Figure 8.27 - Switch Orientation Resource 
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By selecting the resource, the orientation of component has been switched. 

 
Figure 8.28 - Orientation switched 

 
Auto Detect Orientation 

SDE for Eclipse can detect the orientation of a component when you create it with specific size. 
For example, you may drag vertically to create a slider 

 
Figure 8.29 - Drag vertically 

 
 



SDE User’s Guide (Part 1)  Chapter 8 – User Interface Designer 

 

8-18 

The slider created is in vertical orientation. 

 
Figure 8.30 - Component with vertical orientaton 
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Chapter 9 - Instant Reverse 

SDE for Eclipse provides a handy way to reverse engineer various sources (including binary files) into UML class models. 
This feature is called Instant Reverse. The use of Instant Reverse is discussed in this chapter. 

In this chapter:  

• What is Instant Reverse?  
• Supported Sources 
• Using Instant Reverse  
• Java Instant Reverse 

What is Instant Reverse? 

 
The Instant Reverse facility of SDE for Eclipse allows you to reversely engineer different types of source or binary files into 
UML class models, such as java source, java classes, C++ Source, JDBC, .NET binaries, etc...(More types will be supported 
soon). This chapter provides a brief description on the supported formats and the steps required to reverse engineer source 
codes into UML class models in SDE for Eclipse.   

Supported Sources 

 

Supported Instant 
Type  

Extension  Remarks  

Java Source Dir/.java   

Java Class  Dir/.class/.jar/.zip  

Dynamic Link Library  .dll 
Must be created by Microsoft® Visual Studio .NET 
Only one .dll file needs to be supplied. All other required .dll files will be looked up 
automatically.  

Windows Executable .exe  Must be created by Microsoft® Visual Studio .NET 

XML  .xml   

XML Schema .xsd   

C++ Source  .h/.cpp  

CORBA IDL Source  .idl    

PHP 5.0 Source  Dir/.php/.inc    

Hibernate  .hbm.xml   

JDBC  
Reverse the database schema of the specific database according to the given JDBC 
Connection URL. 

Ada 9x Source  .ada/.adb/.ads    

Table 9.1 
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Java Instant Reverse 

Instant Reverse supports the reverse engineering of Java up to version 1.5. Besides this, there are more advanced options for 
Java Instant Reverse compared to other languages.   

Select menu Modeling > Instant Reverse... . The Instant Reverse dialog box will appear; select 'Java' from the language 
combo box. 

 

Figure 9.1 - Java Instant Reverse Dialog 

The buttons on the right are used for adding, removing and reordering of Java source/class paths. 

Button Description  

Add JARs...  Select JAR files to add to the instant reverse paths. 

Add Class Folder...  Select class folders to add to the instant reverse paths. 

Add ZIPs...  Select ZIP files to add to the instant reverse paths. 

Add Source Folder...  Select source folders to add to the instant reverse paths. 

Remove  Remove selected instant reverse paths. 

Up  Move selected instant reverse paths upwards. 

Down  Move selected instant reverse paths downwards. 

Table 9.2 

Select the Reverse source on demand option if you want the paths to be reversed to UML models only when you request it 
(see the On-Demand Java Instant Reverse section later in this chapter for details). If this option is not selected, the instant 
reverse paths will be reversed to UML models once you click OK. 
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On-Demand Java Instant Reverse 

After performed instant reverse of Java with the Reverse source on demand option selected, the Class Repository will have 
the reversed paths added under the Java Resources node. 

 

Figure 9.2 - Class Repository 

There are three kinds of on-demand Java instant reverse you can use, they are 'reverse to Class Repository', 'reverse to diagram' 
and 'reverse by drag-and-drop'. 

Reverse to Class Repository 
In the Class Repository's Java Resources node, select the desired resources to be reversed, right-click on the selection and 
select Reverse "<RESOURCE_NAME>" to > Class Repository from the popup menu. 

 

Figure 9.3 - Revert resources to Class Repository 
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The resources will be reversed to UML models and added to the project, but no diagrams or shapes will be generated. 

 

Figure 9.4 - Resource reversed in Class Repository 

Reverse to Diagram 
In the Class Repository's Java Resources node, select the desired resources to reverse, right-click on the selection and select 
Reverse "<RESOURCE_NAME>" to from the popup menu to expand it. 

 

Figure 9.5 - Revert resources to form a new diagram 
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If you select the New Class Diagram menu, a new class diagram will be generated from the reversed UML models. 

 

Figure 9.6 - The reversed Class Diagram 

If there is an active class diagram and you selected the "<DIAGRAM_NAME>" (Active Diagram) menu, the shapes of the 
reversed UML models will be generated and appended to the empty space of this diagram. 

Reverse by Drag-and-Drop 
In the Class Repository's Java Resources node, select the desired resources to be reversed, drag the selection over the target 
class diagram and then release the mouse button to drop it. 

 

Figure 9.7 - Reverse by Drag and Drop 

The shapes of the reversed UML models will be generated and placed to the location of this diagram where you dropped the 
resources. 
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Dynamic Link Library Instant Reverse 

 Instant Reverse supports the reverse engineering of dynamic link library into UML class model.  

 
Figure 9.8 - Dynamic Link Library file 

To perform instant reverse of dll: 

1. Select menu Modeling > Instant Reverse ... the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. Select the language '.NET dll or exe files' from the combo box. 

Figure 9.9 - Open Instant Reverse dialog box and select language 
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2. Type in the path of the Dynamic Link Library file. You may also select ... to select the file path. Then select OK to start. 

 
Figure 9.10 - Specify the file path 

3. A Message dialog box will appear telling you the reversal is successful. 

 
Figure 9.11 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, you can form a diagram using the default package. You may 
also change the form diagram and presentation options. After selections have been made, click OK . 

 
Figure 9.12 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversal in the Model pane. 

 
Figure 9.13 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation to form a new 
diagram. 

 
Figure 9.14 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there.  

 
Figure 9.15 - Form Diagram dialog box 
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  8.A new diagram is formed by the selected models.  

 
Figure 9.16 - New diagram formed 

XML Instant Reverse 

Instant Reverse supports the reverse engineering of XML into UML class model. Every XML Node in the XML will be 
reversed as a class model. The attributes in node will be reversed as Class' attributes and all Class models will be reversed into 
a root package. 

Figure 9.17 - XML file 
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To perform instant reverse of XML: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with the Instant Reverse options for 
configuration. 

 
Figure 9.18 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the XML file. You may also select ... to select the file path. 
Then select OK to start. 

 
Figure 9.19 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.20 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, you can form a diagram using the default package. You may 
also change the form diagram and presentation options. Select OK . 

 
Figure 9.21 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversal in the Model pane. 

 
Figure 9.22 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation to form a new 
diagram. 

 
Figure 9.23 - Select model to form diagram 

 



SDE User’s Guide (Part 1)  Chapter 9 – Instant Reverse 

 

9-15 

7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there.  

 
Figure 9.24 - Form Diagram dialog box 
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 8. A new diagram is formed by the selected models.  

 
Figure 9.25 - New diagram formed 
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XML Schema Instant Reverse 

SDE for Eclipse can reverse XML Schema into UML class model. 

 
Figure 9.26 - XML schema file 
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1. Select Modeling > Instant Reverse... from the main menu. The Instant Reverse dialog box appears with Instant Reverse 
options for configuration. 

 
Figure 9.27 - Open Instant Reverse dialog box 

 

2. Select the language from the combo box and type in the path of the XML Schema file. You may also select ... to select the 
file path. Then select OK to start. 

 
Figure 9.28 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.29 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, you can form a diagram using the default package. You may 
also change the form diagram and presentation options. Then select OK . 

 
Figure 9.30 - Select class or package to form diagram 
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5. You can see the reverse result in the Model pane, and expand the tree to see the what the models contain. 

 
Figure 9.31 - Model pane showing result 

 
6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical/Navigation to form a new 
diagram. 

 
Figure 9.32 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there.  

 
 Figure 9.33 - Form Diagram dialog box 
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 8. A new diagram is formed with the selected models.  

 
Figure 9.34 - Diagram formed 

 

C++ Instant Reverse 

SDE for Eclipse can reverse C++ into UML class model. 

 
 Figure 9.35 - C++ file 
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To perform instant reverse of C++: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.36 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the C++ file. You may also select ... to select the file path. 
You can select a folder or a C++ file, with the extension of .h or .cpp. Then select OK to start. 

 
Figure 9.37 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.38 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, you can form a diagram using the default package. You may 
also change the form diagram and presentation options. Then, select OK . 

 
Figure 9.39 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversal in the Model pane. 

 
Figure 9.40 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation to form a new 
diagram. 

 
Figure 9.41 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there. 

 
Figure 9.42 - Form Diagram dialog box 
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8. A new diagram is formed with the selected models. 

 
Figure 9.43 - New diagram formed 

 

CORBA IDL Source Instant Reverse 

SDE for Eclipse also supports reversing CORBA IDL Source into UML classes or models. 

 
Figure 9.44 - CORBA IDL file 
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To perform instant reverse of CORBA IDL: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.45 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the CORBA file. You may also select ... to select the file 
path. You can select a folder or a CORBA file. Then select OK to start. 

 
Figure 9.46 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.47 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, the diagram will follow the default package. You may also 
change the form diagram and presentation options. Then, select OK . 

 
Figure 9.48 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversal in the Model pane. 

 
Figure 9.49 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation from the 
popup menu to form a new diagram. 

 
Figure 9.50 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there. 

 
Figure 9.51 - Form Diagram dialog box 
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 8. A new diagram is formed with the selected models. 

 
Figure 9.52 - New diagram formed 

PHP Instant Reverse 

SDE for Eclipse can reverse PHP into UML class model. 

 
Figure 9.53 - PHP file 
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To perform instant reverse of PHP: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.54 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the PHP file. You may also select ... to select the file path. 
You can select a folder or a PHP file. Then select OK to start. 

 
Figure 9.55 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.56 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, the diagram will follow the default package. You may also 
change the form diagram and presentation options. Then, select OK . 

 
Figure 9.57 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversal in the Model pane. 

 
Figure 9.58 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation to form a new 
diagram. 

 
Figure 9.59 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there. 

 
Figure 9.60 - Form Diagram dialog box 
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 8. A new diagram is formed with the selected models. 

 
Figure 9.61 - New diagram formed 

Hibernate Instant Reverse 

In SDE for Eclipse, you can generate UML classes and models by converting Hibernate code. 

 
Figure 9.62 - Hibernate file 
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To perform instant reverse of Hibernate: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.63 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the Hibernate file. You may also select ... to select the file 
path. You can select a folder or a Hibernate file. Then select OK to start. 

 
Figure 9.64 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.65 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, the diagram will follow the default package. You may also 
change the form diagram and presentation options. Then, select OK . 

 
Figure 9.66 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversing in the Model pane. 

 
Figure 9.67 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation from the 
popup menu to form a new diagram. 

 
Figure 9.68 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there. 

 
Figure 9.69 - Form Diagram dialog box 
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 8. A new diagram is formed by the selected models. 

 
Figure 9.70 - New diagram formed 
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JDBC Instant Reverse 

You can reverse databases into UML classes and models via JDBC. 
 
To perform instant reverse of JDBC: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.71 - Open Instant Reverse dialog box 
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2. Select the language from the combo box and configure the JDBC Setting. You can select or type in the path of the driver in 
the JDBC Driver . Then select the JDBC Driver Name from the dropdown menu. 

 
Figure 9.72 - Select the Driver Name 

 
3. The JDBC Driver Class is automatically generated. You may also configure the driver class yourself. 

 
Figure 9.73 - Driver class is generated automatically 
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4. Configure the JDBC Connection URL, User and Password. Then select OK . 

 
Figure 9.74 - Configure connection URL, user and password 

 

5. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.75 - Message dialog box 
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6. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, the diagram will follow the default package. You may also 
change the form diagram and presentation options. Then, select OK .  

 
Figure 9.76 - Instant Reverse form Diagram dialog box 

 
7. You can see the result of reversing in the Model pane.  

 
Figure 9.77 - Model pane 

 



SDE User’s Guide (Part 1)  Chapter 9 – Instant Reverse 

 

9-47 

8. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation from the 
popup menu to form a new diagram. 

 
Figure 9.78 - Select model to form diagram 
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9. The Form Diagram dialog box is shown. You can edit the details of the new diagram there.  

 
Figure 9.79 - Form Diagram dialog box 
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10. A new diagram is formed by the selected models. 

 
Figure 9.80 - New diagram formed 

Ada 9x Instant Reverse 

SDE for Eclipse also supports reversing Ada 9x code into UML classes or models. 

 
Figure 9.81 - Ada 9X file 
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To perform instant reverse of Ada 9x: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.82 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the Ada 9x file. You may also select ... to select the file path. 
You can select a folder or an Ada 9x file. Then select OK to start. 

 
Figure 9.83 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.84 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, the diagram will follow the default package. You may also 
change the form diagram and presentation options. Then, select OK . 

 
Figure 9.85 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversing in the Model pane. 

 
Figure 9.86 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation from the 
popup menu to form a new diagram. 

 
Figure 9.87 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there. 

 
Figure 9.88 - Form Diagram dialog box 
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8. A new diagram is formed by the selected models. 

 
Figure 9.89 - New diagram formed 

 

Objective-C Instant Reverse 

SDE for Eclipse also supports reversing Objective-C code into UML classes or models. 

  

 
Figure 9.90 - Objective-C file 
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To perform instant reverse of Ada 9x: 

1. Select menu Modeling > Instant Reverse..., the Instant Reverse dialog box appears with Instant Reverse options for 
configuration. 

 
Figure 9.91 - Open Instant Reverse dialog box 

2. Select the language from the combo box and type in the path of the Objective-C file. You may also select ... to select the file 
path. You can select a folder or an Ada 9x file. Then select OK to start. 

 
Figure 9.92 - Specify the file path 
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3. A Message dialog box appears telling you the reversal is successful. 

 
Figure 9.93 - Message dialog box 

4. An Instant Reverse form Diagram dialog box then appears. You can check the reversed classes and packages to form a 
new diagram. If you check the check box <default package>, the diagram will follow the default package. You may also 
change the form diagram and presentation options. Then, select OK . 

 
Figure 9.94 - Instant Reverse form Diagram dialog box 
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5. You can see the result of reversing in the Model pane. 

 
Figure 9.95 - Model pane 

6. You may also select one or more models and select Form Diagram > Customize.../Hierarchical /Navigation from the 
popup menu to form a new diagram. 

 
Figure 9.96 - Select model to form diagram 
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7. The Form Diagram dialog box is shown. You can edit the details of the new diagram there. 

 
Figure 9.97 - Form Diagram dialog box 
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8. A new diagram is formed by the selected models. 

 
Figure 9.98 - New diagram formed 
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Chapter 10 - Instant Generator 

In SDE for Eclipse, you can generate codes by using Instant Generator. 

In this chapter:  

• What is Instant Generator?  
• Supported Sources 
• Using Instant Generator  
• Generating different languages 

What is Instant Generator? 

 
The Instant Generator facility of SDE for Eclipse allows you to generate codes. SDE for Eclipse supports many types of 
language including Java, C#, VB.NET etc.This chapter provides a brief description on the supported formats and will show you 
how to generate codes. 

Supported Sources 

Instant Generator currently supports fifteen types of sources. They are: 

• Java 
• C# 
• VB.NET 
• PHP 
• ODL 
• ActionScript 
• IDL  
• C++ 
• Delphi 
• Perl 
• XSD 
• Python 
• Objective-C 
• Ada95 
• Ruby 
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We will use a SDE for Eclipse project as an example to illustrate the advanced options of different languages. 

 
Figure 10.1 - Sample SDE for Eclipse project to illustrate the advanced options 

Using Instant Generator 

Open the Instant Generator dialog from the main menu: click Modeling > Instant Generator > Instant Generator... . 

 
Figure 10.2 Open Instant Generator dialog 
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The Instant Generator dialog box will be displayed.   

 

Figure 10.3 Instant Generator dialog 

General Settings 

As the configuration is simplified, only three values are required to be input even if it is the first time running Instant Generator.  

1. Select Language to specify which language of source will generated for. In this example, C++ is selected. 

 
Figure 10.4 - Select Language 



SDE User’s Guide (Part 1)  Chapter 10 – Instant Generator 

 

10-5 

 

2. Choose classes or packages which will be included in the generation. 

 
Figure 10.5 - Choose classes or 
packages included 

 

3. Select an output path for placing generated source. 

 
Figure 10.6 - Select output path 
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Language Specified Options 

There are two options which allow you to control the properties in each language. One is Basic options and the other is 
Advanced options. 
You can directly edit the common change options in Basic options in the Instant Generator dialog. 

 
Figure 10.7 - Basic Options 

 
Advanced options contains all options of the language,  including those in Basic options. To edit Advanced options, click 
Advanced Options in the Instant Generator dialog.  

 
Figure 10.8 - Select Advanced Options 
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Figure 10.9 - Advanced Options 
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Preview or Generate 

As different values of options will produce different generation results, the Instant Generator provides a preview of the 
generation result before the actual generation. 

To Preview the generation result: 

Press Preview in Instant Generator dialog. 

 
Figure 10.10 - Select Preview 

 

Previewing result: 

 
Figure 10.11 - Previewing result 
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To generate codes using the Instant Generator dialog: 
Press Generate in the Instant Generator dialog to perform actual generation. 

 
Figure 10.12 - Select Generate 

 

While the generation, the progress is displayed in Generator Output. 
Output folder can be opened by pressing Open output folder in Instant Generator dialog. 

 
Figure 10.13 - Open output folder 
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Generating Java 

Using SDE for Eclipse, Java can be generated easily. 

To generate Java: 

1. Open the Instant Generator dialog for Java by clicking Modeling > Instant Generator > Java... in the main menu. 

 
 Figure 10.14 - Open Instant Generator dialog for Java 
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2. The Instant Generator dialog box for Java is displayed. 

 
Figure 10.15 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate in Java. 

 
 Figure 10.16 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.17 - Edit the options 

 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Generate Ant build file Check this option to generate Ant build file. 

Implements abstract 
operations 

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding 
operation(s) will be generated for the role's attribute.  

Association 
implementation 

Select from drop-down menu any of the options to configure the multiplicity of a class: 
Vector - The collection is expandable size. 
Array - The collection has fixed size. 

JDK Version 
Select this option to generate code for target JDK. The version SDE for Eclipse supports are 5.0 
and 1.4. 

Advanced Options... Edit the advance options. 

Table 10.1 
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Figure 10.18 - Example illustrating the functions of different options in Advanced Options 

 

 
Figure 10.19 - Diagram of invalid char 
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4. Specify the Output path and select Generate to generate Java. 

 
Figure 10.20 - Select Generate 

 
5.The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.21 - Open output folder 
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6. Java files are generated. 

 
Figure 10.22 - Java files generated 
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Generating C# 

SDE for Eclipse can generate C# file. 
To generate C#: 

1. Open Instant Generator dialog for C# by clicking Modeling > Instant Generator > C#... in the main menu. 

 
 Figure 10.23 - Open Instant Generator dialog for C# 

 



SDE User’s Guide (Part 1)  Chapter 10 – Instant Generator 

 

10-17 

2. The Instant Generator dialog box for C# is displayed. 

 
 Figure 10.24 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate C#. 

 
 Figure 10.25 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.26 - Edit the options 

 

Name Description  

Create folder for 
namespace 

Create a new folder for namespace to avoid name conflict. 

Implements abstract 
method 

Check this option to implement abstract methods in generated classes. 

Follow Microsoft naming 
convention  

Name the file generated using the Microsoft naming convention. If you uncheck this option, you 
can enter the prefix for attribute and parameter of prefix. 

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter. 

Advanced Options... Edit the advance options. 

Table 10.2 

 



SDE User’s Guide (Part 1)  Chapter 10 – Instant Generator 

 

10-19 

 
Figure 10.27 - Example illustrating the functions of different options in Advanced Options 
 

 
Figure 10.28 - Diagram of invalid char 
 

 
Figure 10.29 - File generated with folder created for namespace 
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5. Specify the Output path and select Generate to generate C#.  

 
Figure 10.30 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.31 - Open output folder 
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7.C# files generated. 

 
Figure 10.32 - C# files generated 

 

Generating VB.NET 

SDE for Eclipse can generate VB.NET file. 
To generate VB.NET file: 

1. Open the Instant Generator dialog for VB.NET by clicking Modeling > Instant Generator > VB.NET... in the main 
menu. 

 
 Figure 10.33 - Open Instant Generator dialog for VB.NET 
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2. The Instant Generator dialog box for VB.NET is displayed. 

 
 Figure 10.34 Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.35 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.36 - Edit the options 

 

Name Description  

Create folder for 
namespace 

Create a new folder for namespace to avoid name conflict. 

Implements abstract 
method 

Check this option to implement abstract methods in generated classes. 

Follow Microsoft naming 
convention  

Name the file generated using the Microsoft naming convention. If you uncheck this option, you 
can enter the prefix for attribute and parameter of prefix. 

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter. 

Advanced Options... Edit the advance options. 

Table 10.3 
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Figure 10.37 - Example illustrating the functions of different options in Advanced Options 

 
Figure 10.38 - File generated with folder created for namespace 
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5. Specify the Output path and select Generate to generate VB.NET.  

 
Figure 10.39 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.40 - Open output folder 
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7.VB.NET files generated. 

 
Figure 10.41 - VB.NET files generated 

 

Generating PHP 

SDE for Eclipse can generate PHP file. 
To generate PHP file: 

1. Open the Instant Generator dialog for PHP by clicking Modeling > Instant Generator > PHP... in the main menu. 

 
 Figure 10.42 - Open Instant Generator dialog for PHP 
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2. The Instant Generator dialog box for PHP is displayed.  

 
 Figure 10.43 - Instant Generator dialog box 

 
3. Choose the classes or packages you want to generate . 

 
 Figure 10.44 - Choose the classes and packages 
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4. Edit the Options.  

 
 Figure 10.45 - Edit the options 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute.  

Directory 

Select from drop-down menu any of the options to configure the output directory: 
Flat level: Save files to the output path defined below. 
Follow package: Create a new directory with the package names in the output path and save files 
there. 

Advanced Options... Edit the advance options. 

Table 10.4 
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Figure 10.46 - Example illustrating the functions of different options in Advanced Options 

 

 

Figure 10.47 - Diagram of invalid char 
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5. Specify the Output path and select Generate to generate PHP.  

 
Figure 10.48 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.49 - Open output folder 
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7.PHP files generated. 

 
Figure 10.50 - PHP files generated 

 

Generating ODL 

SDE for Eclipse can generate ODL file. 
To generate ODL file: 

1. Open the Instant Generator dialog for ODL by clicking Modeling > Instant Generator > ODL... in the main menu. 

 
 Figure 10.51 - Open Instant Generator dialog for ODL 
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2. Instant Generator dialog box for ODL is displayed. 

 
 Figure 10.52 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.53 - Choose the classes and packages 
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4. Specify the Output path and select Generate to generate ODL.  

 
Figure 10.54 - Select Generate 

 
5. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.55 - Open output folder 
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6.ODL files generated. 

 
Figure 10.56 - ODL files generated 

 

Generating ActionScript 

SDE for Eclipse can generate ActionScript file. 
To generate ActionScript file: 

1. Open the Instant Generator dialog for ActionScript by clicking Modeling > Instant Generator > ActionScript... in the 
main menu. 

 
 Figure 10.57 - Open Instant Generator dialog for ActionScript 
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2. The Instant Generator dialog box for ActionScript is displayed. 

 
 Figure 10.58 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.59 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.60 - Edit the options 

 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute.  

Advanced Options... Edit the advance options.  

Table 10.5 
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Figure 10.61 - Example illustrating the functions of different options in Advanced Options 

 

 
Figure 10.62 - Diagram of invalid char 
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5. Specify the Output path and select Generate to generate ActionScript.  

 
Figure 10.63 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.64 - Open output folder 
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7.ActionScript files generated. 

 
Figure 10.56 - ActionScript files generated 

 

Generating IDL 

SDE for Eclipse can generate IDL file. 
To generate IDL file: 

1. Open the Instant Generator dialog for IDL by clicking Modeling > Instant Generator > IDL...  in the main menu. 

 
 Figure 10.66 - Open Instant Generator dialog for IDL 
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2. The Instant Generator dialog box for IDL is displayed. 

 
 Figure 10.67 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.68 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.69 - Edit the options 

 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute.  

Advanced Options... Edit the advance options.  

Table 10.6 
 

 

 Figure 10.70 - Example illustrating the functions of different options in Advanced Options 
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5. Specify the Output path and select Generate to generate ActionScript.  

 
Figure 10.71 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.72 - Open output folder 
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7.IDL files generated. 

 
Figure 10.73 - IDL files generated 

 
 

Generating C++ 

SDE for Eclipse can generate C++ file. 
To generate C++ file: 

1. Open the Instant Generator dialog for IDL by clicking Modeling > Instant Generator > C++... in the main menu. 

 
 Figure 10.74 - Open Instant Generator dialog for C++  
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2.The Instant Generator dialog box for C++ is displayed. 

 
 Figure 10.75 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.76 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.77 - Edit the options 

 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding 
operation(s) will be generated for the role's attribute. 

Association 
implementation 

Select from drop-down menu any of the options to configure the multiplicity of a class: 
Vector - The collection is expandable size. 
Array - The collection has fixed size. 

Advanced Options... Edit the advance options.  

Table 10.7 
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 Figure 10.78 - Example illustrating the functions of different options in Advanced Options 

 

 
Figure 10.79 - Diagram of invalid char 
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5. Specify the Output path and select Generate to generate C++.  

 
Figure 10.80 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.81 - Open output folder 
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7.C++ files generated. 

 
Figure 10.82 - C++ files generated 
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Generating Delphi 

SDE for Eclipse can generate Delphi file. 
To generate Delphi file: 

1. Open the Instant Generator dialog for Delphi by clicking Modeling > Instant Generator > Delphi... in the main menu. 

 
 Figure 10.38 - Open Instant Generator dialog for Delphi 
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2. The Instant Generator dialog box for Delphi is displayed. 

 
 Figure 10.84 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.85 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.86 - Edit the options 

 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute. 

Advanced Options... Edit the advance options.  

Table 10.8 
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 Figure 10.87 - Example illustrating the functions of different options in Advanced Options 
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5. Specify the Output path and select Generate to generate Delphi.  

 
Figure 10.88 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.89 - Open output folder 
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7.Delphi files generated. 

 
Figure 10.90 - Delphi files generated 
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Generating Perl 

SDE for Eclipse can generate Perl file. 
To generate Perl file: 

1. Open the Instant Generator dialog for Delphi by clicking Modeling > Instant Generator > Perl... in the main menu. 

 
 Figure 10.91 - Open Instant Generator dialog for Perl  
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2.The Instant Generator dialog box for Perl is displayed. 

 
 Figure 9.92 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.93 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.94 - Edit the options 

 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute. 

Advanced Options... Edit the advance options.  

Table 10.9 
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Figure 10.95 - Example illustrating the functions of different options in Advanced Options 

 

 
Figure 10.96 - Diagram of invalid char 
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5. Specify the Output path and select Generate to generate Perl.  

 
Figure 10.97 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.98 - Open output folder 
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7.Perl files generated. 

 
Figure 10.99 - Perl files generated 

 
 

Generating XSD 

SDE for Eclipse can generate XSD file. 
To generate XSD file: 

1. Open the  Instant Generator dialog for XSD by clicking Modeling > Instant Generator > XSD... in the main menu. 

 
 Figure 10.100 - Open Instant Generator dialog for XSD 
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2 The. Instant Generator dialog box for XSD is displayed. 

 
 Figure 10.101 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.102 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.103 - Edit the options 

 

Name Description  

Indentation 
To configure the spacing characters you want to use for each indent level. 
A tab button is provided to add tab to define different levels. 

Generate unnamed 
attribute 

To allow generating unnamed attribute. 

Unnamed attribute Predefine a name for unnamed attribute. 

Invalid char replacement 
If there is character which is invalid, the character will be replaced by the character type in the text 
box. 

Default attribute type Configure the default type of attribute. 

Advanced Options... Edit the advance options.  

Table 10.10 
 

 

Figure 10.104 - Example illustrating the functions of different options in Advanced Options 
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Figure 10.105 - Diagram of invalid char 

 

 
5. Specify the Output path. Then, select Generate to generate XSD.  

 
Figure 10.106 - Select Generate 
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6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.107 - Open output folder 

 
7.XSD files generated. 

 
Figure 10.108 - XSD files generated 
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Generating Python 

SDE for Eclipse can generate Python file. 
To generate Python file: 

1. Open Instant Generator dialog for Python by clicking Modeling > Instant Generator > Python... in the main menu. 

 
 Figure 10.109 - Open Instant Generator dialog for Python 
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2. Instant Generator dialog box for Python is displayed. 

 
 Figure 10.110 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.111 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.112 - Edit the options 

 

Name Description  

Attribute prefix To configure the prefix of attribute. 

Parameter prefix To configure the prefix of parameter. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute.  

Advanced Options... Edit the advance options.  

Table 10.11 
 

 

Figure 10.113 - Example illustrating the functions of different options in Advanced Options 
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Figure 10.114 - Diagram of invalid char 
 
 
5. Specify the Output path and select Generate to generate Python.  

 
Figure 10.115 - Select Generate 
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6. The progress of generation is shown in the Generator Output column. After generation is complete, you can select Open 
output folder to open the files in the generated folder. 

 
Figure 10.116 - Open output folder 

 
7. Python files generated. 

 
Figure 10.117 - Python files generated 

 
 
 
 



SDE User’s Guide (Part 1)  Chapter 10 – Instant Generator 

 

10-70 

Generating Objective-C 

SDE for Eclipse can also generate Objective-C files. 
To generate an Objective-C file: 

1. Open the Instant Generator dialog for Objective-C by clicking Modeling > Instant Generator > Objective-C... in the 
main menu. 

 
 Figure 10.118 - Open Instant Generator dialog for Objective-C 
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2. Instant Generator dialog box for Objective-C is displayed. 

 
 Figure 10.119 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.120 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.121 - Edit the options 

Name Description  

Attribute prefix To configure the prefix of attribute. 

Parameter prefix To configure the prefix of parameter. 

Implements abstract 
operations 

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute.  

Advanced Options... Edit the advance options.  

Table 10.12 
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Figure 10.122- Example illustrating the functions of different options in Advanced Options 

 

 
Figure 10.123- Diagram of invalid char 
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5. Specify the Output path. Then, select Generate to generate Objective-C.  

 
Figure 10.124 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the newly generated folder. 

 
Figure 10.125 - Open output folder 
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7. Objective-C files generated. 

 
Figure 10.126 - Objective-C files generated 
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Generating Ada95 

SDE for Eclipse can also generate Ada95 file. 
To generate an Ada95 file: 

1. Open the Instant Generator dialog for Ada95 by clicking Modeling > Instant Generator > Ada95... in the main menu. 

 
 Figure 10.127 - Open Instant Generator dialog for Ada95 
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2. The Instant Generator dialog box for Ada9x is displayed. 

 
 Figure 10.128 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate. 

 
 Figure 10.129 - Choose the classes and packages 
 



SDE User’s Guide (Part 1)  Chapter 10 – Instant Generator 

 

10-78 

4. Edit the Options. 

 
 Figure 10.130- Edit the options 

Name Description  

Attribute prefix To configure the prefix of attribute. 

Parameter prefix To configure the prefix of parameter. 

Generate this parameter Check to generate this parameter. 

This Parameter Name Configure the name of this parameter. 

Advanced Options... Edit the advance options.  

Table 10.13 
 

 

Figure 10.131 - Example illustrating the functions of different options in Advanced Options 
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5. Specify the Output path and click Generate to generate Ada95.  

 
Figure 10.132 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.133 - Open output folder 
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7. Ada95 files generated. 

 
Figure 10.134 - Ada95 files generated 
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Generating Ruby 

SDE for Eclipse can generate Ruby files. 
To generate a Ruby file: 

1. Open Instant Generator dialog for Ruby by clicking Modeling > Instant Generator > Ruby... in the main menu. 

 
 Figure 10.135 - Open Instant Generator dialog for Ada9x 

 



SDE User’s Guide (Part 1)  Chapter 10 – Instant Generator 

 

10-82 

2. Instant Generator dialog box for Ada95 is displayed. 

 
 Figure 10.136 - Instant Generator dialog box 

 

3. Choose the classes or packages you want to generate . 

 
 Figure 10.137 - Choose the classes and packages 
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4. Edit the Options. 

 
 Figure 10.138 - Edit the options 

Name Description  

Attribute prefix Configure the prefix of attribute. 

Parameter prefix Configure the prefix of parameter.  

Implements abstract 
operations  

Check this option to implement abstract operations in generated classes. 

Generate association 
operations 

If you check this box, when a role is selected to provide setter/getter, the corresponding operation(s) 
will be generated for the role's attribute. 

Advanced Options... Edit the advance options.  

Table 10.14 
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Figure 10.139 - Example illustrating the functions of different options in Advanced Options 

 

 
Figure 10.140 - Diagram of invalid char 
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5. Specify the Output path. Then, select Generate to generate Ada95.  

 
Figure 10.141 - Select Generate 

 
6. The progress of generation is shown in the Generator Output column. After generation, you can select Open output folder 
to open the output folder generated. 

 
Figure 10.142 - Open output folder 
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7. Ruby files generated. 

 
Figure 10.143 - Ruby files generated 
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Chapter 11 - Java Round-Trip Engineering 

SDE for Eclipse facilitate the generation and reverse of Java by the Java Round-Trip Engineering.  

In this chapter: 

• Generating Code 
• Reversing Code 
• Select in Code/UML 
• Round-trip Code Engineering 
• Advanced code generation 

Generate Code 

You can generate Java using Java round-trip Engineering in SDE for Eclipse.  

 
Figure 11.1 - Generate code 

 
Here, a class diagram is used as an example to illustrate the steps of generating code. 

 
Figure 11.2 - Class diagram used as an example 

 
You may generate Java source code from three kinds of sources: project, package and class. 
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Generate by Selecting Project 

There are several ways of generating code from project. The first one is by clicking Update Code in the toolbar. 

 
 Figure 11.3 - Clicking Update 

Code 
 
Alternatively, you may select Update Code in Diagram Navigator, Model Tree or Class Repository. 

 
 Figure 11.4 - Selecting Update Code 

 
You may also right-click on the project node in Diagram Navigator, Model Tree or Class Repository, and then select Update 
Project to Code from the popup menu.  

 
 Figure 11.5 - Selecting Update 

Project to Code 
 
This will result in generating code from all the classes models under the project. 



SDE User’s Guide (Part 1)  Chapter 11 – Java Round Trip Engineering 

 

11-4 

Generate by Selecting Package 

Besides generating all the class models, you may select to generate a package of classes. There are several ways to achieve this. 
The first one is by right-clicking on a package in Diagram Navigator, Model Tree or Class Repository, and then by selecting 
Update to Code from the popup menu. 

 
 Figure 11.6 - Selecting Update to 

Code 
 
You may also right-click on a package on diagram, and select Update to Code from the popup menu. 

 
 Figure 11.7 - Selecting Update to Code from the popup menu of a package on 

diagram 
 
Both approaches will result in generating code from the selected package and the class models under it.  
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Generate by Selecting Class 

You may also select to generate code from specific classes. The first way to achieve this is by right-clicking on a class in 
Diagram Navigator, Model Tree or Class Repository, and selecting Update to Code from the popup menu. 

 
 Figure 11.8 - Selecting Update to 

Code 
 
Alternatively, right-click on a class on diagram, and select Update to Code from the popup menu. 

 
 Figure 11.9 - Selecting Update to Code 

 
This will generate code from the selected class model. 
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Reverse Code 

You can reverse class model using Java round-trip Engineering in SDE for Eclipse. 

 
Figure 11.10 - Reverse code 

 
Here, a class called Professor which created in the IDE is used as an example. 

 
 Figure 11.11 - Java source of Professor.java 

 
You may reverse Java source code from three kinds of sources: project, package and class. 

Reverse by Selecting Project 

There are several ways of reversing code from project. The first one is by clicking Update UML Model in the toolbar. 

 
Figure 11.12 - Selecting Update 

UML Model 
 
 



SDE User’s Guide (Part 1)  Chapter 11 – Java Round Trip Engineering 

 

11-7 

Alternatively, you may select Update UML Model in Diagram Navigator, Model Tree or Class Repository. 

 
Figure 11.13 - Selecting Update UML Model 
 
You may also right-click on the project node under the Package Explorer, and then select Update UML Model from the popup 
menu. 

 
Figure 11.14 - Selecting Update UML 

Model 
 
This will result in reversing all the classes and packages defined under the source project.  
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Reverse by Selecting Package 

Besides generating all the class models, you may select to generate a package of classes by right-clicking on a package node 
under the source project, and then by selecting Update UML Model from the popup menu. 

 
Figure 11.15 - Selecting Update UML 

Model 
 
This will result in reversing the selected package, its contained classes, and its subpackages.  
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Reverse by Selecting Class 

You may also select to reverse from specific classes. The first way to achieve this is by right-clicking on a class node under the 
source package, and selecting Update UML Model from the popup menu. 

 
Figure 11.16 - Selecting Update UML Model 

 
Alternatively, right-click on the code editor, and select Update UML Model from the popup menu. 

 
Figure 11.17 - Selecting Update UML Model 

 
This will reverse the selected class into UML class model.  
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Forming Diagram from Reversed Model 

UML class models are formed by reverse engineering. They can be used to form a new class diagram. To form a class diagram 
from the class models: 

1. Select from Model Tree or Class Repository the class models to be included in the new diagram. 
2. Right-click on the selection 
3. Select Form Diagram > %OPTION%  from the popup menu 

To add class models to an existing diagram, simply drag them from Model Tree or Class Repository and drop them onto the 
diagram.  

 
 Figure 11.18 - Drag and drop to add a class model to diagram 
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Select Code from Model 

When editing a class or a class member such as attribute or operation, you can open up the corresponding piece of code. By 
doing so, the code editor will show up and the related portion of code will be highlighted. You can select code from model in 
different ways: 

• Using popup menu of Diagram Navigator, Model Tree or Class Repository 
• Using popup menu of class models in diagram 

To select code from Model Tree, Class Repository or Diagram Navigator: 
Right-click on a class, operation or attribute model under the tree and select Select in Code in the popup menu. 

 
Figure 11.19 - Selecting code from 

class model 
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To select code from class models in diagram: 
Right-click on a class, operation or attribute model in the diagram and select Select in Code in the popup menu.  

 
Figure 11.20 - Selecting code from operation 

 
Selection cannot be made to project and package. 
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Select Model from Code 

During implementation, you can select a class model from the code. By doing so, the class model will be selected under the 
Model Tree and Class Repository. However, selection won't be made to class shape in any diagram. You can select model from 
code in different ways:  

• Using popup menu of Package Explorer 
• Using popup menu of code ediitor 

To select code from Model Tree, Class Repository or Diagram Navigator: 
Right-click on a class, operation or attribute model under the tree and select Select in Code in the popup menu. 

 
Figure 11.21 - Selecting class model from 

code 
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To select code from class models in diagram: 
Right-click on a class, operation or attribute model in the diagram and select Select in Code in the popup menu. 

 
Figure 11.22 - Selecting class model from code 

 
Selection cannot be made to project, package, attribute and operation. 

Round-trip Code Engineering 

Here, the Java round-trip Engineering is shown.  

 
 Figure 11.23 - Java round-trip Engineering 
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In order to demonstrate the round-trip code engineering, the source of a generated Java file is amended. First, a statement is 
amended in the source.  

 
 Figure 11.24 - Statement amended 

Also, an operation is added. 

 
 Figure 11.25 - Class added 

On the other hand, the signature of a class is amended in the diagram. 

 
 Figure 11.26 - Signature amended 
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After all the changes have been saved, generate to code. The source has been changed. Both the changes in the source and in 
the diagram are retained.  

 
Figure 11.27 - Source changed 

Now reverse code. The source is reversed into diagram. 

 
Figure 11.28 - Class changed 

Advanced Options 

Upon generation of Java code, there are advanced options for you to configure your output with. To open the options dialog: 

1. Select Modeling > Application Options... from to open the Options dialog box. 
2. Open the Eclipse category. 

You can enable or disable changing to Modeling Perspective when starting SDE-EC by selecting the desired option from the 
dropdown menu Change to UML perspective when start SDE-EC. 

 
Figure 11.29 - Change to UML perspective 
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There are three tabs.  
Code tab  

 
 Figure 11.30 - Code tab 

 

Name Description  

Default attribute prefix Configure the default prefix of attribute. 

Default operation return type Configure the default return type of operation. 

Default parameter type Configure the default prefix of parameter. 

Remove method body after 
changes to abstract method 

Check the check box to remove method body after change to abstract method. 

Add import statement instead of 
using fully qualified type name 

Check the check box to add import statement. 

Import fully qualified type name 
for referenced type 

Check the check box to import fully qualified type name. 

Auto realize interface Check the check box to realize interface automatically. 

Collection type Select a collection type from the drop down menu. 

Use generic collections  Check the check box to use generic collections. 

Generate annotation on  
Specify the code generator to generate the annotation in field-based or property-based 
access type. 

Generate annotation in code 
convention 

Check the checkbox so that before updating the code, SDE for Eclipse will select suitable 
placement strategy on either field-based or property-based access type. 

System default Select the system default type of text file encoding to type. 

Other Select other types of text file encoding to type. 

Apply Eclipse code formatting 
Check the check box to make the generated code follow Eclipse's code formatting. 
Otherwise, user can defined the code formatting on Brace and Indentation and New 
Lines tabs. 

Table 11.1 
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 Figure 11.31 - Example illustrating options in Code tab about default type setting 

 

 
 Figure 11.32 - Example illustrating options in Code tab about Remove method body 

 

 
 Figure 11.33 - Example illustrating options in Code tab about Add import statement 
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 Figure 11.34 - Example illustrating options in Code tab about Auto realize interface 

 

 
 Figure 11.35 - Example illustrating options in Code tab about Java Collection 
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Brace and Indentation tab  

 
 Figure 11.36 - Brace and Indentation tab 

 

Name Description  

Class declaration 
Select the position of Class declaration from the drop-down menu. 
You can place it on the same line or the next line. 

Constructor declaration 
Select the position of Constructor declaration drop-down menu. 
You can place it on the same line or the next line. 

Method declaration 
Select the position of Method declaration drop-down menu. 
You can place it on the same line or the next line. 

Enum declaration 
Select the position of Enum declaration drop-down menu. 
You can place it on the same line or the next line. 

Annotation type declaration 
Select the position of Annotation type declaration drop-down menu. 
You can place it on the same line or the next line. 

All Same Line Select to set all the brace positions to be on the same line. 

All Next Line Select to set all the brace positions to be on the same line. 

Indentation policy 
Select a way of indentation. 
You may choose Tabs and space to be the indentation. 

Indentation size If you select space as indentation, you can select the size of it. 

Table 11.2 
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Figure 11.37 - Example illustrating options in Brace and Indentation tab 

 
New Lines Tab  

 
 Figure 11.38 - New Lines Tab 
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Name Description  

Before package declaration Type in the number of blank lines place before package declaration. 

After package declaration Type in the number of blank lines place after package declaration. 

Before import declaration Type in the number of blank lines place before import declaration. 

After import declaration Type in the number of blank lines place after import declaration. 

Before first declaration Type in the number of blank lines place before first declaration. 

Before different kind declaration Type in the number of blank lines place before different kind declaration. 

Before field declaration Type in the number of blank lines place before field declaration. 

Before method declaration Type in the number of blank lines place before method declaration. 

Before inner type declaration Type in the number of blank lines place before inner type declaration. 

Number of lines to empty body Type in the number of blank lines place to the empty body. 

Table 11.3 

 

 
Figure 11.39 - Example illustrating options in New Lines tab 

 

 
Figure 11.40 - Example illustrating option in New Lines tab 
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Chapter 12 - State Machine Diagram Code 
Generation 

SDE for Eclipse can assist you in drawing a State Machine Diagram, as well as generate a State Machine Diagram Code. 

 
 Figure 12.1 - State Machine Diagram 
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Drawing State Machine Diagram 

To generate a state machine diagram, you should first have a Class on the class diagram. Select Sub Diagrams > State 
Machine Diagram > Create State Machine Diagram from the pop-down menu of the class to create a sub diagram.  

 
Figure 12.2 - Select Create State Machine Diagram  

 
You will see an initial pseudo state on the state machine diagram. 

 
Figure 12.3 - State machine diagram with an initial pseudo state 
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Drag a State from the diagram toolbar and drop the diagram. 

 
Figure 12.4 - Drag and drop a State 

 
Alternatively, you can use the resources of the initial pseudo state. 

 
Figure 12.5 - Using resources 

 
A diagram can then be created. 

 
 Figure 12.6 - Diagram created 
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Generate State Machine Code 

The process of creating a State Machine Code is simple.  
To generate a state machine code: 
1. Select Modeling > State Machine Code > Generate Code from the main menu. 

 
Figure 12.7 - Select Generate Code... 

 
2. The Generate state machine code dialog is displayed.  

 
Figure 12.8 - Generate state machine code dialog 
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3. Select a language to generate the code in from the drop-down menu. 

 
 Figure 12.9 - Select Language 

 
4. Configure an output path by selecting ... or type in the path in the text box, and configure the options in the dialog. 

 
 Figure 12.10 - Configure an output path 
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5. The process of generation is shown. You may choose to Close Dialog when finished progress by checking the check box. 

 
 Figure 12.11 - Process of generation 

 
6. The code is generated. 

 
Figure 12.12 - Code generated 
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Programming with Generated State Machine Code 

SDE for Eclipse supports the generation of different types of state machine code. Since the steps for generation of codes in 
different languages are similar, Java will be used as an example to illustrate the steps. 
Before generating the code, you may want to configure the properties of states and transitions. 
 
For state, configure by selecting Open Specification...from the pop-up menu. 

 
Figure 12.13 - Select Open Specification... 
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The State Specification dialog box is now open, and you can configure the state properties here. You may edit the Entry 
property by clicking Edit... .  

 
Figure 12.14 - State Specification dialog box 
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This is the Activity Specification(Entry)  dialog box. After editing to suit your needs, click OK to confirm. 

 
Figure 12.15 - Activity Specification(Entry) dialog box 

 
State's property has been edited. 

 
Figure 12.16 - State's property edited 
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Similarly, you can edit the transition by selecting the Open Specification... from the pop-up menu. 

 
Figure 12.17 - Open Specification... 
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Then, edit the properties of transition in the Transition Specification dialog box. 

 
Figure 12.18 - Transition Specification dialog box 

 
The states and transitions properties are configured. 

 
Figure 12.19 - State Machine Diagram 
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Running sample application 

After generating Java files, you can compile and run them.  Command Prompt in windows is used as an example to 
demonstrate the actions. 
1. Run the compiler.  Change the directory to the directory where the code file is generated.  Type in the command for 
compiling.  In this example, the command is javac Name\*java . 

 
Figure 12.20 - Compile Java 

 
 
2. After compiling, you can enter another command for running Java.  For Windows, the command is java -cp . 
telephone.TelephoneSample . 

 
 Figure 12.21 - Run Java 
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3. The Java is run. 

 
 Figure 12.22 - Sample Java 
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Insert Implementation 

If there is no implementation, the Java cannot be run because there is an error. 

 
 Figure 12.23 - Error message box 

. 
The original state machine diagram code generated did not have any implementation. 

 
 Figure 12.24 - No implementation 
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You can add the implementation in the source.  

 
 Figure 12.25 - With implementation 
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The diagram sample is run with the implementation. 

 
Figure 12.26 - Java sample 
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Reverse State Machine Code 

Apart from generation of state machine code, SDE for Eclipse also supports the reversal of the state machine code file, with 
extension .sm. 

 
Figure 12.26 - A .sm file 
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To reverse the .sm file: 
1. Select Modeling > State Machine Code > Reverse Code... from the main menu . 

 
Figure 12.27 - Select Reverse Code... 

 
2. The Reverse State Machine Code dialog box is displayed. Select the Class and State Diagram.  

 
Figure 12.28 - Reverse State Machine Code dialog box 

 
3. Configure the input file path by typing in the text box or select ... .Select OK  to confirm. 

 
Figure 12.29 - Configure the input file path 
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4. The progress of reversal is shown. You can select to Close Dialog when finished progress by checking the check box.  

 
Figure 12.30- Progress of reversing 

 
5. The state machine code is now reversed. 

 
Figure 12.31 - State machine code is reversed 
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Chapter 13 - Team Collaboration with VP 
Teamwork Server 

Visual Paradigm Teamwork Server is easy to use version control and collaboration platform. With SDE for Eclipse VP 
Teamwork Server integration you can record and keep history of all changes in your design in your VP Teamwork Server. 
Other people who may need to only view your designs just need to use the free Viewer to have a look at the project. Please be 
reminded VP Teamwork Server integration is only available in Modeler Edition or above. 

In this chapter: 

• Operating projects 
• Reviewing the old revisions of projects 
• Comparing the differences between revisions 
• Using branch and tag 
• Providing suggested branch usage 

Starting up the Server 

Before you can manage projects in VP Teamwork Server, you have to start the server first. 
You can select the StartTeamworkServer.exe icon in the "bin" folder inside the Teamwork Server installation directory. 

 
Figure 13.1 - Select StartTeamworkServer.exe 
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Starting the Teamwork Client Dialog Box 

The Teamwork Client dialog box is the access point for all Teamwork functions, such as operating projects, reviewing and 
comparing projects and using branches and tags. There are three ways you can start Teamwork Client. 
To start using main menu, you can select Modeling > Teamwork > Open Teamwork Client... . 

 
Figure 13.2 - Open Teamwork Client using main menu 

 
If not, you may use the tool bar to open Teamwork Client dialog box. 

 
Figure 13.3 - Open Teamwork Client using toolbar 

 
 



SDE User’s Guide (Part 1)  Chapter 13 – Team Collaboration with VPTS 

 

13-4 

You can also right click on the project node of different panes and select Teamwork > Open Teamwork Client... . 

 
Figure 13.4 - Open Teamwork Client with project node 

 
By using any one of these methods, the Login to the Teamwork Server dialog box is displayed. 

 
Figure 13.5 - Login to the Teamwork Server dialog box 
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Then, configure the details of server connection. Then click OK to confirm. 

 
Figure 13.6 - Configure details of server conncetion 
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Teamwork Client dialog box is opened.  

 
Figure 13.7 - Teamwork Client dialog box 

 

 Name Function  

 Logout Logout from the server. 

 Checkout  Checkout projects from the server. 

 Open Open the selected project. 

 Refresh projects Refresh the projects to get the latest status of them. 

 Tag... Create a tag for the selected project. 

 Branch... Create a branch for the selected project. 

 Switch... Switch your location in the project. 

 Delete branch... Delete a branch. 
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Checking out Project 

If you have already imported a project to server or selected a project to manage, you can checkout the project from the 
repository. 
When you have just selected a project in the Projects list, the status is 'Not checked out'. 

 
 Figure 13.8 - Project not checked out 

 
When you click Open Project, you can checkout the project and open it immediately. 

 
Figure 13.9 - Select Open Project 
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Alternatively, you can choose to checkout the project without opening it. Checkout Project is quite different from Open Project. 
After checking out the project, your will stay in the Teamwork Dialog for further actions. For example, creating branch, Merge 
change from branch. If you select Open Project, you will open the project for viewing and modification.  
To checkout the project, click Checkout in Teamwork Client dialog box. 

 
 Figure 13.10 - Checkout the project 

 
The status of the project is changed and you have checkout the project successfully. 

 
 Figure 13.11 - Project checked out 
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Committing Project 

After you have modified the project, you can share your local changes with other team member by committing the project to 
server. 
You may commit project in the toolbar. 

 
 Figure 13.12 - Commit project 

 
A Commit Project dialog box will show you the progress of commit. 

 
 Figure 13.13 - Commit project dialog box 

 
A dialog box will be displayed and you may enter a description of the changes. Then, click OK . 

 
 Figure 13.14 - Enter description of commit change 
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A Commit Model(s) dialog box shows the models you have modified. You can click OK to commit. 

 
 Figure 13.15 - Commit Model(s) dialog box 

 
Sometimes, you may encounter conflict when committing models.  

 
Figure 13.16 - Commit with conflict 
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You can choose to revert or overwrite to solve. For more details, please refer to the section 'Resolving Conflict'. 

 
Figure 13.17 - Select overwrite or revert 

Updating Project 

Apart from committing the project you have changed to the server, you can also get other teammates' changes in the server to 
local by updating project.  
To update project, you can click the icon for update in toolbar. 

 
 Figure 13.18 - Update project 
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Update Model(s) dialog box is displayed. The models changed by others are shown. You can click OK to update the models. 

 
 Figure 13.19 - Update Model(s) dialog box 
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Reverting Project 

You may encounter the situation that you have made a lot of changes in the project just to find there are a lot of mistakes. In 
this case, you may want to rollback all the changes and redo the whole project. 
Here, you can revert all local changes by clicking the Revert button. 

 
 Figure 13.20 - Revert project 

 
A dialog box will show and ask if you want to revert. Click Yes to confirm and the project is reverted. 

 
 Figure 13.21 - Confirm revert project 
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Checking for Update 

If the project you are managing is not up-to-date, the status in Teamwork Client dialog box will change. 

 
Figure 13.22 - Status changed 

 
Alternatively, you can check if the local project has a newer version in teamwork server repository by clicking the Check for 
Update button. 

 
Figure 13.23 - Select Check for Update 

 
A message will tell you what the latest revision is. You can then select Update to get the modification from the server. For 
more details, please refer to the section 'Updating project'. 
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Figure 13.24 - Message showing the latest version 
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Resolving Conflict 

Sometimes, you may modify the same model as your teammate with different changes. In this way, the server may not know 
which revision should be preserved and it shows conflict.  
Conflicts can happen when you commit the project. 

 
Figure 13.25 - Conflict found in merging 
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Conflict may also happen when you update your project. 

 
Figure 13.26 - Conflict found in updating 

 
When you face conflict, you can solve it by selecting the conflict model and clicking Overwrite  or Revert.  
Overwrite is to keep local changes while Revert is to accept changes from server. 

 
Figure 13.27 - Solving conflict 
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Viewing Revision History 

From time to time, there may be a lot of changes made by you and your teammates. In SDE for Eclipse, you can view back the 
previous revisions of the project. 
To view the history of committed changes, open the Teamwork Client dialog box and select Revisions tag. 

 
 Figure 13.28 - Select Revisions 

 
You can see the different revisions of the project. 

 
 Figure 13.29 - Different revisions of the project 
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You can see the model, diagram and diagram elements modified in that version. You can also see the checkin description in 
that version. 

 
 Figure 13.30 - Changes of different revisions 
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Checking Out Old Revision 

You can checkout the old revision of project and make changes in it. Afterwards, you can commit your changes to the server. 
To check out a revision of a project, you can select a revision and click Open Project. 

 
Figure 13.31 - Check out old revision 
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Comparing Between Revisions 

You may want to see the differences between different revisions here in SDE for Eclipse.  
To achieve, first you may select a revision. 

 
Figure 13.32 - Select one revision 
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Then, you may press Ctrl and click on the revision you want to compare with.  

 
Figure 13.33- Select another revision 
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Afterwards, click Compare Project to compare. 

 
Figure 13.34 - Select Compare Project 
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A Compare Projects from revision dialog box appears and shows you the differences between your selected revisions. 

 
Figure 13.35 - Compare Project dialog box 

 

Branch and Tag Project 

Branch is a technique to separate the development of project from trunk. You can modify the project in branch while keep the 
most stable version design in trunk. 
In this way, you can perform some research or time-taking task in branch and merge the changes to trunk only when the branch 
is proven to be stable.  
Tag provides a convenient technique to manage and label a stable version. You can go back to check the stable version by 
switching to Tag. 

Creating a Branch 

You can create a branch by clicking the icon for branch in toolbar. 

 
Figure 13.36 - Select branch 
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Create Branch dialog box is displayed and you can enter the name of branch you want to create. 

 
Figure 13.37 - Create Branch dialog box 

 
Then, select a status of branch from the drop-down menu.  

 
Figure 13.38 - Select from drop-down menu 

 
Then, click OK to confirm creating branch. 

 
Figure 13.39 - Confirm creating branch 
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Managing a Branch 

In VP Teamwork Server, you can manage a branch by switching to that branch. 
To switch, you can select the Switch... icon in the toolbar. 

 
Figure 13.40 - Select Switch... 

 
Swtich to dialog box is opened. You can select a branch to switch. 

 
Figure 13.41 - Select a branch to switch 
 
Afterwards, click OK to switch. 

 
Figure 13.42 - Confirm switch 

 

Creating a Tag 

You can label the stable version of project by creating a tag there. 
To create a tag, select Tag... in the toolbar. 

 
Figure 13.43 - Select Tag... 
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Then, you can enter tag name in the Create Tag dialog box. 

 
Figure 13.44 - Create Tag dialog box 

 
Afterwards, you can select your location after creating tag. 

 
Figure 13.45 - Select location after creating tag 

 
Tag is created. 

 
Figure 13.46 - Tag created 
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Managing a Tag 

Similar to managing a branch, you can manage a branch by switching to that branch. 
To switch, you can select the Switch... icon in the toolbar. 

 
Figure 13.47 - Select Switch... 

 
Swtich to dialog box is opened. You can select a branch to switch. 

 
Figure 13.48 - Select a branch to switch 
 
Afterwards, click OK to switch. 

 
Figure 13.49 - Confirm switch 

 

Usage of Merge 

When you have modified your project in branch, you can merge the changes you made to trunk. 
To merge, you can select the icon for merging in the toolbar. 

 
Figure 13.50 - Icon for merging 
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Merge dialog box is displayed. You can select the URL you want to merge from by typing in the text box or select ... . You can 
also select the revision which take part in the merging. 

 
Figure 13.51 - Merge dialog box 

 
The progress of merging is shown. 

 
Figure 13.52 - Progress of merging 
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Then, a dialog box tells you what models and diagrams are going to be merged. You can click OK to confirm merging. 

  
 Figure 13.53 - Models and diagrams which are going to merge 
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Suggested Branch Usage 

This section will show you the suggested usage of the Branch with VP Teamwork Server integration. 
Here, you will learn how to create a single branch called "supportWebService". However, you can choose to have multiple 
branch running at the same time. 

 
Figure 13.54 - Suggested branch usage 
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Chapter 14 – Team Collaboration with CVS 
Repository 

CVS is widely adopted version control and collaboration platform. With SDE for Eclipse CVS repository integration you can 
record and keep history of all changes in your design in your CVS repository. Moreover, your designs are stored along with 
source codes in the same repository. This allows both design and source code to be backed up together, and also saves 
administration cost by needing only a single repository in your team. Other people who may need to only view your designs 
just need to use the free Viewer to have a look at the project. Please be reminded CVS repository is only available in Standard 
Edition or above. 

In this chapter: 

• Importing and managing projects 
• Operating projects 
• Reviewing the old revisions of projects 
• Comparing the differences between revisions 
• Using branch and tag 
• Providing suggested branch usage 

Starting the Teamwork Client Dialog Box 

The Teamwork Client dialog box is the access point for all Teamwork functions, such as importing and managing projects, 
operating projects, reviewing and comparing projects and using branches and tags. There are three ways you can start 
Teamwork Client. 
To start using the main menu, you can select Modeling > Teamwork > Open Teamwork Client... . 

 
Figure 14.1 - Open Teamwork Client using main menu 
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If not, you may use the tool bar to open the Teamwork Client dialog box. 

 
Figure 14.2 - Open Teamwork Client using toolbar 

 
You can also right click on the project node of different panes and select Teamwork > Open Teamwork Client... . 

 
Figure 14.3 - Open Teamwork Client with project node 

 
By using any one of these methods, the Login to the Teamwork Server dialog box will be displayed. 

 
 Figure 14.4 - Login to the Teamwork Server dialog box 
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You can select CVS as the server. 

 
Figure 14.5 - Login to the Teamwork Server dialog box 

 
Configure the details of the server connection, then click OK to confirm. 

 
Figure 14.6 - Configure details of server conncetion 

 
 



SDE User’s Guide (Part 1)  Chapter 14 – Team Collaboration with CVS 

 

14-5 

The Teamwork Client dialog box is opened.  

 
Figure 14.7 - Teamwork Client dialog box 

 

 Name Function  

 Logout Logout from the server. 

 Manage project Manage projects in the server. 

 Import project Import a project into the server. 

 Open Open the selected project. 

 Check for Update Check for updates in the selected project. 

 Refresh projects Refresh the projects to get the latest status. 

 Tag... Create a tag for the selected project. 

 Branch... Create a branch for the selected project. 

 Merge... Merge the modification of branch to head. 

 
Switch... Switch your location in the project. 

 
Delete branch... Delete a branch. 

 
Project Details... Show details of the selected project. 

 Revision Modification history of the selected project.  

 Projects list Show projects selected to be managed. 

Table 14.1 
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Importing Project to the Repository 

You can import your project to the repository by clicking the Import Project to Repository icon in the Teamwork Client 
dialog box. 

 
Figure 14.8 - Select Import Project to Repository 
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The Import Project  dialog box will be displayed. You can edit the project name and the type of project file you want to import. 

 
Figure 14.9 - Import Project dialog box 

 

 Name  Function  

 Project name Edit the name of the imported project. 

 Currently opened project Import the project you have opened 

 Import existing project Import an existing project from the local file system. 

 Create new project Create a new project in the repository. 

 Create folder for project Create a folder for an imported project automatically. 

Table 14.2 
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You can then select the repository where your project will be imported to. You may right-click on a folder and select New 
Remote Folder from the popup menu to create another folder inside it.  

 
 Figure 14.10 - Open a new remote folder 

 

Managing Teamwork Project 

Only the first project user, who usually is Project Leader or Business Analyst, needs to import project to repository. Other team 
members may use the Manage Project dialog box to manage these working projects. To open the Manage Project dialog box, 
you can right-click on the Projects List in the Teamwork Client dialog box, and select Manage Project in the popup menu.  

 
 Figure 14.11 - Select Manage Project 
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Select a project in the repositories and click Add selected to add the project to the Projects list. You may manage more 
than one teamwork project at the same time by selecting different projects and clicking Add selected.  

 
 Figure 14.12 - Manage Project dialog box 
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If you want to remove a project which is added to your Projects list, select Remove selected to remove the project 
selected in the list. 

 
 Figure 14.13 - Remove selected project 

 

Checking Out Project 

If you have already imported a project to server or selected a project to manage, you can checkout the project from the 
repository. 
When you have just selected a project in the Projects list, the status is 'Not checked out'. 

 
 Figure 14.14 - Project not checked out 
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Clicking Open Project will checkout the project and open it immediately. 

 
 Figure 14.15 - Open the project  
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Alternatively, you can choose to checkout the project without opening it. Checkout Project is quite different from Open Project. 
After checking out the project, your will stay in the Teamwork Dialog for further actions. For example, creating branch, Merge 
change from branch. If you select Open Project, you will open the project for viewing and modification.  
To checkout the project, click Checkout in Teamwork Client dialog box. 

 
 Figure 14.16 - Checkout the project 

 
The status of the project is now changed and the project has been checked out successfully. 

 
 Figure 14.17 - Project checked out 
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Committing Project 

After the project has been modified, you can share your local changes with other team members by committing the project to a 
server. 
You may commit project in the toolbar. 

 
 Figure 14.18 - Commit project 

 
A Commit Project dialog box will show you the committing progress. 

 
 Figure 14.19 - Commit project dialog box 

 
A dialog box will be displayed and you may enter a description of the changes. Click OK . 

 
 Figure 14.20 - Enter description of commit change 
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A Commit Model(s) dialog box shows the models you have modified. Click OK to commit. 

 
 Figure 14.21 - Commit Model(s) dialog box 

 
Sometimes, you may encounter conflict when committing models.  

 
Figure 14.22 - Commit with conflict 



SDE User’s Guide (Part 1)  Chapter 14 – Team Collaboration with CVS 

 

14-15 

 
You can choose to revert or overwrite to solve. For more details, please refer to the section 'Resolving Conflict'. 

 
Figure 14.23 - Select overwrite or revert 

 

Updating Project 

Apart from committing the modified project to the server, you can also get teammates' changes on the server to your local area 
by updating teh project. To update a project, click the icon for update in the toolbar. 

 
 Figure 14.24 - Update project 

 
Update Model(s) dialog box is displayed. The models changed by others are shown. Click OK to update. 
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 Figure 14.25 - Update Model(s) dialog box 
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Reverting Project 

You may encounter a situation when you have made a lot of changes in the project just to find there are a lot of mistakes. In 
this case, you may want to rollback all the changes and redo the whole project. 
Here, you can revert all local changes by clicking the Revert button. 

 
 Figure 14.26 - Revert project 

 
A dialog box will show and ask if you want to revert. Click Yes to confirm and the project will be reverted. 

 
 Figure 14.27 - Confirm revert project 
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Resolving Conflict 

Sometimes, you may modify the same model as your teammate with different changes.  In this case, the server will not know 
which revision should be preserved and it will show a conflict.  
Conflicts may happen when you commit the project. 

 
Figure 14.28 - Conflict found in merging 
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Conflict may also happen when you update your project. 

 
Figure 14.29 - Conflict found in updating 

 
If a conflict appears, you can solve it by selecting the conflicting model and clicking Overwrite  or Revert.  
Overwrite  keeps the local changes while Revert accepts changes from the server. 

 
Figure 14.30 - Solving conflict 
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Viewing Revision History 

From time to time, there may be a lot of changes made by you and your teammates. In SDE for Eclipse, you can view previous 
revisions of the project. 
To view the history of committed changes, open the Teamwork Client dialog box and select Revisions tag. 

 
 Figure 14.31 - Select Revisions 

 
You can see the different revisions of the project. 

 
 Figure 14.32 - Different revisions of the project 
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You can see the model, diagram and diagram elements modified in that version. You can also see the check in description in 
that version. 

 
 Figure 14.33 - Changes of different revisions 
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Comparing Between Revisions 

To see the differences between different revisions in SDE for Eclipse, select a revision. 

 
Figure 14.35 - Select one revision 

 
Then press Ctrl and click on the revision you want to compare with.  

 
Figure 14.36 - Select another revision 
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Click Compare Project to compare. 

 
Figure 14.37 - Select Compare Project 

 
A Compare Projects from revision dialog box will appear and show you the differences between your selected revisions. 

 
Figure 14.38 - Compare Project dialog box 
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Branch and Tag Project 

Branch is a technique to separate the development of project from head. You can modify the project in branch while keep the 
most stable version design in head. 
In this way, you can perform some research or time-taking task in branch and merge the changes to head only when the branch 
is proven to be stable.  
Tag provides a convenient technique to manage and label a stable version. You can go back to check the stable version by 
switching to Tag. 

Creating a Branch 

Create a branch by clicking the icon for branch in toolbar. 

 
Figure 14.39 Select branch 

 
The Create Branch dialog box is displayed.  Enter the name of branch you want to create. 

 
Figure 14.40 - Create Branch dialog box 

 
Then, select a status of branch from the drop-down menu.  

 
Figure 14.41 - Select from drop-down menu 
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Click OK to confirm creating the branch. 

 
Figure 14.42 - Confirm creating branch 

 

Managing a Branch 

Similar to managing a project, you can manage a branch in the Manage Project dialog box. 
First, select a branch under a project. 

 
Figure 14.43 - Manage project dialog box 
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Click Add selected  to add the branch to your Projects list. 

 
Figure 14.44 - Add selected branch 
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You can also click Remove selected  to remove the branch from the Projects list. 

 
Figure 14.45 - Remove selected branch 

 

Creating a Tag 

You can label the stable version of project by creating a tag there. 
To create a tag, select Tag... in the toolbar. 

 
Figure 14.46 - Select Tag... 

 
 



SDE User’s Guide (Part 1)  Chapter 14 – Team Collaboration with CVS 

 

14-28 

Then, edit the name of tag in Create Tag dialog box. 

 
Figure 14.47 - Create Tag dialog box 

 
Next, you can select the status after creating tag from the drop-down menu.  

 
Figure 14.48 - Select the status after creating tag 

 
After you have select OK , a message will show you that tag has been created. 

 
Figure 14.49 - Message showing tag created 
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Managing a Tag 

Similar to managing a branch, you can select a tag and click Add Selected in Manage Project dialog box to add the project to 
Projects list. 

 
Figure 14.50 - Add selected project 
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You may remove the tag from Projects list by click Remove selected. 

 
Figure 14.51 - Select Remove selected 

 

Usage of Merge 

When the project in your branch has been modified, you can merge the changes made to the head. 
To merge, select the icon for merging in the toolbar. 

 
Figure 14.52 - Icon for merging 
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The Merge dialog box is displayed. Select a branch to merge to, and select the revision you want to merge. 

 
Figure 14.53 - Merge dialog box 

 
The progress of merging is shown. 

 
Figure 14.54 - Progress of merging 

 
Then, a dialog box tells you what models and diagrams are going to be merged. Click OK to confirm the merge. 

  
 Figure 14.55 - Models and diagrams which are going to merge 
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Suggested Branch Usage 

This section will show you the suggested usage of the Branch with SDE for Eclipse CVS integration. 
Here, you will learn how to create a single branch called "supportWebService". However, you can choose to have multiple 
branch running at the same time. 

 
Figure 14.56 - Suggested branch usage 
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Chapter 15 - Team Collaboration with 
Subversion Repository 

More and more development team adopt Subversion as version control and collaboration platform. With SDE for Eclipse 
Subversion repository integration you can record and keep history of all changes in your design in your Subversion repository. 
Moreover, your designs are stored along with source codes in the same repository. This allows both design and source code to 
be backed up together, and also saves administration cost by needing only a single repository in your team. Other people who 
may need to only view your designs just need to use the free Viewer to have a look at the project. Please be reminded that 
Subversion server is only available in Standard Edition or above. 

In this chapter: 

• Importing and managing projects 
• Operating projects 
• Reviewing the old revisions of projects 
• Comparing the differences between revisions 
• Using branch and tag 
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Starting the Teamwork Client Dialog Box 

The Teamwork Client dialog box is the access point for all Teamwork functions, such as importing and managing projects, 
operating projects, reviewing and comparing projects and using branches and tags. There are three ways you can start 
Teamwork Client. 
To start using main menu, you can select Modeling > Teamwork > Open Teamwork Client... . 

 
Figure 15.1 - Open Teamwork Client using main menu 

 
If not, you may use the tool bar to open Teamwork Client dialog box. 

 
Figure 15.2 - Open Teamwork Client using toolbar 
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You can also right click on the project node of different panes and select Teamwork > Open Teamwork Client... . 

 
Figure 15.3 - Open Teamwork Client with project node 

 
By using any one of these methods, the Login to the Teamwork Server dialog box is displayed. 

 
Figure 15.4 - Login to the Teamwork Server dialog box 
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You can select Subversion as server.  

 
Figure 15.5 - Select subversion as server 

 
Then, configure the details of server connection. Then click OK to confirm. 

 
Figure 15.6 - Configure details of server conncetion 
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Teamwork Client dialog box is opened.  

 
Figure 15.7 - Teamwork Client dialog box 

 

 Name Function  

 Logout Logout from the server. 

 Manage project Manage projects in the server. 

 Import project Import a project into the server. 

 Open Open the selected project. 

 Check for Update Check if there is any update in the selected project. 

 Refresh projects Refresh the projects to get the latest status of them. 

 Tag... Create a tag for the selected project. 

 Branch... Create a branch for the selected project. 

 Merge... Merge the modification of branch and trunk. 

 
Switch... Switch your location in the project. 

 
Delete branch... Delete a branch. 

 
Project Details... The details of the selected project is shown. 

 Revision History of modification of the selected project.  

 Projects list The projects which have been selected to be managed is shown. 
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Importing Project to the Repository 

You can import your project to the repository by clicking the Import Project to Repository icon in the Teamwork Client 
dialog box. 

 
Figure 15.8 - Select Import Project to Repository 
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Import Project  dialog box will be displayed. You can edit the project name and the type of project file you want to import. 

 
Figure 15.9 - Import Project dialog box 

 

 Name Function  

 Project name Edit the name of imported project. 

 Currently opened project Import the project you have opened. 

 Import existing project Import an existing project from the local file system. 

 Create new project Create a new project in the repository.  

 Create folder for project When import a project, create a folder for that project automatically. 

Table 15.1 
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Then, you can select the repository where your project will be imported to. You may right-click on a folder and select New 
Remote Folder from the popup menu to create another folder in it.  

 
 Figure 15.10 - Open a new remote folder 

 

Managing Teamwork Project 

Only the first project user, who usually is Project Leader or Business Analyst, needs to import project to repository. Other team 
members may use the Manage Project dialog box to manage these working projects. To open the Manage Project dialog box, 
you can right-click on the Projects List in the Teamwork Client dialog box, and select Manage Project in the popup menu.  

 
 Figure 15.11 - Select Manage Project 
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You can select a project in the repositories and click Add selected to add the project to the Projects list. You may 
manage more than one teamwork project at the same time by selecting different projects and click Add selected.  

 
 Figure 15.12 - Manage Project dialog box 
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If you want to remove a project which is added to your Projects list, you can select Remove selected  to remove the 
project selected in the list. 

 
 Figure 15.13 - Remove selected project 

 

Checking Out Project 

If you have already imported a project to server or selected a project to manage, you can checkout the project from the 
repository. 
When you have just selected a project in the Projects list, the status is 'Not checked out'. 

 
 Figure 15.14 - Project not checked out 
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You click Open Project, you can checkout the project and open it immediately. 

 
Figure 15.15 - Open Project 
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Alternatively, you can choose to checkout the project without opening it. Checkout Project is quite different from Open Project. 
After checking out the project, your will stay in the Teamwork Dialog for further actions. For example, creating branch, Merge 
change from branch. If you select Open Project, you will open the project for viewing and modification.  
To checkout the project, click Checkout in Teamwork Client dialog box. 

 
 Figure 15.16 - Checkout the project 

 
The status of the project is changed and you have checkout the project successfully. 

 
 Figure 15.17 - Project checked out 
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Committing Project 

After you have modified the project, you can share your local changes with other team member by committing the project to 
server. 
You may commit project in the toolbar. 

 
 Figure 15.18 - Commit project 

 
A Commit Project dialog box will show you the progress of commit. 

 
 Figure 15.19 - Commit project dialog box 

 
A dialog box will be displayed and you may enter a description of the changes. Then, click OK . 

 
 Figure 15.20 - Enter description of commit change 
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A Commit Model(s) dialog box shows the models you have modified. You can click OK to commit. 

 
 Figure 15.21 - Commit Model(s) dialog box 

 
Sometimes, you may encounter conflict when committing models.  

 
Figure 15.22 - Commit with conflict 
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You can choose to revert or overwrite to solve. For more details, please refer to the section 'Resolving Conflict'. 

 
Figure 15.23 - Select overwrite or revert 

 

Updating Project 

Apart from committing the project you have changed to the server, you can also get other teammates' changes in the server to 
local by updating project.  
To update project, you can click the icon for update in toolbar. 

 
 Figure 15.24 - Update project 
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Update Model(s) dialog box is displayed. The models changed by others are shown. You can click OK to update the models. 

 
 Figure 15.25 - Update Model(s) dialog box 
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Reverting Project 

You may encounter the situation that you have made a lot of changes in the project just to find there are a lot of mistakes. In 
this case, you may want to rollback all the changes and redo the whole project. 
Here, you can revert all local changes by clicking the Revert button. 

 
 Figure 15.26 - Revert project 

 
A dialog box will show and ask if you want to revert. Click Yes to confirm and the project is reverted. 

 
 Figure 15.27 - Confirm revert project 
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Resolving Conflict 

Sometimes, you may modify the same model as your teammate with different changes. In this way, the server may not know 
which revision should be preserved and it shows conflict.  
Conflicts can happen when you commit the project. 

 
Figure 15.28 - Conflict found in merging 
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Conflict may also happen when you update your project. 

 
Figure 15.29 - Conflict found in updating 

 
When you face conflict, you can solve it by selecting the conflict model and clicking Overwrite  or Revert.  
Overwrite is to keep local changes while Revert is to accept changes from server. 

 
Figure 15.30 - Solving conflict 
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Viewing Revision History 

From time to time, there may be a lot of changes made by you and your teammates. In SDE for Eclipse, you can view back the 
previous revisions of the project. 
To view the history of committed changes, open the Teamwork Client dialog box and select Revisions tag. 

 
 Figure 15.31 - Select Revisions 

 
You can see the different revisions of the project. 

 
 Figure 15.32 - Different revisions of the project 
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You can see the model, diagram and diagram elements modified in that version. You can also see the checkin description in 
that version. 

 
 Figure 15.33 - Changes of different revisions 

 



SDE User’s Guide (Part 1)  Chapter 15 – Team Collaboration with Subversion 

 

15-23 

Comparing Between Revisions 

You may want to see the differences between different revisions here in SDE for Eclipse.  
To achieve, first you may select a revision. 

 
Figure 15.34 - Select one revision 
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Then, you may press Ctrl and click on the revision you want to compare with.  

 
Figure 15.35 - Select another revision 
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Afterwards, click Compare Project to compare. 

 
Figure 15.36 - Select Compare Project 
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A Compare Projects from revision dialog box appears and shows you the differences between your selected revisions. 

 
Figure 15.37 - Compare Project dialog box 

 

Branch and Tag Project 

Branch is a technique to separate the development of project from trunk. You can modify the project in branch while keep the 
most stable version design in trunk. 
In this way, you can perform some research or time-taking task in branch and merge the changes to trunk only when the branch 
is proven to be stable.  
Tag provides a convenient technique to manage and label a stable version. You can go back to check the stable version by 
switching to Tag. 

Creating a Branch 

You can create a branch by clicking the icon for branch in toolbar. 

 
Figure 15.38 - Select branch 
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Create Branch dialog box is displayed and you can enter the name of branch you want to create. 

 
Figure 15.39 - Create Branch dialog box 

 
Then, select a status of branch from the drop-down menu.  

 
Figure 15.40 - Select from drop-down menu 
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Then, click OK to confirm creating branch. 

 
Figure 15.41 - Confirm creating branch 

 



SDE User’s Guide (Part 1)  Chapter 15 – Team Collaboration with Subversion 

 

15-29 

Managing a Branch 

Similar to managing a project, you can manage a branch in the Manage Project dialog box. 
First, you may select a branch under your desired project. 

 
Figure 15.42 - Manage project dialog box 
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You can click Add selelcted  to add the branch to your Projects list. 

 
Figure 15.43 - Add selected branch 
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On the other hand, you can click Remove selected  to remove the branch from Projects list. 

 
Figure 15.44 - Remove selected branch 

 

Creating a Tag 

You can label the stable version of project by creating a tag there. 
To create a tag, select Tag... in the toolbar. 

 
Figure 15.45 - Select Tag... 

 
 



SDE User’s Guide (Part 1)  Chapter 15 – Team Collaboration with Subversion 

 

15-32 

Then, you can enter tag name in the Create Tag dialog box. 

 
Figure 15.46 - Create Tag dialog box 
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Afterwards, you can select your location after creating tag. 

 
Figure 15.47 - Select location after creating tag 

 
 



SDE User’s Guide (Part 1)  Chapter 15 – Team Collaboration with Subversion 

 

15-34 

Managing a Tag 

Similar to managing a branch, you can select a tag and click Add Selected in Manage Project dialog box to add the project to 
Projects list. 

 
Figure 15.48 - Add selected project 
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You may remove the tag from Projects list by click Remove selected. 

 
Figure 15.49 - Select Remove selected 

 

Usage of Merge 

When you have modified your project in branch, you can merge the changes you made to trunk. 
To merge, you can select the icon for merging in the toolbar. 

 
Figure 15.50 - Icon for merging 
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Merge dialog box is displayed. You can select the URL you want to merge from by typing in the text box or select ... . You can 
also select the revision which take part in the merging. 

 
Figure 15.51 - Merge dialog box 

 
The progress of merging is shown. 

 
Figure 15.52 - Progress of merging 
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Then, a dialog box tells you what models and diagrams are going to be merged. You can click OK to confirm merging. 

  
 Figure 15.53 - Models and diagrams which are going to merge 

 



SDE User’s Guide (Part 1)  Chapter 15 – Team Collaboration with Subversion 

 

15-38 

Suggested Branch Usage 

This section will show you the suggested usage of the Branch with SDE for Eclipse SVN integration. 
Here, you will learn how to create a single branch called "supportWebService". However, you can choose to have multiple 
branch running at the same time. 

 
Figure 15.54 - Suggested branch usage 

 



 

Configuring Application Options A 
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Appendix A - Configuring Application Options  

This chapter will describe the configurable Application Options and how they can be configured. 

Configuring Application Options using the Applicati on Options 
Dialog Box  

The Application Options can be configured in the Application Options dialog box. To invoke the application dialog, choose 
Tools > Options...from main menu. The Application Options dialog consists of five pages: General, Diagramming, 
Diagram/Model View, Instant Reverse and ORM . Each page represents a category of options whose descriptions are 
described below. 

General 

The General page of the Application Options dialog box contains general application options, such as auto save options, look 
and feel configuration and proxy server settings. 

 

Figure A.1 - Application Option (General) 

Option Description  

Project  

Auto save project Check/Uncheck 'Auto save' project to enable/disable to auto-saving of project file.  
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Auto save interval (mins):  
Click on the Auto save interval (mins) drop down menu and select a time interval for performing 
an auto-save at regular time interval.  

Backup level  Set the number of backup copies of the project file to maintain. 

Confirm close project  Select this option if you want a dialog asking for confirmation every time you try to close a project.  

Confirm delete diagram 
Select this option if you want a dialog asking for confirmation every time you try to delete a 
diagram. 

Confirm delete shape  Select this option if you want a dialog asking for confirmation every time you try to delete shapes.  

Open last project on 
startup 

Select if you want VP-UML to load the last opened project on startup. 

Appearance  

Look and Feel Click on the Look and feel drop down menu and select a look and feel for the program interface.  

Theme  
Click on the Theme drop down menu and select the theme for the selected Look and Feel. The 
theme setting is only available for "Office 2003 LookAndFeel" .  

User Language 
Click on the User Language drop down menu and select a language. This is used for changing the 
language of the VP-UML program interface.  

Connection 

Email  Enter the Email field to specify your email address. 

Use Proxy  
Check/Uncheck Use Proxy to enable/disable the need of using a proxy server for connecting to the 
Internet.  

Host Enter the Host field to specify the host of the proxy server. 

Port  Enter the Port field to specify the port of the proxy server. 

Login name  
Enter the Login name field to specify the user name of the proxy server (if the proxy server 
required the user to login).  

Password 
Enter the Password field to specify the password of the proxy server (if the proxy server required 
the user to login).  

Printing 

Use gradient color when 
print diagram  

Select to use gradient color in printing diagrams. 

Table A.1 
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Diagramming  

The Diagramming page of the Application Options dialog box contains diagram-related options, such as grid settings and anti-
aliasing options. 

 

Figure A.2 - Application Option (Diagramming) 

Option Description  

Appearance  

Show grid Check/Uncheck Show grid to show/hide grid lines.  

Color  Click on the Color field or the ...button beside it to adjust the grid color.  

Width  Enter the Width field to specify the width of the grid.  

Height  Enter the Height field to specify the height of the grid.  

Snap to grid  
Check/Uncheck Snap to grid to set whether diagram elements should/should not stick to 
grid lines when moving in the diagram  

Graphics anti-aliasing Check/Uncheck Graphics anti-aliasing to enable/disable smoothing of edges on graphics. 

Text Anti-Aliasing  Check/Uncheck Text anti-aliasing to enable/disable smoothing of text.  

Documentation type  
Select to use either HTML (rich-text) or plain text format in documentation of models and 
diagrams.  

Diagram background 
Click on the Diagram background field or the ...button beside it to adjust the default 
background color of all diagrams.  

Environment 



SDE User’s Guide (Part 1)  Appendix A – Configuring Application Options 

 

A-5 

Connector Style  Select either Rectilinear or Oblique or Curve for connector style.  

Connection Point Style 
Select either 'Round the shape' or 'Follow center' to specify how the connecting points of 
the connectors should move if the shape is being moved. 

Textual Analysis Highlight 
Option  

Select either Case insensitive or Case sensitive to specify the highlight option in Textual 
Analysis. This determines whether words which are the same as the entered word or/and 
with same case are highlighted.  

Clear opposite side content in 
flow of event 

Select Yes to enable clearing of the opposite side content in flow of event, i.e. In a row 
within a flow of events, entering text on either Actor Input or System Response result sin 
removing the content of the opposite side). Click No to disable clearing of the opposite side 
content in flow of event. Click Prompt to enable prompting for clearing opposite side 
content every time you enter text on one side for which its opposite side has existing 
content. 

Alignment Guide  
Select the diagram alignment guide style to either Show edges (show guides at edges of the 
closest shape) or Show center (show a guide that lies on the center of the closest shape).  

Delay of show Quick Preview in 
Diagram Navigator (second) 

Enter the time (secs) needed for the Quick Preview for being displayed after the mouse is 
hovering on any diagram node in Diagram Navigator.  

Default Copy Action  
Select the default copy action (the action that will be performed when user presses hotkey 
Ctrl+C in diagram).  

Show sequence number in 
collaboration diagram. 

Check/Uncheck to enable/disable showing sequence numbers for messages display in the 
collaboration diagram. 

Show sequence number in 
sequence diagram.  

Check/Uncheck to enable/disable showing sequence numbers for messages displayed in the 
sequence diagram.  

Show shape content when 
dragging 

Check/Uncheck to enable/disable showing the content of shapes and not just the outline. 

Show diagram alignment guide  
Check/Uncheck to enable/disable showing the guide which helps aligning shapes on a 
diagram.  

Show Message Operation 
Signature for Sequence Diagram 
and Communication Diagram 
(diagram-based)  

Select to show operation signature of messages in Sequence Diagrams and Communication 
Diagrams. 

Model Generation  

Generate Sequence Diagram from 
Use Case Description Overwrite 
Existing Diagram  

Select to allow overwrite of sequence diagrams generated from use case description without 
prompt.  

Generate Diagram from Scenario 
Overwrite Existing Diagram 

Select to allow overwrite of diagrams generated from scenarios (activity diagrams) without 
prompt. 

Overwrite Flow of Events when 
Synchronize from Sequence 
Diagram 

Select to allow overwrite of flow of events of use case description is synchronized from 
sequence diagram without prompt.  

Default generate diagram type 
from scenario 

Select the default type of diagram to be generated from scenario (activity diagram). 

Shape  

Font  Enter the font family of shape text. 

Size  Enter the font size of shape text. 

Bold  Check/Uncheck to set the shape text to/not to be bold. 

Italic  Check/Uncheck to set the shape text to/not to be italic. 

Color  
Click on the Color field or the ...button beside it to adjust the default font color of all 
shapes.  

Show extra resources 
Check/Uncheck to enable/disable extra resource icons in addition to those originally 
supported. 

Auto hide resource delay (second) Enter the time interval for hiding resources icons after they have lost focus.  

Shape foreground  Click on the Color field or the ...button beside it to adjust the default color of all shapes. 
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Shape background  
Click on the Color field or the ...button beside it to adjust the default background color of 
all shapes. 

Auto fit size (diagram-based)  Select to keep shapes in diagram fit-to-size. 

Pin from  Select to pin the "from" end of connector by default. 

Pin to  Select to pin the "to" end of connector by default. 

Class  

Use model assist 
Check/Uncheck 'Use model assist' to enable/disable the Model Assist feature that allows 
automatic class name completion.  

Show package structure on model 
assist 

Check/Uncheck to enable/disable displaying the package name of the list of available 
models when using the Model Assist feature.  

Show attribute option  

Set the default option for displaying attributes of classes to one of the following: 
Hide all: All attributes are hidden. 
Show all: All attributes are shown. 
Show public only: Only public attributes are shown. 

Show operation option  

Set the default option for displaying operations of classes to one of the following: 
Hide all: All operations are hidden. 
Show all: All operations are shown. 
Show public only: Only public operations are shown.  

Visibility style 

The default visibility style for Class. It can either be: 
Icon - Visibilities are represented by icons). 
UML - Visibilities are represented by UML visibility symbols, e.g. + for public, - for 
private. 
Off - Visibility is not shown.  

Show attribute initial value Check/Uncheck to enable/disable the display of initial value of attributes 

Show attribute multiplicity  Check/Uncheck to enable/disable the display of multiplicity of attributes  

Show operation signature  Check/Uncheck to enable/disable the display of operation signature of attributes  

Show class member stereotype  
Check/Uncheck to enable/disable the display of stereotype of class members (e.g. attributes 
and operations)  

Show owner of class/package 
Check/Uncheck to enable/disable the display of the owner of classes and packages (e.g. 
package) 

Show template parameter  Check/Uncheck to enable/disable the display of template parameter of classes.  

Display as Robustness Analysis 
icon  

Check/Uncheck to enable/disable displaying classes as robustness analysis icon.  

Display as stereotype icon Check/uncheck to enable/disable displaying classes as stereotype icon (if any). 

Auto-synchronize role name  Select to enable auto synchronization of role names of associations. 

Auto-generate role name  Select to enable auto generation of role names when creating associations. 

ERD  

Show column type Select to show the data type of table columns in ERD and ORM diagram by default. 

Table A.2 
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View 

The View page of the Application Options dialog box contains options related to the view of Diagram Navigator, Model Tree 
and Class Repository. 

 

Figure A.3 - Application Option (View) 

Option Description  

Diagram Navigator Sort 
Type  

Specifies the sort type to use for the Diagram Navigator. It can either be Sort by name (sort by the 
element name, which is the default option) or Sort by type (sort by the element type). 

Model Pane Sort Type  
Specifies the sort type to use for the Model Pane. It can either be No sort, Sort by name (sort by 
the element name, which is the default option) or Sort by type (sort by the element type). 

Class Repository sort 
type  

Specifies the sort type to use for the Class Repository. It can either be Sort by name (sort by the 
element name, which is the default option) or Sort by type (sort by the type). 

Show data types  Check/Uncheck to enable/disable the display of data types in the Model Pane.  

Show relationships  Check/Uncheck to enable/disable the display of relationships in the Model Pane.  

Show sub diagrams Select to show sub diagrams of diagram elements in Diagram Navigator. 

Show Activation in 
Diagram Navigator  

Select to show activations (sequence diagram) in Diagram Navigator.  

Table A.3 

Instant Reverse 
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The Instant Reverse page of the Application Options dialog box contains options related to instant reverse for a specific 
language. 

 

Figure A.4 - Application Option (Instant Reverse) 

Option Description  

.NET  Select the availability of Instant Reverse on .NET. It can either be Not Specified, Enabled or Disabled. 

C++  Select the availability of Instant Reverse on C++. It can either be Not Specified, Enabled or Disabled. 

Table A.4 
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ORM 

The ORM page of the Application Options dialog box contains options related to ORM code generation. 

 

Figure A.5 - Application Option (ORM) 

Option  Description  

Quote SQL 
Identifier  

Allows you to specify the usage of quoted name on reserved word. By using Quote SQL Identifier, the 
reserved word will be quoted when generating the data definition language and used as an ordinary word.  

Table A.5 
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Appendix B - Configuring Stereotypes and 
Tagged Value 

This chapter explains in detail how to apply Stereotypes and Tagged Value to categorize model elements. 

Introduction 

Stereotypes  allow you to categorize different kinds of model elements. It may specify additional constraints and tag definitions 
for the models, and also be used to indicate a difference in meaning or usage between two model elements with an identical 
structure. An icon or formatting (fill, line and font) can be specified to a stereotype to present the elements that apply to that 
stereotype. 

We know that everything in UML contains its own properties. Tagged values let you add properties for specifying keyword-
value pairs of model elements. You can define tags that apply to a model element or a stereotype. 

Adding Stereotype to a Model Element 

 

Figure B.1 - Class with Stereotypes 

To add stereotype for a model element: 

1. Select the desired model element from the diagram. 
2. Right-click on the selection and choose Stereotypes > Stereotypes...from the popup menu. 

 

Figure B.2 - Select Stereotype in popup menu 
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3. This displays the Stereotypes page of the Class Specification dialog box. 

 

Figure B.3 - Class specification dialog (stereotypes) 

4. Select a stereotype listed under the All  list. 
5. Press > to assign the stereotype to the model element. 

 
To assign multiple stereotypes to a model element, press on the Ctrl key and select the desired stereotypes 
and press >> to assign them to the model element. 

6. Press OK  to apply the setting. 
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Configuring Stereotypes 

Apart from using existing stereotypes, you can create new stereotypes to suit your need.  Similarly, you can edit stereotypes to 
change their properties and appearance in a diagram.  To configure stereotypes, you must first display the Configure 
Stereotypes dialog box. Select from main menu Tools > Configure Stereotypes...to display the dialog box. 

 

Figure B.4 - Configure Stereotypes dialog 

Command Description  

Add  
Allows you to create a new stereotype for a particular model element by displaying the Stereotype Specification 
dialog box of the new stereotype. Fill in the details of the new stereotype from that dialog box and confirm the 
changes to create a new stereotype. 

Edit  
Allows you to edit an existing stereotype by displaying the Stereotype Specification dialog box of the selected 
stereotype. Fill in the details of the stereotype from that dialog box and confirm the changes to edit the properties 
of the stereotype..  

Remove Remove a stereotype available to a particular model element. 

OK  Close the dialog box by committing all changes made. 

Cancel  Close the dialog box without saving any changes made. 

Help  Display the Help content of the Configure Stereotypes dialog box. 

Table B.1 
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Creating a New Stereotype 

To create a new stereotype: 

1. Displays the Configure Stereotypes dialog box. 
2. Select the model element for which the new stereotype is to be available to. 

 

Figure B.5 - Model Elements 
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3. Press on the Add...button. This displays the Stereotype Specification dialog box for specifying the details of the new 
stereotype. 

 

Figure B.6 - Stereotypes Specification dialog 

4. Specify the details of the stereotype such as its name, documentation and its icon. (For more details on the use of 
Stereotype Specification dialog box, please refer to the following section in this chapter) 

5. Click OK  to confirm the changes. 

The new stereotype is now available to the selected model element. 

 

Figure B.7 - User defined stereotypes 
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Editing a Stereotype 

 

Figure B.8 - Modify stereotype 

To edit a stereotype: 

1. Display the Configure Stereotypes dialog box. 
2. Select a stereotype from the Stereotypes list for editing. The stereotype can be a predefined one or one defined by you. 

 

Figure B.9 - Select stereotype from the Stereotype list 
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3. Press on the Edit...button. This displays the Stereotype Specification dialog box for specifying the details of the new 
stereotype. 

 

Figure B.10 - Edit Stereotype 

4. Specify the details of the stereotype such as its name, documentation and its icon. (For more details on the use of 
Stereotype Specification dialog box, please refer to the following section in this chapter) 

5. Click OK  to confirm the changes. 

If the stereotype is in use by a model element, the appearance of that stereotype needs to be refreshed by pressing OK  from the 
Configure Stereotypes dialog box in order to commit the changes made.  
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Using the Stereotype Specification Dialog Box 

When creating or editing a stereotype you will come across the Stereotype Specification dialog box. 

 

Figure B.11 - Stereotype specification dialog 

Field Description  

Name  The name of the stereotype. 

Icon Path  An image assigned to this stereotype. Click ...to select the path of the image, or click to discard the icon. 

Fill, Line, Font  
To specify the appearance of the stereotyped shapes. Their usages will be described in detail in the Stereotype 
Formats section later in this chapter. 

Documentation The description or any information relevant to the stereotype.  

Abstract To specify the stereotype as abstract.  

Leaf To specify the stereotype as leaf.  

Root To specify the stereotype as root.  

Reset Reset all changes made.  

OK  Close the dialog box by committing all changes made. 

Cancel  Close the dialog box without saving any changes made. 

Apply  Committing all changes made. 

Help  Display the Help content of Stereotypes Specification dialog box. 

Table B.2 
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Adding Tagged Value to a Stereotype 

To add Tagged Value definitions to a stereotype: 

1. Select Tools > Configure Stereotypes...from main menu. This displays the Configure Stereotypes dialog box. 
2. Select the desired stereotype and click Edit... 

 

Figure B.12 - Press Edit button to open Stereotype specification 

3. The Stereotype Specification dialog box is displayed. Switch to the Tagged Value Definitions tab. 

 

Figure B.13 - Tagged value definitions 
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4. Click Add.  This displays two kind of tags for selection, Text or Model Element.  Click on the desired one. 

 

Figure B.14 - Tag options 

Adding Text Tag to stereotypes 
From the Stereotype Specification dialog box, press Add and then select Text Tag from the popup menu. 

 

Figure B.15 - Add Text tag 

This displays a new Tag entry. 

 

Figure B.16 - A new text tag entry 

To change the name of the Tag, double click to the Name field and enter a new name. 

 

Figure B.17 - Rename the tag 

You can also change the type of Tag from Text to Model Element. To change the type, click on Type field and select a type 
from the popup menu. 

 

Figure B.18 - Change the type of tag 

To specify a default value of the Tag, double click to the Default Value field and enter a value. 

 

Figure B.19 - Enter the value 

Adding Model Element Tag to a stereotype 
From the Stereotype Specification dialog box, press Add and then select Model Element Tag from the popup menu. 

 

Figure B.20 - Add Model Element Tag 
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This displays a new Tag entry. 

 

Figure B.21 - A new model element tag 

To change the name of the Tag, double click to the Name field and enter a new name. 

 

Figure B.22 - Rename the model element tag 

You can also change the type of Tag from Text to Model Element. To change the type, click on Type field and select a type 
from the popup menu. 

 

Figure B.23 - Change the type of tag 

To specify a default value of the Tag, double click to the Default Value field and enter a value. 

 

Figure B.24 - Enter the value of tag 

Adding Tagged Value to a Model Element 

To add Tagged Value definitions to a model element: 

1. Right-click on a model element and select Open Specification...from the popup menu. 

 

Figure B.25 - Open specification 
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2. The specification dialog box is displayed. Switch to the Tagged Value Definitions tab. 

 

Figure B.26 - Actor Specification dialog 

3. Click Add. This displays two kind of tag for selection. One is Text Tag and another is Model Element Tag. Click on 
the desired one. 

 

Figure B.27 - Add Tag options 

Adding Text Tag to Model Element 
From the Stereotype Specification dialog box, press Add and then select Text Tag from the popup menu. 

 

Figure B.28 - Add text tag 

This displays a new Tag entry. 

 

Figure B.29 - The new text tag 
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To change the name of the Tag, double click to the Name field and enter a new name. 

 

Figure B.30 - The name of tag 

You can also change the type of Tag from Text to Model Element. To change the type, click on Type field and select a type 
from the popup menu. 

 

Figure B.31 - the type of tag 

To specify a default value of the Tag, double click to the Value field and enter a value. 

 

Figure B.32 - The value of tag 

Adding Model Element Tag to a Model Element 
From the Stereotype Specification dialog box, press Add and then select Model Element Tag from the popup menu. 

 

Figure B.33 - Add Model element Tag 

This displays a new Tag entry. 

 

Figure B.34 - The blank new model element tag 

To change the name of the Tag, double click to the Name field and enter a new name. 

 

Figure B.35 - The name of tag 

You can also change the type of Tag from Text to Model Element. To change the type, click on Type field and select a type 
from the popup menu. 

 

Figure B.36 - The type of tag 
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To specify a default value of the Tag, double click to the Value field and enter a value. 

 

Figure B.37 - The tag value 

Stereotype Formats 

You can configure the formats of stereotypes including fill, line and font, so that stereotyped elements can be easily 
distinguished and emphasized in the diagram. 

Configuring Stereotype Formats 

1. To configure stereotype formats, select menu Tools > Configure Stereotypes....  
2. In the Configure Stereotypes dialog box, select a model type in Model elements and the target stereotype in 

Stereotypes. Click the Edit... button. 

 

Figure B.38 - Configure Stereotype dialog 
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3. The Stereotype Specification is shown. 

 

Figure B.39 - Stereotype Specification dialog 

Applying Fill Color 

1. To apply fill color to stereotype, select the Use checkbox and click the ... button of the Fill  property.  

 

Figure B.40 - Edit fill of stereotype 
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2. Select a fill color in the Format Fill  dialog box and click OK .  

 

Figure B.41 - Format Fill dialog 

Applying Line Style 

1. To apply line style to stereotype, select the Use checkbox and click the ... button of the Line property.  

 

Figure B.42 - Edit line of stereotype 
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2. Configure the line style in the Format Line dialog box and click OK .  

 

Figure B.43 - Format Line dialog 

Applying Font  

1. To apply font to stereotype, select the Use checkbox and click the ... button of the Font property.  

 

Figure B.44 - edit Font 
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2. Select a font in the Select Font dialog box and click OK . 

 

Figure B.45 - Select Font dialog 

After setting a stereotype to a shape, the formats of the stereotype will be applied to the shape immediately. 

 

Figure B.46 - The Modified stereotype 
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Changing Stereotype Formats 

1. Just like configuring stereotype formats, open the 'Configure Stereotypes' dialog box and select a model type in 
Model elements and the target stereotype in Stereotypes. Click the Edit... button to edit its fill, line and font in the 
Stereotype Specification. 

 

Figure B.47 - Edit the format of stereotype 
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2. After changing stereotype formats, it is important that you ensure the 'Apply changes to stereotypes in current 
project' option is selected, otherwise the stereotypes used in the current project will not be updated. 

 

Figure B.48 - apply the change to current project 

3. The appearances of shapes assigned to the changed stereotype are updated. 

 

  

Figure B.49 - Model style updated  
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Appendix C - Supported Mouse Gestures  

General Commands  

    

Layout Diagram  Open Diagram Specification Close Diagram  
Show Diagrams Thumbnail 

View 

Activity Diagram (UML 2.0)   

    

Action  Activity Decision Node  

Initial Node/Final Node 
(If there is no Initial Node, an 
Initial Node will be created. 
Likewise if there is no Final 
Node, a Final Node will be 

created) 

Activity Diagram (UML 1.x)   

    

Action State  Sub-Activity  Swimlane  
Horizontal Synchronization 

Bar 

  

  

Vertical Synchronization Bar 

Initial State/Final State(If 
there is no Initial State, an 
Initial State will be created. 
Likewise if there is no Final 
State, a Final State will be 

created) 

  

Class Diagram  

   

 

Synchronize to ERD Class  Package    

Communication Diagram  

    

Synchronize to Sequence 
Diagram  

Lifeline Actor  Package  
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Component Diagram  

   

 

Component Instance Specification  Package  

Composite Structure Diagram  

    

Class  Interface Collaboration  Collaboration Use 

Deployment Diagram  

    

Node  Component  Node Instance  Package 

EJB Diagram  

    

Synchronize to ERD  Entity Bean  Message-Driven Bean  Session Bean  

 

    

Package      

Entity Relationship Diagram  

  

  

Synchronize to Class Diagram Entity     

Interaction Overview Diagram  

   

 

Interaction Decision Node  

Initial Node/Final Node(If 
there is no Initial Node, an 
Initial Node will be created. 
Likewise if there is no Final 
Node, a Final Node will be 

created) 
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Object Diagram  

   

 

Instance Specification Class  Package    

ORM Diagram  

   

 

Class  Entity Package   

Overview Diagram  

 

    

Diagram Overview      

Package Diagram  

 

    

Package      

Sequence Diagram  

    

Synchronize to 
Communication Diagram 

Lifeline  Actor  Alt Combined Fragment  

 

    

Loop Combined Fragment      

State Machine Diagram (UML 2.0)  

   

 

State  Submachine State 

Initial Node/Final Node(If 
there is no Initial Node, an 
Initial Node will be created. 
Likewise if there is no Final 
Node, a Final Node will be 

created) 
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State Machine Diagram (UML 1.x)  

    

State  Concurrent State Submachine State  
Horizontal Synchronization 

Bar 

  

  

Vertical Synchronization Bar 

Initial State/Final State(If 
there is no Initial State, an 
Initial State will be created. 
Likewise if there is no Final 
State, a Final State will be 

created) 

  

Timing Diagram  

 

    

Frame      

Use Case Diagram  

   

 

Use Case  Actor Package   
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Appendix D - Keyboard Shortcuts  

Action Hot Key  Description  

New Project...  Ctrl-N  
To create either a new UML 1.x or a new UML 2.0 project. The Create New Project dialog box 
will appear, which allows you to create a blank project, a project created from existing project 
templates, or import a project from other CASE tool project files.  

Open Project... Ctrl-O  To open an existing project.  

Save Project Ctrl-S  
To save the current project. If the project is a new one, this operation is equivalent to "Save 
Project as...  

New Diagram... 
Ctrl-Shift-
N 

To create a new diagram. 

Print...  Ctrl-P  
To print selected diagrams in the current project. A new dialog box will be presented, allowing 
you to select the diagrams to be printed, as well as configuring various printing options. 

Undo  Ctrl-Z  To undo the last action that you performed. 

Redo  Ctrl-Y  To redo the last action that you performed. 

Repeat Create... F3 To repeat create last shape. 

Cut  Ctrl-X  
To cut the selected diagram elements from the diagram and copy them to the application 
clipboard.  

Default Copy  Ctrl-C 
To perform the copy action as configured in the VP-UML application options (Options dialog 
box -> Diagramming category -> Environment page). The default "default copy" action is 
Copying within VP-UML. 

Copy to 
Clipboard as OLE 

Ctrl-Shift-
C 

To copy the selected diagram elements from the diagram to the system clipboard. The diagram 
elements can then be pasted to OLE containers like Word, Excel and PowerPoint, which can be 
edited directly. 

Copy to 
Clipboard as 
Image (JPG)  

Ctrl-Alt-C To copy the selected diagram elements as a JPG image to the system clipboard. 

Copy to 
Clipboard as 
Image (EMF)  

Ctrl-Alt-
Shift-C 

To copy the selected diagram elements as an EMF image to the system clipboard. 

Duplicate  Ctrl-E  To duplicate the selected diagram elements. 

Paste View  Ctrl-V  To paste the contents of the application clipboard to the drawing pane.  

Delete  Delete  To delete the selected diagram elements from the diagram. 

Select All  Ctrl-A  To select all the diagram elements from the current diagram. 

Deselect  Ctrl-D  To deselect all diagram elements. 

Find  Ctrl-F  To find elements (model elements and diagram elements) in the current project.  

Jump to Element 
in Active 
Diagram...  

Ctrl-J To jump to an element in the active diagram.  

Jump to 
Element... 

Ctrl-Shift-J  
To jump to an element in the project. If the selected element belongs to a diagram, this diagram 
will be opened, and the element will be selected and centered in the diagram. If the selected 
element is a model that does not have a view, it will be selected in the Model pane.  

Group Ctrl-G  
To organize shapes in group. The group can manipulate related shapes together at the same 
time (select, deselect, move, align and resize).  

Ungroup  
Ctrl-Shift-
G 

To ungroup the grouped shapes in a diagram.  

Align Shapes F12  
To display the Align Shapes dialog box that allows you to configure the top/bottom, left/right 
alignments and same width/same height options all at a time.  

Show Diagram 
Navigator 

Ctrl-Shift-I  To open/activate the Diagram Navigator. 
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Show Model 
Pane  

Ctrl-Shift-
O  

To open/activate the Model Pane. 

Show Class 
Repository  

Ctrl-Shift-
L 

To open/activate the Class Repository Pane.  

Show Logical 
View 

Ctrl-Shift-
A  

To open/activate the Logical View Pane. 

Show ORM Pane  
Ctrl-Shift-
R  

To open/activate the ORM Pane. 

Show Stencil 
Pane  

Ctrl-Shift-
S  

To open/activate the Stencil Pane. 

Show Property 
Pane  

Ctrl-Shift-
P  

To open/activate the Property Pane. 

Show Diagram 
Overview Pane  

Ctrl-Shift-
V 

To open/activate the Diagram Overview Pane.  

Show 
Documentation 
Pane 

Ctrl-Shift-
U  

To open/activate the Documentation Pane. 

Show Message 
Pane  

Ctrl-Shift-
M  

To open/activate the Message Pane. 

Toggle Show 
Resources  

Ctrl-R  To toggle the visibility of resources. 

Full Screen  F11  
To toggle the full screen mode (display only the Toolbar and the Diagram Pane, all the other 
UI components will be hidden).  

Zoom In Ctrl-Equals  To magnify the diagram by 10%.  

Zoom Out Ctrl-Minus  To diminished the diagram by 10%. 

Zoom 100% 
(Actual Size)  

Ctrl-0  To view the diagram in its actual size. 

Previous Diagram Alt-Left  To switch to the previous diagram. 

Next Diagram  Alt-Right  To switch to the next diagram. 

Switch to 
Diagram...  

Ctrl-Shift-
E  

To manage windows by selecting windows to close, and/or activate a selected window.  

Close Active 
Window 

Ctrl-W  To close the active window.  

Close All 
Windows 

Ctrl-Shift-
W  

To close all opened the windows. 

Open 
Specification... 

Enter To open the specification of active diagram or diagram element 

Table D-1 

Classes 

Action Hot Key  Description  

Add Attribute Alt-Shift-A To add a attribute to a currently selected Class 

Add Operation Alt-Shift-O To add an operation to a currently selected Class 

Table D-2 
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Entities 

Action Hot Key  Description  

New Column Alt-Shift-C To add a new column to an currently selected Entity or ResultSet 

Table D-3 



 

Glossary E 
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Appendix E - Glossary 

A   

Activity diagram  

Activity diagrams are an amalgamation of a number of techniques: Jim Odell's event diagrams, SDL state 
modeling techniques, workflow modeling and petri-nets. They can also be considered as variants of state 
diagrams. Activity diagrams are organized according to actions and mainly target towards representing the 
internal behaviors of a method or a use case. They describe the sequencing of activities, with support for 
both conditional and parallel behaviors. 

Actor input  In editing the flow of events, an actor input is the input from an actor to the system. 

Align to grid  Whether diagram elements should align to the grid when being moved. 

Anti-aliasing  A method which handles the staircase pixels of slanted lines and curves to make them look smoother.  

Application 
Options  

The global options in VP-UML. 

Auto save  
VP-UML provides an auto save feature that saves a copy of the current project periodically. If the 
application terminates abnormally, with this feature turned on, when you start VP-UML again the system 
will check if an auto save file exists. If so, it will ask you whether you want to recover the project. 

Automatic 
containment rule 
detection  

A facility to automatically detect the containment rule for a container. For example, an Actor will not be 
contained in the System Boundary even if they are moved into the container's region. 

B   

Backup files 
Every time you save a project a backup file will be created. The backup file name is determined by the 
original project file name, followed by a "~" and the version number. A backup file with a larger version 
number means that it is more recent than those with smaller version numbers.  

Button group 

The diagram toolbar groups some of the diagram elements that are similar in nature together. For example, 
Package and Subsystem are grouped into a single button group. Buttons that are grouped are indicated by a 
small triangle on the lower-right-hand corner. To view the list of items under the group, click on the small 
triangle or click and hold the button until the selection list appears.  

C   

Candidate Class 
Pane 

The candidate class pane, located at the upper-right corner of the textual analysis pane, displays the 
candidate classes as rectangle shapes.  

Candidate class 
view  

In performing textual analysis, the Candidate Class View hides the Problem Statement Editor and only 
displays the Candidate Class Pane and the Data Dictionary Table. It allows you to concentrate on further 
editing of the identified candidate classes, such as specifying the candidate class type or creating models.  

Cascade  Arranges the opened windows diagonally, with the active window on top. 

Class diagram  

Class diagrams are the most common diagrams used for modeling object-oriented systems. They are used 
to describe the types of objects and their relationships by providing a static, structural view of a system. 
They are important not only for visualizing, specifying, and documenting structural models, but also for 
constructing executable systems through forward and reverse engineering.  

Class repository  
A project may contain many classes. The Class Repository View lists all the classes within the current 
project. 

Collaboration 
diagram  

Collaboration diagrams emphasize the organization of objects that are involved in an interaction. 
Collaboration is a mechanism composed of both structural and behavioral elements. Two important 
features - the concept of a path and the sequence number - distinguish collaboration diagrams from 
sequence diagrams. 

Component 
diagram  

Component diagrams show the various components (physical modules of code) in a system and their 
dependencies. A component may often be the same as a package. 

Copy as image  
To copy the selected diagram elements to the system clipboard as an image. This feature is supported in 
both the Windows and the Linux platform. 

Copy to system 
clipboard  

To copy the selected diagram elements to the system clipboard as OLE objects so that the copied content 
can be pasted to OLE containers like Microsoft Word/Excel/PowerPoint, as well as directly edit the OLE 
object inside the document. This feature is supported in the Windows platform only. 
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Copy within VP-
UML  

To copy the selected diagram elements to the application clipboard. You can then paste the diagram 
elements to other VP-UML diagrams. 

D   

Data dictionary 
table  

The data dictionary table, which is located at the lower-right area of the textual analysis pane, provides a 
table view for the candidate classes. It displays all the information of a candidate class. You can edit its 
name and type, as well as adding description to the candidate class.  

Data dictionary 
view 

In performing textual analysis, the Data Dictionary View displays only the Data Dictionary Table. It 
allows you to concentrate on filling the candidate class information in the data dictionary. 

Deployment 
diagram  

Deployment diagrams show the physical layout and relationships among software and hardware 
components in the implemented system. It shows how components and objects are routed and moved 
around a distributed system.  

Diagram base 
layout  

In the print preview pane, if the Fit to Pages option is selected, and there are multiple pages in the printout, 
selecting Diagram Base Layout will cause the distribution of pages to be diagram-oriented. Note that this 
option affects the preview only, the order of the printout remains unchanged. 

Diagram element  A diagram element is a shape or a connector that represent the view of its underlying model element.  

Diagram exporter  The diagram exporter allows you to export selected diagrams as images in JPG, PNG or SVG format.  

Diagram pane  The diagram pane contains the opened diagrams; it allows you edit multiple diagrams at the same time.  

Diagram toolbar 
The diagram toolbar contains the buttons of the diagram elements available for developing the active 
diagram. 

Diagram navigator  
A project may consist of many diagrams. The Diagram Navigator lists all the diagrams within the project. 
Through the use of a folding tree structure, you can browse the names of these diagrams by expanding or 
collapsing the folders and perform sorting by diagram type.  

Document info 
When generating HTML/PDF reports, the document info (such as title, author, keywords) you specified 
becomes the meta data of the report. Users can open the HTML source/PDF document summary to view 
this information. 

Documentation 
pane  

The Documentation pane allows you to enter a description about a diagram or a diagram element. 

E   

Extra Resource-
Centric  

By default, the resource-centric interface displays the most commonly used resources of a diagram 
element. The least commonly used resources are hidden by default, and they are called the extra resources. 

F   

Flow of event A section in the use case description for editing the base paths and the alternative paths in a use case. 

H   

HTML report 
generation 

To generate report for the VP-UML project in HTML format. 

J   

Java-enabled 
platforms 

Any platforms that have Java runtime installed and thus are able to run Java programs. 

L   

Layout diagram  
A feature to layout the shapes so that they do not overlap, and to layout the connectors so that they do not 
cross with one another. 

License key  
The license key is a file that you import using the License Key Manager so that you can start using VP-
UML.  

License Key 
Manager  

The License Key Manager allows you to manage the license key files of Visual Paradigm products.  

Logical View 
The Logical View refers to a user's view of the way project is organized. It provides another view of 
creating, structuring and sharing the UML diagrams and models apart from the traditional Diagram 
Navigator, Model Tree View and Class Repository.  

Look and Feel  The appearance of VP-UML user interface. 
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M   

Message pane  
The message pane logs the messages for the operations that you performed. For example, Java language 
syntax checking, model validation, report generation, etc. 

Model element  
A model element stores the model data. A diagram element associates with a model element, and a model 
element may be associated with more than one diagram element (multiple views). 

Model repository  The repository where the model elements are stored. 

Model tree view  
The Model Tree View lists all the model elements within the current project. Model elements can be 
dragged to appropriate diagrams to create a new diagram element. 

Model validation  A process to validate the models against UML syntax. 

O   

OLE  An object that supports the OLE protocol for object linking and embedding.  

Open specification 
dialog  

The open specification dialog of a diagram allows you to configure the diagram settings, such as the 
diagram name and grid settings; while the open specification dialog of a model element allows you to 
configure its model data.  

ORM Pane  

Display a list of classes and database tables from the specified classpath (s) and database (s). You can 
click Refresh to update the content under Class View and DataBase View whenever there are changes to 
source code or database. You can drag classes or entities onto diagrams and generate source code/database 
from them when necessary. 

P   

Paper base layout  
If the Fit to Pages option is selected, and there are multiple pages in the printout, selecting Paper Base 
Layout will cause the distribution of pages to be paper-oriented (the diagram size is ignored in arranging 
the preview). Note that this option affects the preview only; the order of the printout remains unchanged. 

Paper place style  

To change the order of the printout. Consider a large diagram divided into many pages.  Selecting 'From 
left to right' will arrange the printout order from the pages on the left to the pages on the right, while 
selecting 'From top to bottom' will arrange the print order from the pages on the top to the pages on the 
bottom. 

Pattern watermark  The watermark that repeats the product name diagonally in the printout, exported image or copied content.  

PDF report 
generation 

To generate report for the VP-UML project in PDF format. 

Preview pane  
The Preview pane, also known as the Diagram Monitor, shows an overall view of the diagram. The 
Diagram Monitor allows you to navigate the whole diagram pane when the diagram is larger than the 
display area of the diagram pane.  

Print preview pane  
The print preview pane allows you to configure various print settings, preview the printout and print the 
diagrams.  

Problem statement A description about the problem to investigate.  

Problem statement 
editor 

The problem statement editor is the text editor located on the left of the text analysis pane, which allows 
you to view and edit the problem statement.  

Problem statement 
view 

The Problem Statement View displays the Problem Statement Editor, the Candidate Class Pane and the 
Data Dictionary Table; allows you to concentrate on editing the problem statement. 

Project explorer  
The project explorer pane contains three views: the Diagram Navigator, the Model Tree View, and the 
Class Repository View. Each view shows different perspectives of the project. 

Properties pane  
There are four pages associated with the Properties Pane: the Property page, the Preview page, the 
Documentation page and the Element Viewer page.  

Property pane 
Every diagram and diagram element has its own properties. The Property pane in the Properties Pane 
allows you to view and edit its various properties. 

Q   

Quick Print  Prints diagrams without previewing them; speeds up the print job. 

R   

Realistic 
containment 
interaction 

A specific effect to indicate a diagram element moving in/out of a container. 



SDE User’s Guide (Part 1)  Appendix E - Glossary 

 

E-5 

Reference shape 
for alignment  

When there are multiple shapes selected, the last selected shape will be used as the referenced shape for 
alignment. That is, the alignment methods will be performed based on the position/size of the referenced 
shape. The referenced shape will be rendered with its resize handles surrounded by black rectangles. 

Report Writer  A feature for performing agile report creation. 

Resource-centric  
A user interface based on the Resource-Centric approach is adopted in VP-UML to enable UML diagrams 
to be constructed intuitively with minimal efforts. With the novel interface, only valid editing resources 
are grouped around a graphical entity, totally eliminating invalid operations during diagram construction. 

Rose importer  
The Rose importer allows you to import a Rational Rose project file and convert it into diagrams and 
models in your VP-UML project.  

Round trip 
engineering 

Round trip engineering is the process to convert from diagram to code, and to convert from code to 
diagram. 

S   

Scrollable toolbar  
If you have resized the diagram pane to the extent that some of the buttons on the diagram toolbar are not 
visible, an "Up" button and a "Down" button will appear. You can click on these buttons to scroll up or 
down to the desired buttons on the toolbar. 

Sequence diagram  

Sequence diagram captures the behavior of a single use case and displays a number of example objects, as 
well as the messages that are passed between these objects within the use case from a temporal standpoint. 
There are two important features, the object lifeline and the focus of control, that distinguish them from 
collaborative diagrams.  

Single line 
watermark  

The watermark that prints a single line of the product name in the printout, exported image or copied 
content.  

State diagram 

State diagrams, sometimes referred to as state chart diagrams, are a common technique to describe the 
dynamic behavior of a system. They represent state machines from the perspective of states and 
transitions, describing all the possible states that a particular object can get into and how the object's state 
changes as a result of events that affect the object. In most Object-Oriented techniques, state diagrams are 
drawn for a single class to show the lifetime behaviors of a single object. 

Stencil Pane  

Although the original UML notations are rich, they may still not be expressive enough to represent your 
idea. The stencils in VP-UML provides a large variety of shapes apart from the ordinary UML notations, 
and you can place the stencils in UML diagrams to express your own ideas. The Stencil Pane is a 
repository where imported shapes are stored. 

Stereotype  
The stereotype concept provides a way of classifying (marking) elements so that they behave in some 
respects as if they were instances of new "virtual" metamodel constructs. 

Sub-diagrams  
A facility to associate a diagram with other lower level UML diagrams to facilitate levels of abstraction 
and increase the traceability among UML diagrams. 

System response  In editing the flow of events, this is the response from the system to an actor input. 

T   

Textual analysis 
Textual analysis is a process to analyze the system domain. It helps to identify the candidate classes in a 
problem statement.  

Tile  Arrange the opened windows so that all windows are visible at the diagram pane. 

Tile horizontally  
Arrange the opened windows horizontally. The windows are resized to share the available workspace 
height without overlapping each other.  

Tile vertically 
Arrange the opened windows vertically. The windows are resized to share the available workspace width 
without overlapping each other. 

U   

UML 

The Unified Modeling Language (UML) is a language for specifying, visualizing, constructing, and 
documenting the artifacts of software systems, as well as for business 
modeling and other non-software systems. The UML represents a collection of the best engineering 
practices that have proven to be successful in the modeling of large and complex systems. 

Use case 
description  

A use case description describes the use case, including the preconditions, post-conditions, flow of events, 
etc. 

Use case detail  A use case detail holds one or more use case description.  
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Use case 
diagram  

Use case diagrams, together with activity diagrams, state diagrams, sequence diagrams and collaboration 
diagrams, are the five diagrams in UML for modeling the dynamic aspects of a system. Invented by Ivar 
Jacobson, use case diagrams are central to modeling the behaviors of the system, a sub-system or a class, 
providing a means to visualize, specify and document the behaviors of an element. They describe the behavior 
of a system from a user's perspective by using actions and reactions. A use case shows the relationships between 
actors and objects, and between the system and its environment.  

Use case 
scheduling  

To schedule the use cases by assigning priorities. 

V   

Visio 
integration  

VP-UML allows you to create Visio drawing in UML diagrams. Besides, you can also import Visio stencil into 
VP-UML and use the Visio shape in UML diagrams. 

Visual 
Paradigm 
Suite  

Abbreviated as VP-Suite, Visual Paradigm Suite allows you to install all Visual Paradigm leading CASE Tools. 

X   

XMI 
importer  

The XMI importer imports the models from an XMI file into a VP-UML project. 

Table E.1 


